]> git.pld-linux.org Git - SPECS.git/blob - ffsearch.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / ffsearch.spec
1 Summary:        Fast File Search
2 Summary(pl.UTF-8):      Szybka wyszukiwarka plików
3 Name:           ffsearch
4 Version:        1.1.12
5 Release:        4
6 License:        GPL v2
7 Group:          Applications/WWW
8 Source0:        http://dl.sourceforge.net/ffsearch/%{name}-%{version}.tar.bz2
9 # Source0-md5:  37fd70f94431c70198f5fa2031b4f9ac
10 Source1:        %{name}.crond
11 Patch0:         %{name}-config.patch
12 URL:            http://ffsearch.sourceforge.net/
13 BuildRequires:  rpm-perlprov >= 4.1-13
14 BuildRequires:  rpmbuild(macros) >= 1.202
15 Requires(postun):       /usr/sbin/groupdel
16 Requires(postun):       /usr/sbin/userdel
17 Requires(pre):  /bin/id
18 Requires(pre):  /usr/bin/getgid
19 Requires(pre):  /usr/sbin/groupadd
20 Requires(pre):  /usr/sbin/useradd
21 Requires:       perl-DBD-mysql
22 Requires:       webserver
23 Requires:       webserver(php) >= 4.0.3
24 Provides:       group(ffsearch)
25 Provides:       user(ffsearch)
26 BuildArch:      noarch
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %define         _phpdir         %{_datadir}/%{name}/www
30
31 %description
32 Fast File Search is a crawler for FTP servers and SMB shares that can
33 be found on Windows or UNIX systems running Samba. It provides a web
34 interface for searching files. It is optimized for searching files by
35 a wildcard when there are some normal (not '*' or '?') chars specified
36 in the beginning or in the end of the mask (for example '*.iso').
37
38 %description -l pl.UTF-8
39 Fast File Search (szybka wyszukiwarka plików) jest skryptem
40 zbierającym informacje o udostępnianych zasobach FTP i SMB. Udostępnia
41 przyjemny interfejs WWW do wyszukiwania plików. Jest zoptymalizowana
42 do wyszukiwania plików przez podanie masek plików ze stałą częścią na
43 początku lub końcu nazwy (na przykład *.iso).
44
45 %prep
46 %setup -q
47 %patch0 -p1
48
49 %install
50 rm -rf $RPM_BUILD_ROOT
51 install -d $RPM_BUILD_ROOT{%{_phpdir},%{_sysconfdir}/%{name},%{_datadir}/%{name}/bin,/var/{log/{,archiv/}%{name},lock/%{name}}}
52 rm -rf {bin,flag,lang,htdocs/ffsearch/{,flag,lang},doc}/CVS
53
54 cp -r htdocs/ffsearch/*         $RPM_BUILD_ROOT%{_phpdir}
55 install bin/*                   $RPM_BUILD_ROOT%{_datadir}/%{name}/bin
56 install makedb.pl               $RPM_BUILD_ROOT%{_datadir}/%{name}
57 install %{name}.conf            $RPM_BUILD_ROOT%{_sysconfdir}
58
59 mv $RPM_BUILD_ROOT%{_phpdir}/config.php $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
60 ln -sf %{_sysconfdir}/%{name}/config.php $RPM_BUILD_ROOT%{_phpdir}/config.php
61
62 install -D %{SOURCE1} $RPM_BUILD_ROOT/etc/cron.d/%{name}
63
64 %clean
65 rm -rf $RPM_BUILD_ROOT
66
67 %pre
68 %groupadd -g 118 ffsearch
69 %useradd -u 118 -s /bin/false -g ffsearch -c "Fast File Search user" -d %{_datadir}/ffsearch ffsearch
70
71 %postun
72 if [ "$1" = "0" ]; then
73         %userremove ffsearch
74         %groupremove ffsearch
75 fi
76
77 %files
78 %defattr(644,root,root,755)
79 %doc INSTALL README MAINTAINERS UPGRADE AUTHORS ChangeLog doc/*
80 %attr(750,root,ffsearch) %dir %{_datadir}/%{name}
81 %attr(750,root,ffsearch) %dir %{_datadir}/%{name}/bin
82 %attr(750,root,ffsearch) %{_datadir}/%{name}/bin/*.pl
83 %attr(750,root,ffsearch) %{_datadir}/%{name}/*.pl
84 %attr(640,ffsearch,ffsearch) %verify(not md5 mtime size) %config(noreplace) %{_sysconfdir}/%{name}.conf
85 %attr(640,ffsearch,http) %verify(not md5 mtime size) %config(noreplace) %{_sysconfdir}/%{name}/config.php
86 %{_phpdir}/config.php
87 %attr(750,root,http) %dir %{_phpdir}
88 %attr(640,root,http) %{_phpdir}/a*.php
89 %attr(640,root,http) %{_phpdir}/body.php
90 %attr(640,root,http) %{_phpdir}/browse.php
91 %attr(640,root,http) %{_phpdir}/colors.php
92 %attr(640,root,http) %{_phpdir}/comment*.php
93 %attr(640,root,http) %{_phpdir}/db.php
94 %attr(640,root,http) %{_phpdir}/f*.php
95 %attr(640,root,http) %{_phpdir}/h*.php
96 %attr(640,root,http) %{_phpdir}/index.php
97 %attr(640,root,http) %{_phpdir}/lang.php
98 %attr(640,root,http) %{_phpdir}/menu*.php
99 %attr(640,root,http) %{_phpdir}/s*.php
100 %attr(640,root,http) %{_phpdir}/t*.php
101 %attr(640,root,http) %{_phpdir}/vars.php
102 %attr(640,root,http) %{_phpdir}/*.css
103 %attr(640,root,http) %{_phpdir}/*.gif
104 %attr(640,root,http) %{_phpdir}/*.png
105 %attr(750,root,http) %{_phpdir}/flag
106 %attr(750,root,http) %{_phpdir}/lang
107 %attr(640,root,root) /etc/cron.d/%{name}
108 %attr(750,ffsearch,ffsearch) %dir /var/lock/%{name}
109 %attr(750,ffsearch,ffsearch) %dir /var/log/%{name}
110 %attr(750,ffsearch,ffsearch) %dir /var/log/archive/%{name}
This page took 0.637686 seconds and 3 git commands to generate.