]> git.pld-linux.org Git - packages/ffcall.git/blob - ffcall.spec
- new
[packages/ffcall.git] / ffcall.spec
1 Summary:        Libraries for building foreign function call interfaces
2 Summary(pl):    Biblioteki do tworzenia interfejsów wywo³añ obcych funkcji
3 Name:           ffcall
4 Version:        1.8d
5 Release:        2
6 Epoch:          1
7 License:        GPL
8 Group:          Libraries
9 # original version (1.8):
10 #Source0:       ftp://ftp.ilog.fr/pub/Users/haible/gnu/%{name}-%{version}
11 # version updated for GNUstep project:
12 Source0:        ftp://ftp.gnustep.org/pub/gnustep/libs/%{name}-%{version}.tar.gz
13 URL:            http://www.haible.de/bruno/packages-ffcall.html
14 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16 %description
17 This is a collection of four libraries which can be used to build
18 foreign function call interfaces in embedded interpreters.
19
20 The four packages are:
21 - avcall - calling C functions with variable arguments
22 - vacall - C functions accepting variable argument prototypes
23 - trampoline - closures as first-class C functions
24 - callback - closures with variable arguments as first-class C
25   functions (a reentrant combination of vacall and trampoline)
26
27 This version B includes some minor configuration changes so that files
28 are installed in the proper place. Also it compiles on cygwin and
29 mingw32.
30
31 %description -l pl
32 To jest zestaw czterech bibliotek, których mo¿na u¿yæ do tworzenia
33 interfejsów wywo³añ obcych procedur we wbudowanych interpreterach.
34
35 Te cztery pakiety to:
36 - avcall - wywo³ywanie funkcji w C ze zmiennymi argumentami
37 - vacall - funkcje w C akceptuj±ce prototypy ze zmiennymi argumentami
38 - trampoline - domkniêcia jako funkcje C pierwszej klasy
39 - callback - domkniêcia ze zmiennymi argumentami jako funkcje C
40   pierwszej klasy (zagnie¿d¿alna kombinacja vacall i trampoline)
41
42 Ta wersja B zawiera trochê ma³ych zmian w konfiguracji, dziêki którym
43 pliki instaluj± siê we w³a¶ciwych miejscach. A tak¿e kompiluje siê pod
44 cygwinem i mingw32.
45
46 %package devel
47 Summary:        Development files for ffcall libraries
48 Summary(pl):    Pliki dla programistów u¿ywaj±cych bibliotek ffcall
49 Group:          Development/Libraries
50 Requires:       %{name} = %{version}
51
52 %description devel
53 Development files for ffcall libraries: headers and static trampoline
54 and vacall libraries.
55
56 %description devel -l pl
57 Pliki dla programistów u¿ywaj±cych bibliotek ffcall: nag³ówki i
58 statyczne biblioteki trampoline oraz vacall.
59
60 %package static
61 Summary:        Static versions of avcall and callback libraries
62 Summary(pl):    Statyczne wersje bibliotek avcall i callback
63 Group:          Development/Libraries
64 Requires:       %{name}-devel = %{version}
65
66 %description static
67 Static versions of avcall and callback libraries.
68
69 %description static -l pl
70 Statyczne wersje bibliotek avcall i callback.
71
72 %prep
73 %setup -q
74
75 %build
76 %configure2_13 \
77         --enable-shared
78
79 %{__make}
80
81 %install
82 rm -rf $RPM_BUILD_ROOT
83 install -d $RPM_BUILD_ROOT%{_mandir}
84
85 %{__make} install \
86         DESTDIR=$RPM_BUILD_ROOT
87
88 %clean
89 rm -r $RPM_BUILD_ROOT
90
91 %post   -p /sbin/ldconfig
92 %postun -p /sbin/ldconfig
93
94 %files
95 %defattr(644,root,root,755)
96 %doc ChangeLog NEWS README
97 %attr(755,root,root) %{_libdir}/lib*.so.*.*
98
99 %files devel
100 %defattr(644,root,root,755)
101 %attr(755,root,root) %{_libdir}/lib*.so
102 %{_libdir}/lib*.la
103 %{_libdir}/libtrampoline.a
104 %{_libdir}/libvacall.a
105 %{_includedir}/*
106 %{_mandir}/man?/*
107
108 %files static
109 %defattr(644,root,root,755)
110 %{_libdir}/libavcall.a
111 %{_libdir}/libcallback.a
This page took 0.072709 seconds and 4 git commands to generate.