]> git.pld-linux.org Git - packages/ffcall.git/blob - ffcall.spec
- __make -j1
[packages/ffcall.git] / ffcall.spec
1 Summary:        Libraries for building foreign function call interfaces
2 Summary(pl.UTF-8):      Biblioteki do tworzenia interfejsów wywołań obcych funkcji
3 Name:           ffcall
4 Version:        1.10
5 Release:        1
6 Epoch:          1
7 License:        GPL
8 Group:          Libraries
9 Source0:        ftp://ftp.santafe.edu/pub/gnu/%{name}-%{version}.tar.gz
10 # Source0-md5:  2db95007e901f3bc2ae7e5a9fe9ebea4
11 URL:            http://www.haible.de/bruno/packages-ffcall.html
12 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
13
14 %description
15 This is a collection of four libraries which can be used to build
16 foreign function call interfaces in embedded interpreters.
17
18 The four packages are:
19 - avcall - calling C functions with variable arguments
20 - vacall - C functions accepting variable argument prototypes
21 - trampoline - closures as first-class C functions
22 - callback - closures with variable arguments as first-class C
23   functions (a reentrant combination of vacall and trampoline)
24
25 This version B includes some minor configuration changes so that files
26 are installed in the proper place. Also it compiles on cygwin and
27 mingw32.
28
29 %description -l pl.UTF-8
30 To jest zestaw czterech bibliotek, których można użyć do tworzenia
31 interfejsów wywołań obcych procedur we wbudowanych interpreterach.
32
33 Te cztery pakiety to:
34 - avcall - wywoływanie funkcji w C ze zmiennymi argumentami
35 - vacall - funkcje w C akceptujące prototypy ze zmiennymi argumentami
36 - trampoline - domknięcia jako funkcje C pierwszej klasy
37 - callback - domknięcia ze zmiennymi argumentami jako funkcje C
38   pierwszej klasy (zagnieżdżalna kombinacja vacall i trampoline)
39
40 Ta wersja B zawiera trochę małych zmian w konfiguracji, dzięki którym
41 pliki instalują się we właściwych miejscach. A także kompiluje się pod
42 cygwinem i mingw32.
43
44 %package devel
45 Summary:        Development files for ffcall libraries
46 Summary(pl.UTF-8):      Pliki dla programistów używających bibliotek ffcall
47 Group:          Development/Libraries
48 Requires:       %{name} = %{epoch}:%{version}-%{release}
49
50 %description devel
51 Development files for ffcall libraries: headers and static trampoline
52 and vacall libraries.
53
54 %description devel -l pl.UTF-8
55 Pliki dla programistów używających bibliotek ffcall: nagłówki i
56 statyczne biblioteki trampoline oraz vacall.
57
58 %package static
59 Summary:        Static versions of avcall and callback libraries
60 Summary(pl.UTF-8):      Statyczne wersje bibliotek avcall i callback
61 Group:          Development/Libraries
62 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
63
64 %description static
65 Static versions of avcall and callback libraries.
66
67 %description static -l pl.UTF-8
68 Statyczne wersje bibliotek avcall i callback.
69
70 %prep
71 %setup -q
72
73 %build
74 %configure \
75         --enable-shared
76
77 # with __make -j2:
78 #       make[1]: *** No rule to make target `vacall_r/libvacall.la', needed by `libcallback.la'.  Stop.
79 #       make[1]: *** Waiting for unfinished jobs....
80 %{__make} -j1
81
82 %install
83 rm -rf $RPM_BUILD_ROOT
84 install -d $RPM_BUILD_ROOT%{_mandir}
85
86 %{__make} install \
87         DESTDIR=$RPM_BUILD_ROOT
88
89 %clean
90 rm -r $RPM_BUILD_ROOT
91
92 %post   -p /sbin/ldconfig
93 %postun -p /sbin/ldconfig
94
95 %files
96 %defattr(644,root,root,755)
97 %doc NEWS README
98 %attr(755,root,root) %{_libdir}/lib*.so.*.*
99
100 %files devel
101 %defattr(644,root,root,755)
102 %doc */*.html
103 %attr(755,root,root) %{_libdir}/lib*.so
104 %{_libdir}/lib*.la
105 %{_libdir}/libtrampoline.a
106 %{_libdir}/libvacall.a
107 %{_includedir}/*
108 %{_mandir}/man?/*
109
110 %files static
111 %defattr(644,root,root,755)
112 %{_libdir}/libavcall.a
113 %{_libdir}/libcallback.a
This page took 0.031411 seconds and 3 git commands to generate.