]> git.pld-linux.org Git - SPECS.git/blob - faust.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / faust.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build with tests
4 %bcond_without  tests           # build without tests
5 #
6 Summary:        Faust - Programming Language for Audio Applications and Plugins
7 Name:           faust
8 Version:        2.20.2
9 %define         libsrev 127e5bf
10 Release:        1
11 License:        GPL v2 and BSD
12 Group:          Applications/Multimedia
13 # SF URL: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
14 Source0:        https://github.com/grame-cncm/faust/archive/%{version}/%{name}-%{version}.tar.gz
15 # Source0-md5:  2e4f2db77a1229edf7eb18f14ddd6617
16 Source1:        https://github.com/grame-cncm/faustlibraries/archive/%{libsrev}/%{name}libraries-%{version}-%{libsrev}.tar.gz
17 # Source1-md5:  a0402ea3d24a3fcfb2b8e2e5f251e329
18 Patch0:         libmicrohttpd.patch
19 Patch1:         libdir.patch
20 URL:            https://faust.grame.fr/
21 BuildRequires:  cmake
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %define _noautostrip    .*/.*libsndfile\..*
25
26 %description
27 Faust (Functional Audio Stream) is a functional programming language
28 for sound synthesis and audio processing with a strong focus on
29 the design of synthesizers, musical instruments, audio effects, etc.
30 Faust targets high-performance signal processing applications and
31 audio plug-ins for a variety of platforms and standards.
32
33 %package android
34 Summary:        Faust API support for android
35 Group:          Applications/Multimedia
36
37 %description android
38 Faust API support for android.
39
40 %package devel
41 Summary:        Header files for %{name} library
42 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki %{name}
43 Group:          Development/Libraries
44
45 %description devel
46 Header files for %{name} library.
47
48 %description devel -l pl.UTF-8
49 Pliki nagłówkowe biblioteki %{name}.
50
51 %package static
52 Summary:        Static %{name} library
53 Summary(pl.UTF-8):      Statyczna biblioteka %{name}
54 Group:          Development/Libraries
55 Requires:       %{name}-devel = %{version}-%{release}
56
57 %description static
58 Static %{name} library.
59
60 %description static -l pl.UTF-8
61 Statyczna biblioteka %{name}.
62
63 %prep
64 %setup -q -a1
65 %patch0 -p1
66 %patch1 -p1
67
68 %{__mv} faustlibraries-%{libsrev}*/* libraries/
69 %{__rm} -r faustlibraries-%{libsrev}*
70
71 %{__sed} -E -i -e '1s,#!\s*/usr/bin/env\s+python3(\s|$),#!%{__python3}\1,' \
72       tools/faust2appls/faust2atomsnippets \
73       tools/faust2appls/faust2md
74
75 %{__sed} -E -i -e '1s,#!\s*/usr/bin/env\s+ruby(\s|$),#!%{__ruby}\1,' \
76       tools/faust2sc-1.0.0/faust2sc
77
78 %build
79 CMAKEOPT="\
80         -DCMAKE_VERBOSE_MAKEFILE=ON \
81         -DCMAKE_BUILD_TYPE=%{!?debug:PLD}%{?debug:Debug} \
82         -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
83         -DCMAKE_CXX_FLAGS_PLD='%{rpmcxxflags}' \
84         -DCMAKE_C_FLAGS_PLD='%{rpmcflags}' \
85         -DCMAKE_Fortran_FLAGS_PLD='%{rpmcflags}' \
86         -DCMAKE_EXE_LINKER_FLAGS_PLD='%{rpmldflags}' \
87         -DCMAKE_SHARED_LINKER_FLAGS_PLD='%{rpmldflags}' \
88         -DCMAKE_MODULE_LINKER_FLAGS_PLD='%{rpmldflags}'"
89
90 %{__make} \
91         JOBS=%{?_smp_mflags} \
92         PREFIX=%{_prefix} \
93         LIBSDIR=%{_lib} \
94         CMAKEOPT="$CMAKEOPT"
95
96 %install
97 rm -rf $RPM_BUILD_ROOT
98
99 %{__make} install \
100         PREFIX=%{_prefix} \
101         LIBSDIR=%{_lib} \
102         DESTDIR=$RPM_BUILD_ROOT
103
104 %clean
105 rm -rf $RPM_BUILD_ROOT
106
107 %files
108 %defattr(644,root,root,755)
109 %doc README.md WHATSNEW.md
110 %attr(755,root,root) %{_bindir}/%{name}*
111 %attr(755,root,root) %{_bindir}/encoderunitypackage
112 %attr(755,root,root) %{_bindir}/filename2ident
113 %attr(755,root,root) %{_bindir}/sound2reader
114 %{_datadir}/faust
115 %{_mandir}/man1/faust.1*
116
117 %exclude %{_datadir}/faust/android
118 %exclude %{_datadir}/faust/api/android
119 %exclude %{_datadir}/faust/smartKeyboard/android
120
121 %files android
122 %defattr(644,root,root,755)
123 %{_datadir}/faust/android
124 %{_datadir}/faust/api/android
125 %{_datadir}/faust/smartKeyboard/android
126
127 %files devel
128 %defattr(644,root,root,755)
129 %{_includedir}/faust
130 %{_libdir}/*.a
This page took 1.126255 seconds and 3 git commands to generate.