]> git.pld-linux.org Git - SPECS.git/blob - fasm.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / fasm.spec
1 #
2 # Conditional build:
3 %bcond_without  bootstrap       # don't use included binary
4 #
5 Summary:        Flat asembler
6 Summary(pl.UTF-8):      "Płaski" assembler
7 Name:           fasm
8 Version:        1.66
9 Release:        1
10 License:        distributable
11 Group:          Development/Tools
12 Source0:        http://flatassembler.net/%{name}-%{version}.tgz
13 # Source0-md5:  f5cb8e91bfc53d0a1102790a64c80153
14 URL:            http://flatassembler.net/
15 %if %{without bootstrap}
16 BuildRequires:  fasm
17 %endif
18 ExclusiveArch:  %{ix86}
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 The flat assembler is a fast and efficient self-assembling 80x86
23 assembler for DOS, Windows and Linux operating systems. Currently it
24 supports all 8086-80486/Pentium instructions with MMX, SSE, SSE2, SSE3
25 and 3DNow! extensions, can produce output in binary, MZ, PE, COFF or
26 ELF format. It includes the powerful but easy to use macroinstruction
27 support and does multiple passes to optimize the instruction codes for
28 size. The flat assembler is self-compilable and the full source code
29 is included.
30
31 %description -l pl.UTF-8
32 Płaski asembler jest szybkim i efektywnym, samo-asemblujący się
33 asemblerem 80x86 dla systemów DOS, Windows i Linux. Aktualnie
34 obsługuje wszystkie instrukcje 8086-80486/Pentium z rozszerzeniami
35 MMX, SSE, SSE2, SSE3 i 3DNow!, może produkować programy w formacie
36 binarnym, MZ, PE, COFF lub ELF. Zawiera potężne, ale proste wsparcie
37 dla makroinstrukcji oraz wielokrotnie optymalizuje kod dla rozmiaru.
38 Płaski asembler potrafi sam się skompilować oraz zawiera pełen kod
39 źródłowy.
40
41 %prep
42 %setup -q -n %{name}
43
44 %build
45 %if %{without bootstrap}
46 ASM=%{name}
47 %else
48 ASM=../../%{name}
49 %endif
50 cd source/Linux
51 $ASM %{name}.asm
52 chmod +x %{name}
53
54 %install
55 rm -rf $RPM_BUILD_ROOT
56
57 install -D source/Linux/%{name} $RPM_BUILD_ROOT%{_bindir}/%{name}
58
59 %clean
60 rm -rf $RPM_BUILD_ROOT
61
62 %files
63 %defattr(644,root,root,755)
64 %doc *.txt
65 %attr(755,root,root) %{_bindir}/*
This page took 1.361878 seconds and 3 git commands to generate.