]> git.pld-linux.org Git - packages/farstream.git/blob - farstream.spec
6d0f2bd2ecc5bda4ea27f17fafff5a62d40c6be2
[packages/farstream.git] / farstream.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # do not build and package API docs
4 %bcond_without  static_libs     # don't build static libraries
5
6 Summary:        Audio/Video Communications Framework
7 Summary(pl.UTF-8):      Szkielet komunikacji Audio/Video
8 Name:           farstream
9 Version:        0.2.9
10 Release:        1
11 License:        LGPL v2+
12 Group:          Libraries
13 Source0:        https://freedesktop.org/software/farstream/releases/farstream/%{name}-%{version}.tar.gz
14 # Source0-md5:  35ad6b9e0fb52debeaa2d5194bf5153c
15 Patch0:         %{name}-make.patch
16 URL:            https://www.freedesktop.org/wiki/Software/Farstream
17 BuildRequires:  autoconf >= 2.60
18 BuildRequires:  automake
19 BuildRequires:  glib2-devel >= 1:2.40
20 BuildRequires:  gobject-introspection-devel >= 0.10.1
21 BuildRequires:  gstreamer-devel >= 1.4
22 BuildRequires:  gstreamer-plugins-base-devel >= 1.4
23 BuildRequires:  gtk-doc >= 1.18
24 BuildRequires:  gupnp-igd-devel >= 0.2
25 BuildRequires:  libnice-devel >= 0.1.8
26 BuildRequires:  libtool
27 BuildRequires:  pkgconfig
28 BuildRequires:  python >= 2.1
29 Requires:       glib2 >= 1:2.40
30 Requires:       gstreamer >= 1.4
31 Requires:       gstreamer-plugins-base >= 1.4
32 Requires:       gupnp-igd >= 0.2
33 Requires:       libnice >= 0.1.8
34 Obsoletes:      farsight2 < 0.0.32
35 Obsoletes:      python-farsight2 < 0.0.32
36 Obsoletes:      python-farstream < 0.2.0
37 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39 %description
40 The Farstream (formerly Farsight) project is an effort to create a
41 framework to deal with all known audio/video conferencing protocols.
42 On one side it offers a generic API that makes it possible to write
43 plugins for different streaming protocols, on the other side it offers
44 an API for clients to use those plugins.
45
46 The main target clients for Farstream are Instant Messaging
47 applications. These applications should be able to use Farstream for
48 all their Audio/Video conferencing needs without having to worry about
49 any of the lower level streaming and NAT traversal issues.
50
51 %description -l pl.UTF-8
52 Projekt Farstream (dawniej Farsight) to próba stworzenia szkieletu
53 obsługującego wszystkie znane protokoły konferencji audio/video. Z
54 jednej strony oferuje ogólne API umożliwiające pisanie wtyczek dla
55 różnych protokołów strumieniowych, z drugiej strony oferuje API dla
56 klientów, pozwalającyce im używać tych wtyczek.
57
58 Głównymi klientami szkieletu Farstream mają być aplikacje
59 komunikatorów (IM). Powinny być w stanie używać Farstreama do potrzeb
60 konferencji audio/video bez konieczności obsługi niskopoziomowych
61 poziomów strumieni i omijania NAT-u.
62
63 %package devel
64 Summary:        Header files for Farstream library
65 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Farstream
66 Group:          Development/Libraries
67 Requires:       %{name} = %{version}-%{release}
68 Requires:       glib2-devel >= 1:2.40
69 Requires:       gstreamer-devel >= 1.4
70 Requires:       gstreamer-plugins-base-devel >= 1.4
71 Obsoletes:      farsight2-devel < 0.0.32
72
73 %description devel
74 Header files for Farstream library.
75
76 %description devel -l pl.UTF-8
77 Pliki nagłówkowe biblioteki Farstream.
78
79 %package static
80 Summary:        Static Farstream library
81 Summary(pl.UTF-8):      Statyczna biblioteka Farstream
82 Group:          Development/Libraries
83 Requires:       %{name}-devel = %{version}-%{release}
84 Obsoletes:      farsight2-static < 0.0.32
85
86 %description static
87 Static Farstream library.
88
89 %description static -l pl.UTF-8
90 Statyczna biblioteka Farstream.
91
92 %package apidocs
93 Summary:        Farstream API documentation
94 Summary(pl.UTF-8):      Dokumentacja API biblioteki Farstream
95 Group:          Documentation
96 Requires:       gtk-doc-common
97 Obsoletes:      farsight2-apidocs < 0.0.32
98 %if "%{_rpmversion}" >= "4.6"
99 BuildArch:      noarch
100 %endif
101
102 %description apidocs
103 API documentation for Farstream library.
104
105 %description apidocs -l pl.UTF-8
106 Dokumentacja API biblioteki Farstream.
107
108 %prep
109 %setup -q
110 %patch0 -p1
111
112 %build
113 %{__libtoolize}
114 %{__aclocal} -I m4 -I common/m4
115 %{__autoconf}
116 %{__autoheader}
117 %{__automake}
118 %configure \
119         %{__enable_disable apidocs gtk-doc} \
120         %{__enable_disable static_libs static} \
121         --disable-silent-rules \
122         --with-html-dir=%{_gtkdocdir}
123 %{__make}
124
125 %install
126 rm -rf $RPM_BUILD_ROOT
127
128 %{__make} install \
129         DESTDIR=$RPM_BUILD_ROOT
130
131 %{__rm} $RPM_BUILD_ROOT%{_libdir}/{farstream-0.2,gstreamer-1.0}/*.la
132 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
133
134 %clean
135 rm -rf $RPM_BUILD_ROOT
136
137 %post   -p /sbin/ldconfig
138 %postun -p /sbin/ldconfig
139
140 %files
141 %defattr(644,root,root,755)
142 %doc AUTHORS ChangeLog NEWS README
143 %attr(755,root,root) %{_libdir}/libfarstream-0.2.so.*.*.*
144 %attr(755,root,root) %ghost %{_libdir}/libfarstream-0.2.so.5
145 %{_libdir}/girepository-1.0/Farstream-0.2.typelib
146 %dir %{_libdir}/farstream-0.2
147 %attr(755,root,root) %{_libdir}/farstream-0.2/libmulticast-transmitter.so
148 %attr(755,root,root) %{_libdir}/farstream-0.2/libnice-transmitter.so
149 %attr(755,root,root) %{_libdir}/farstream-0.2/librawudp-transmitter.so
150 %attr(755,root,root) %{_libdir}/farstream-0.2/libshm-transmitter.so
151 %attr(755,root,root) %{_libdir}/gstreamer-1.0/libfsrawconference.so
152 %attr(755,root,root) %{_libdir}/gstreamer-1.0/libfsrtpconference.so
153 %attr(755,root,root) %{_libdir}/gstreamer-1.0/libfsrtpxdata.so
154 %attr(755,root,root) %{_libdir}/gstreamer-1.0/libfsvideoanyrate.so
155 %{_datadir}/farstream
156
157 %files devel
158 %defattr(644,root,root,755)
159 %attr(755,root,root) %{_libdir}/libfarstream-0.2.so
160 %{_datadir}/gir-1.0/Farstream-0.2.gir
161 %{_includedir}/farstream-0.2
162 %{_pkgconfigdir}/farstream-0.2.pc
163
164 %if %{with static_libs}
165 %files static
166 %defattr(644,root,root,755)
167 %{_libdir}/libfarstream-0.2.a
168 %endif
169
170 %if %{with apidocs}
171 %files apidocs
172 %defattr(644,root,root,755)
173 %{_gtkdocdir}/farstream-libs-0.2
174 %{_gtkdocdir}/farstream-plugins-0.2
175 %endif
This page took 0.061506 seconds and 2 git commands to generate.