]> git.pld-linux.org Git - packages/expect.git/blob - expect.spec
- updated to 5.44.1.15
[packages/expect.git] / expect.spec
1 #
2 # BIG FAT WARNING:
3 #       - expect requires mounted /dev/pts to avoid `spawn failed' errors.
4 #
5 Summary:        Tcl expect extension
6 Summary(de.UTF-8):      Tcl-Erweiterung
7 Summary(fr.UTF-8):      Extension Tcl
8 Summary(pl.UTF-8):      Rozszerzenie Tcl expect
9 Summary(ru.UTF-8):      Расширение Tcl для управления программами из скриптов
10 Summary(tr.UTF-8):      Programlar arası etkileşimi mümkün kılan Tcl genişletmesi
11 Summary(uk.UTF-8):      Розширення Tcl для керування програмами зі скриптів
12 Name:           expect
13 Version:        5.44.1.15
14 Release:        1
15 License:        BSD
16 Group:          Development/Languages/Tcl
17 Source0:        http://downloads.sourceforge.net/expect/%{name}-%{version}.tar.bz2
18 # Source0-md5:  9307bbf67e19125036ce34544a78dadf
19 Patch0:         %{name}-pty.patch
20 Patch1:         %{name}-bug7869.patch
21 Patch2:         %{name}-fixcat.patch
22 Patch3:         %{name}-soname.patch
23 URL:            http://expect.nist.gov/
24 BuildRequires:  autoconf
25 BuildRequires:  automake
26 BuildRequires:  tcl-devel >= 8.5.0
27 BuildRequires:  tk-devel >= 8.5.0
28 BuildRequires:  xorg-lib-libX11-devel
29 BuildRequires:  xorg-lib-libXext-devel
30 BuildRequires:  xorg-lib-libXScrnSaver-devel
31 Requires:       tcl >= 8.5.0
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %define         _ulibdir        /usr/lib
35
36 %description
37 Expect is a tool for automating interactive applications such as
38 telnet, ftp, passwd, fsck, rlogin, tip, etc. It makes it easy for a
39 script to control another program and interact with it.
40
41 %description -l pl.UTF-8
42 Expect to narzędzie do automatyzacji interakcji z aplikacjami takimi
43 jak telnet, ftp, passwd, fsck, rlogin, tip itp. Expect pozwala w łatwy
44 sposób przy pomocy skryptu kontrolować inny program.
45
46 %description -l de.UTF-8
47 Expect ist ein Tool zur Automatisierung interaktiver Applikationen wie
48 telnet, ftp, passwd, fsck, rlogin, tip usw. Mit seiner Hilfe kann ein
49 Skript ein anderes Programm sehr leicht steuern oder damit
50 interagieren.
51
52 %description -l fr.UTF-8
53 expect est un un outil pour automatiser les applications interactives
54 comme telnet, ftp, passwd, fsck, rlogin, tip, etc. Il est alors facile
55 pour un script de contrôler un autre programme et d'interagir avec
56 lui.
57
58 %description -l tr.UTF-8
59 Expect telnet, ftp, passwd, fsck, rlogin, tip gibi etkileşimli
60 uygulamaları otomatize etmeye yarayan bir araçtır. Bir uygulamanın bir
61 diğer uygulamayı denetlemesini kolaylaştırır.
62
63 %description -l ru.UTF-8
64 Expect - это инструмент для автоматизации интерактивных программ,
65 таких как telnet, ftp, passwd, fsck, rlogin, tip, и т.п. Позволяет
66 управлять программами и взаимодействовать с ними из скриптов.
67
68 %description -l uk.UTF-8
69 Expect - це інструмент для автоматизації інтерактивних програм, таких
70 як telnet, ftp, passwd, fsck, rlogin, tip, і т.і. Дозволяє керувати
71 програмами та взаємодіяти з ними зі скриптів.
72
73 %package X11
74 Summary:        Tk extension
75 Summary(pl.UTF-8):      Rozszerzenie Tk
76 Group:          Development/Languages/Tcl
77 Requires:       %{name} = %{version}-%{release}
78
79 %description X11
80 This package contains expectk, which is an Tk extension, just as
81 expect Tcl extension.
82
83 %description X11 -l pl.UTF-8
84 Ten pakiet zawiera expectk, który jest rozszerzeniem dla Tk takim jak
85 expect jest dla Tcl.
86
87 %package devel
88 Summary:        Tcl expect extension header files and development documentation
89 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumentacja do rozszerzenia expect języka Tcl
90 Group:          Development/Languages/Tcl
91 Requires:       %{name} = %{version}-%{release}
92 Requires:       tcl-devel >= 8.5.0
93 Obsoletes:      expect-static
94
95 %description devel
96 Tcl expect extension language header files and development
97 documentation.
98
99 %description devel -l pl.UTF-8
100 Pliki nagłówkowe i dokumentacja do rozszerzenia expect języka Tcl.
101
102 %prep
103 %setup -q
104 %patch0 -p1
105 %patch1 -p1
106 %patch2 -p1
107 %patch3 -p1
108
109 chmod +w {.,testsuite}/configure
110
111 %build
112 install /usr/share/automake/config.* .
113 # only local macros, don't call aclocal
114 %{__autoconf}
115 cd testsuite
116 %{__autoconf} -I ..
117 cd ..
118 CFLAGS="%{rpmcflags} -I%{_includedir}/tcl-private/unix"
119 %configure \
120         --enable-gcc \
121         --enable-shared \
122         --with-tclconfig=%{_ulibdir} \
123         --with-tkconfig=%{_ulibdir} \
124         --with-tclinclude=%{_includedir}/tcl-private \
125         --with-tkinclude=%{_includedir}
126
127 %{__make}
128
129 %install
130 rm -rf $RPM_BUILD_ROOT
131
132 LD_LIBRARY_PATH=$RPM_BUILD_ROOT%{_libdir} \
133 %{__make} install \
134         DESTDIR=$RPM_BUILD_ROOT \
135         TCLSH_PROG=tclsh
136
137 mv -f $RPM_BUILD_ROOT%{_bindir}/{rftp,rftp-expect}
138
139 mv -f $RPM_BUILD_ROOT%{_libdir}/expect%{version}/libexpect%{version}.so $RPM_BUILD_ROOT%{_libdir}
140 ln -sf ../libexpect%{version}.so $RPM_BUILD_ROOT%{_libdir}/expect%{version}/libexpect%{version}.so
141 ln -sf libexpect%{version}.so $RPM_BUILD_ROOT%{_libdir}/libexpect.so
142
143 %clean
144 rm -rf $RPM_BUILD_ROOT
145
146 %post   -p /sbin/ldconfig
147 %postun -p /sbin/ldconfig
148
149 %files
150 %defattr(644,root,root,755)
151 %doc ChangeLog FAQ HISTORY NEWS README
152 %attr(755,root,root) %{_bindir}/autoexpect
153 %attr(755,root,root) %{_bindir}/autopasswd
154 %attr(755,root,root) %{_bindir}/cryptdir
155 %attr(755,root,root) %{_bindir}/decryptdir
156 %attr(755,root,root) %{_bindir}/dislocate
157 %attr(755,root,root) %{_bindir}/expect
158 %attr(755,root,root) %{_bindir}/ftp-rfc
159 %attr(755,root,root) %{_bindir}/kibitz
160 %attr(755,root,root) %{_bindir}/lpunlock
161 %attr(755,root,root) %{_bindir}/mkpasswd
162 %attr(755,root,root) %{_bindir}/passmass
163 %attr(755,root,root) %{_bindir}/rftp-expect
164 %attr(755,root,root) %{_bindir}/rlogin-cwd
165 %attr(755,root,root) %{_bindir}/timed-read
166 %attr(755,root,root) %{_bindir}/timed-run
167 %attr(755,root,root) %{_bindir}/unbuffer
168 %attr(755,root,root) %{_bindir}/weather
169 %attr(755,root,root) %{_libdir}/libexpect%{version}.so
170 %dir %{_libdir}/expect%{version}
171 %attr(755,root,root) %{_libdir}/expect%{version}/pkgIndex.tcl
172 %attr(755,root,root) %{_libdir}/expect%{version}/libexpect%{version}.so
173 %{_mandir}/man1/autoexpect.1*
174 %{_mandir}/man1/cryptdir.1*
175 %{_mandir}/man1/decryptdir.1*
176 %{_mandir}/man1/dislocate.1*
177 %{_mandir}/man1/expect.1*
178 %{_mandir}/man1/kibitz.1*
179 %{_mandir}/man1/mkpasswd.1*
180 %{_mandir}/man1/passmass.1*
181 %{_mandir}/man1/unbuffer.1*
182
183 %files X11
184 %defattr(644,root,root,755)
185 %attr(755,root,root) %{_bindir}/expectk
186 %attr(755,root,root) %{_bindir}/multixterm
187 %attr(755,root,root) %{_bindir}/tknewsbiff
188 %attr(755,root,root) %{_bindir}/tkpasswd
189 %attr(755,root,root) %{_bindir}/xkibitz
190 %attr(755,root,root) %{_bindir}/xpstat
191 %{_mandir}/man1/expectk.1*
192 %{_mandir}/man1/multixterm.1*
193 %{_mandir}/man1/tknewsbiff.1*
194 %{_mandir}/man1/xkibitz.1*
195
196 %files devel
197 %defattr(644,root,root,755)
198 %attr(755,root,root) %{_libdir}/libexpect.so
199 %{_includedir}/expect*.h
200 %{_includedir}/tcldbg.h
201 %{_mandir}/man3/libexpect.3*
This page took 0.194273 seconds and 4 git commands to generate.