]> git.pld-linux.org Git - packages/expect.git/blob - expect.spec
71804d1bbb059d89740b7333c5798148ccc6a7b4
[packages/expect.git] / expect.spec
1 #
2 # BIG FAT WARNING:
3 #       - expect requires mounted /dev/pts to avoid `spawn failed' errors.
4 #
5 Summary:        Tcl extension
6 Summary(de.UTF-8):      Tcl-Erweiterung
7 Summary(fr.UTF-8):      Extension Tcl
8 Summary(pl.UTF-8):      Rozszerzenie Tcl
9 Summary(ru.UTF-8):      Расширение Tcl для управления программами из скриптов
10 Summary(tr.UTF-8):      Programlar arası etkileşimi mümkün kılan Tcl genişletmesi
11 Summary(uk.UTF-8):      Розширення Tcl для керування програмами зі скриптів
12 Name:           expect
13 %define major   5.43
14 Version:        %{major}.0
15 Release:        2
16 License:        BSD
17 Group:          Development/Languages/Tcl
18 Source0:        http://expect.nist.gov/src/%{name}-%{version}.tar.gz
19 # Source0-md5:  230400129630335b3060a42f66fec11d
20 Patch0:         %{name}-pty.patch
21 Patch1:         %{name}-alpha.patch
22 Patch2:         %{name}-bug7869.patch
23 Patch3:         %{name}-fixcat.patch
24 Patch4:         %{name}-soname.patch
25 Patch5:         %{name}-lib64.patch
26 Patch6:         %{name}-build.patch
27 Patch7:         %{name}-tcl85.patch
28 URL:            http://expect.nist.gov/
29 BuildRequires:  autoconf
30 BuildRequires:  automake
31 BuildRequires:  tcl-devel >= 8.5.0
32 BuildRequires:  tk-devel >= 8.5.0
33 BuildRequires:  xorg-lib-libX11-devel
34 BuildRequires:  xorg-lib-libXext-devel
35 BuildRequires:  xorg-lib-libXScrnSaver-devel
36 Requires:       tcl >= 8.5.0
37 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39 %define         _ulibdir        /usr/lib
40
41 %description
42 Expect is a tool for automating interactive applications such as
43 telnet, ftp, passwd, fsck, rlogin, tip, etc. It makes it easy for a
44 script to control another program and interact with it.
45
46 %description -l pl.UTF-8
47 Expect to narzędzie do automatyzacji interakcji z aplikacjami takimi
48 jak telnet, ftp, passwd, fsck, rlogin, tip itp. Expect pozwala w łatwy
49 sposób przy pomocy skryptu kontrolować inny program.
50
51 %description -l de.UTF-8
52 Expect ist ein Tool zur Automatisierung interaktiver Applikationen wie
53 telnet, ftp, passwd, fsck, rlogin, tip usw. Mit seiner Hilfe kann ein
54 Skript ein anderes Programm sehr leicht steuern oder damit
55 interagieren.
56
57 %description -l fr.UTF-8
58 expect est un un outil pour automatiser les applications interactives
59 comme telnet, ftp, passwd, fsck, rlogin, tip, etc. Il est alors facile
60 pour un script de contrôler un autre programme et d'interagir avec
61 lui.
62
63 %description -l tr.UTF-8
64 Expect telnet, ftp, passwd, fsck, rlogin, tip gibi etkileşimli
65 uygulamaları otomatize etmeye yarayan bir araçtır. Bir uygulamanın bir
66 diğer uygulamayı denetlemesini kolaylaştırır.
67
68 %description -l ru.UTF-8
69 Expect - это инструмент для автоматизации интерактивных программ,
70 таких как telnet, ftp, passwd, fsck, rlogin, tip, и т.п. Позволяет
71 управлять программами и взаимодействовать с ними из скриптов.
72
73 %description -l uk.UTF-8
74 Expect - це інструмент для автоматизації інтерактивних програм, таких
75 як telnet, ftp, passwd, fsck, rlogin, tip, і т.і. Дозволяє керувати
76 програмами та взаємодіяти з ними зі скриптів.
77
78 %package X11
79 Summary:        Tk extension
80 Summary(pl.UTF-8):      Rozszerzenie Tk
81 Group:          Development/Languages/Tcl
82 Requires:       %{name} = %{version}-%{release}
83
84 %description X11
85 This package contains expectk, which is an Tk extension, just as
86 expect Tcl extension.
87
88 %description X11 -l pl.UTF-8
89 Ten pakiet zawiera expectk, który jest rozszerzeniem dla Tk takim jak
90 expect jest dla Tcl.
91
92 %package devel
93 Summary:        Tcl extension header files and development documentation
94 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumentacja do rozszerzenia języka Tcl
95 Group:          Development/Languages/Tcl
96 Requires:       %{name} = %{version}-%{release}
97 Requires:       tcl-devel >= 8.4.6
98
99 %description devel
100 Tcl extension language header files and develppment documentation.
101
102 %description devel -l pl.UTF-8
103 Pliki nagłówkowe i dokumentacja do rozszerzenie języka Tcl.
104
105 %package static
106 Summary:        Tcl extension static library
107 Summary(pl.UTF-8):      Biblioteka statyczna rozszerzenia języka Tcl
108 Group:          Development/Languages/Tcl
109 Requires:       %{name}-devel = %{version}-%{release}
110
111 %description static
112 Tcl extension language static library.
113
114 %description static -l pl.UTF-8
115 Biblioteka statyczna rozszerzenia języka Tcl.
116
117 %prep
118 %setup -q -n %{name}-%{major}
119 %patch0 -p1
120 %patch1 -p1
121 %patch2 -p1
122 %patch3 -p1
123 %patch4 -p1
124 %if "%{_lib}" == "lib64"
125 %patch5 -p1
126 %endif
127 %patch6 -p1
128 %patch7 -p1
129
130 chmod +w {.,testsuite}/configure
131
132 %build
133 install /usr/share/automake/config.* .
134 # only local macros, don't call aclocal
135 %{__autoconf}
136 cd testsuite
137 cp ../aclocal.m4 .
138 %{__autoconf}
139 cd -
140 CFLAGS="%{rpmcflags} -I%{_includedir}/tcl-private/unix"
141 %configure \
142         --enable-gcc \
143         --enable-shared \
144         --with-tclconfig=%{_ulibdir} \
145         --with-tkconfig=%{_ulibdir} \
146         --with-tclinclude=%{_includedir}/tcl-private \
147         --with-tkinclude=%{_includedir}
148
149 cat expect_cf.h | sed "s|.*SETPGRP_VOID.*|\#define SETPGRP_VOID 1|" > expect_cf.h.new
150 mv -f expect_cf.h{.new,}
151
152 %{__make}
153
154 %install
155 rm -rf $RPM_BUILD_ROOT
156
157 LD_LIBRARY_PATH=$RPM_BUILD_ROOT%{_libdir} \
158 %{__make} install \
159         INSTALL_ROOT=$RPM_BUILD_ROOT
160
161 mv -f $RPM_BUILD_ROOT%{_bindir}/{rftp,rftp-expect}
162
163 ln -sf $(cd $RPM_BUILD_ROOT%{_libdir} ; echo libexpect%{major}.so.*.*) \
164         $RPM_BUILD_ROOT%{_libdir}/libexpect%{major}.so
165 ln -sf $(cd $RPM_BUILD_ROOT%{_libdir} ; echo libexpect%{major}.so.*.*) \
166         $RPM_BUILD_ROOT%{_libdir}/libexpect.so
167
168 %clean
169 rm -rf $RPM_BUILD_ROOT
170
171 %post   -p /sbin/ldconfig
172 %postun -p /sbin/ldconfig
173
174 %files
175 %defattr(644,root,root,755)
176 %attr(755,root,root) %{_bindir}/autoexpect
177 %attr(755,root,root) %{_bindir}/autopasswd
178 %attr(755,root,root) %{_bindir}/cryptdir
179 %attr(755,root,root) %{_bindir}/decryptdir
180 %attr(755,root,root) %{_bindir}/dislocate
181 %attr(755,root,root) %{_bindir}/expect
182 %attr(755,root,root) %{_bindir}/ftp-rfc
183 %attr(755,root,root) %{_bindir}/kibitz
184 %attr(755,root,root) %{_bindir}/lpunlock
185 %attr(755,root,root) %{_bindir}/mkpasswd
186 %attr(755,root,root) %{_bindir}/passmass
187 %attr(755,root,root) %{_bindir}/rftp-expect
188 %attr(755,root,root) %{_bindir}/rlogin-cwd
189 %attr(755,root,root) %{_bindir}/timed-read
190 %attr(755,root,root) %{_bindir}/timed-run
191 %attr(755,root,root) %{_bindir}/unbuffer
192 %attr(755,root,root) %{_bindir}/weather
193 %dir %{_libdir}/expect*
194 %attr(755,root,root) %{_libdir}/expect*/pkgIndex.tcl
195 %attr(755,root,root) %{_libdir}/libexpect*.so.*.*
196 %{_mandir}/man1/autoexpect.*
197 %{_mandir}/man1/cryptdir.*
198 %{_mandir}/man1/decryptdir.*
199 %{_mandir}/man1/dislocate.*
200 %{_mandir}/man1/expect.*
201 %{_mandir}/man1/kibitz.*
202 %{_mandir}/man1/mkpasswd.*
203 %{_mandir}/man1/passmass.*
204 %{_mandir}/man1/unbuffer.*
205
206 %files X11
207 %defattr(644,root,root,755)
208 %attr(755,root,root) %{_bindir}/expectk
209 %attr(755,root,root) %{_bindir}/multixterm
210 %attr(755,root,root) %{_bindir}/tknewsbiff
211 %attr(755,root,root) %{_bindir}/tkpasswd
212 %attr(755,root,root) %{_bindir}/xkibitz
213 %attr(755,root,root) %{_bindir}/xpstat
214 %{_mandir}/man1/expectk.*
215 %{_mandir}/man1/multixterm.*
216 %{_mandir}/man1/tknewsbiff.*
217 %{_mandir}/man1/xkibitz.*
218
219 %files devel
220 %defattr(644,root,root,755)
221 %doc ChangeLog FAQ HISTORY NEWS README
222 %attr(755,root,root) %{_libdir}/libexpect*.so
223 %{_includedir}/*.h
224 %{_mandir}/man3/*
225
226 %files static
227 %defattr(644,root,root,755)
228 %{_libdir}/libexpect*.a
This page took 0.059337 seconds and 3 git commands to generate.