]> git.pld-linux.org Git - SPECS.git/blob - eventum-irc-bot.spec
SPECS updated Tue 30 Apr 15:06:09 CEST 2024
[SPECS.git] / eventum-irc-bot.spec
1 %define         php_min_version 5.6.0
2 Summary:        Eventum IRC Notification Bot
3 Summary(pl.UTF-8):      IRC-owy bot powiadamiający dla Eventum
4 Name:           eventum-irc-bot
5 Version:        1.1.1
6 Release:        1
7 License:        GPL v2+
8 Group:          Networking/Daemons
9 Source0:        https://github.com/eventum/irc-bot/releases/download/v%{version}/irc-bot-v%{version}.tar.xz
10 # Source0-md5:  d2e4a1c5d0df21a559c20cb1b7d2d73b
11 Source1:        eventum-irc.init
12 Source2:        eventum-irc.sysconfig
13 Patch0:         paths.patch
14 URL:            https://github.com/eventum/irc-bot
15 BuildRequires:  tar >= 1:1.22
16 BuildRequires:  xz
17 Requires:       php(sockets)
18 Obsoletes:      eventum-irc < 4.4
19 BuildArch:      noarch
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %define         appdir          %{_datadir}/%{name}
23 %define         confdir         %{_sysconfdir}/%{name}
24
25 %description
26 The IRC notification bot is a nice feature for remote teams that want
27 to handle issues and want to have a quick and easy way to get simple
28 notifications. Right now the bot notifies of the following actions:
29 - New Issues
30 - Blocked emails
31 - Issues that got their assignment list changed
32
33 NOTE: You will need to manually edit the bot.php script to set your
34 appropriate preferences, like IRC server and channel that the bot
35 should join.
36
37 %description -l pl.UTF-8
38 IRC-owy bot powiadamiający to miła funkcjonalność dla zdalnych
39 zespołów chcących obsługiwać sprawy i mieć szybki i łatwy sposób na
40 uzyskiwanie prostych powiadomień. Aktualnie bot powiadamia o
41 następujących zdarzeniach:
42 - nowych sprawach
43 - zablokowanych listach
44 - sprawach, dla których zmieniła się lista powiązań
45
46 UWAGA: w celu wprowadzenia własnych ustawień, takich jak serwer IRC i
47 kanał używany przez bota, trzeba ręcznie zmodyfikować skrypt bot.php .
48
49 %prep
50 %setup -qc
51 mv irc-bot-*/* .
52 mv config/{config.dist.php,config.php}
53 %patch0 -p1
54
55 %install
56 rm -rf $RPM_BUILD_ROOT
57 install -d $RPM_BUILD_ROOT{%{_sbindir},%{appdir},%{confdir}}
58 cp -a bin src vendor $RPM_BUILD_ROOT%{appdir}
59 cp -a config/*.php $RPM_BUILD_ROOT%{confdir}
60 ln -s %{confdir} $RPM_BUILD_ROOT%{appdir}/config
61
62 install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig}
63 install -p %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/eventum-irc
64 cp -p %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/eventum-irc
65
66 %clean
67 rm -rf $RPM_BUILD_ROOT
68
69 %files
70 %defattr(644,root,root,755)
71 %doc README.md
72 %dir %{confdir}
73 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{confdir}/config.php
74 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/eventum-irc
75 %attr(754,root,root) /etc/rc.d/init.d/eventum-irc
76 %attr(755,root,root) %{appdir}/bin/irc-bot.php
77 %dir %{appdir}
78 %dir %{appdir}/bin
79 %{appdir}/config
80 %{appdir}/src
81 %{appdir}/vendor
This page took 1.000281 seconds and 3 git commands to generate.