]> git.pld-linux.org Git - SPECS.git/blob - emotion.spec
SPECS updated Mon 29 Apr 22:05:02 CEST 2024
[SPECS.git] / emotion.spec
1 # NOTE: for versions >= 1.8 see efl.spec, emotion-decoders-generic.spec
2 #
3 # Conditional build:
4 %bcond_without  gstreamer       # don't build gstreamer decoder
5 %bcond_without  vlc             # don't build vlc generic decoder
6 %bcond_without  xine            # don't build xine decoder
7 %bcond_without  static_libs     # don't build static library
8 #
9 %define         ecore_ver       1.7.10
10 %define         edje_ver        1.7.10
11 %define         eet_ver         1.7.10
12 %define         eeze_ver        1.7.10
13 %define         eina_ver        1.7.10
14 %define         eio_ver         1.7.10
15 %define         evas_ver        1.7.10
16
17 Summary:        Emotion - EFL media playback library
18 Summary(pl.UTF-8):      Emotion - biblioteka EFL do odtwarzania multimediów
19 Name:           emotion
20 Version:        1.7.10
21 Release:        3
22 License:        BSD-like
23 Group:          Libraries
24 Source0:        http://download.enlightenment.org/releases/%{name}-%{version}.tar.bz2
25 # Source0-md5:  9a0b2dad190937b68331c38360eb1edb
26 Patch0:         %{name}-am.patch
27 URL:            http://trac.enlightenment.org/e/wiki/Emotion
28 BuildRequires:  autoconf >= 2.60
29 BuildRequires:  automake >= 1.6
30 BuildRequires:  ecore-devel >= %{ecore_ver}
31 BuildRequires:  ecore-evas-devel >= %{ecore_ver}
32 BuildRequires:  ecore-fb-devel >= %{ecore_ver}
33 BuildRequires:  ecore-x-devel >= %{ecore_ver}
34 BuildRequires:  edje >= %{edje_ver}
35 BuildRequires:  edje-devel >= %{edje_ver}
36 BuildRequires:  eet-devel >= %{eet_ver}
37 BuildRequires:  eeze-devel >= %{eeze_ver}
38 BuildRequires:  eio-devel >= %{eio_ver}
39 BuildRequires:  eina-devel >= %{eina_ver}
40 BuildRequires:  evas-devel >= %{evas_ver}
41 %if %{with gstreamer}
42 BuildRequires:  gstreamer0.10-devel >= 0.10.2
43 BuildRequires:  gstreamer0.10-plugins-base-devel >= 0.10.34
44 %endif
45 BuildRequires:  libtool
46 BuildRequires:  pkgconfig >= 1:0.22
47 %{?with_vlc:BuildRequires:      vlc-devel >= 0.9}
48 %{?with_xine:BuildRequires:     xine-lib-devel >= 2:1.1.1}
49 Requires:       ecore >= %{ecore_ver}
50 Requires:       ecore-evas >= %{ecore_ver}
51 Requires:       ecore-fb >= %{ecore_ver}
52 Requires:       ecore-x >= %{ecore_ver}
53 Requires:       edje-libs >= %{edje_ver}
54 Requires:       eet >= %{eet_ver}
55 Requires:       eeze >= %{eeze_ver}
56 Requires:       eina >= %{eina_ver}
57 Requires:       eio >= %{eio_ver}
58 Requires:       evas >= %{evas_ver}
59 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
60
61 %description
62 Emotion is a library to easily integrate media playback into EFL
63 applications, it will take care of using Ecore's main loop and video
64 display is done using Evas.
65
66 %description -l pl.UTF-8
67 Emotion to biblioteka pozwalająca na łatwą integrację odtwarzania
68 multimediów w aplikacjach EFL. Współpracuje z główną pętlą Ecore, a do
69 wyświetlania wykorzystuje bibliotekę Evas.
70
71 %package devel
72 Summary:        Emotion header files
73 Summary(pl.UTF-8):      Pliki nagłówkowe Emotion
74 Group:          Development/Libraries
75 Requires:       %{name} = %{version}-%{release}
76 Requires:       ecore-devel >= %{ecore_ver}
77 Requires:       eio-devel >= %{eio_ver}
78 Requires:       eet-devel >= %{eet_ver}
79 Requires:       eeze-devel >= %{eeze_ver}
80 Requires:       eina-devel >= %{eina_ver}
81 Requires:       evas-devel >= %{evas_ver}
82
83 %description devel
84 Header files for Emotion.
85
86 %description devel -l pl.UTF-8
87 Pliki nagłówkowe Emotion.
88
89 %package static
90 Summary:        Static Emotion library
91 Summary(pl.UTF-8):      Statyczna biblioteka Emotion
92 Group:          Development/Libraries
93 Requires:       %{name}-devel = %{version}-%{release}
94
95 %description static
96 Static Emotion library.
97
98 %description static -l pl.UTF-8
99 Statyczna biblioteka Emotion.
100
101 %package decoder-gstreamer
102 Summary:        Emotion decoder using gstreamer
103 Summary(pl.UTF-8):      Dekoder Emotion używający gstreamera
104 Group:          Development/Libraries
105 Requires:       %{name} = %{version}-%{release}
106 Requires:       gstreamer0.10 >= 0.10.2
107 Requires:       gstreamer0.10-plugins-base >= 0.10.34
108
109 %description decoder-gstreamer
110 Emotion decoder using gstreamer.
111
112 %description decoder-gstreamer -l pl.UTF-8
113 Dekoder Emotion używający gstreamera.
114
115 %package decoder-xine
116 Summary:        Emotion decoder using xine
117 Summary(pl.UTF-8):      Dekoder Emotion używający xine
118 Group:          Development/Libraries
119 Requires:       %{name} = %{version}-%{release}
120 Requires:       xine-lib >= 2:1.1.1
121
122 %description decoder-xine
123 Emotion decoder using xine.
124
125 %description decoder-xine -l pl.UTF-8
126 Dekoder Emotion używający xine.
127
128 %package decoder-vlc
129 Summary:        Emotion decoder using vlc
130 Summary(pl.UTF-8):      Dekoder Emotion używający vlc
131 Group:          Development/Libraries
132 Requires:       %{name} = %{version}-%{release}
133 Requires:       vlc >= 0.9
134
135 %description decoder-vlc
136 Emotion decoder using vlc and Emotion generic plugin.
137
138 %description decoder-vlc -l pl.UTF-8
139 Dekoder Emotion używający vlc i wtyczkę generic biblioteki Emotion.
140
141 %prep
142 %setup -q
143 %patch0 -p1
144
145 %build
146 %{__libtoolize}
147 %{__aclocal} -I m4
148 %{__autoconf}
149 %{__autoheader}
150 %{__automake}
151 %configure \
152         --disable-silent-rules \
153         %{!?with_static_libs:--disable-static} \
154         %{!?with_vlc:--disable-generic-vlc} \
155         %{!?with_gstreamer:--disable-gstreamer} \
156         %{!?with_xine:--disable-xine}
157 %{__make}
158
159 %install
160 rm -rf $RPM_BUILD_ROOT
161
162 %{__make} install \
163         DESTDIR=$RPM_BUILD_ROOT
164
165 %{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/*.la \
166         $RPM_BUILD_ROOT%{_libdir}/edje/modules/emotion/linux-gnu-*/*.la
167
168 %if %{without vlc}
169 # dir not installed if vlc module not installed
170 install -d $RPM_BUILD_ROOT%{_libdir}/%{name}/utils
171 %endif
172
173 %clean
174 rm -rf $RPM_BUILD_ROOT
175
176 %post   -p /sbin/ldconfig
177 %postun -p /sbin/ldconfig
178
179 %files
180 %defattr(644,root,root,755)
181 %doc AUTHORS COPYING ChangeLog README TODO
182 %attr(755,root,root) %{_bindir}/emotion_test
183 %attr(755,root,root) %{_libdir}/libemotion.so.*.*.*
184 %attr(755,root,root) %ghost %{_libdir}/libemotion.so.1
185 %dir %{_libdir}/%{name}
186 %attr(755,root,root) %{_libdir}/%{name}/em_generic.so
187 %dir %{_libdir}/%{name}/utils
188 %dir %{_libdir}/edje/modules/emotion
189 %dir %{_libdir}/edje/modules/emotion/linux-gnu-*
190 %attr(755,root,root) %{_libdir}/edje/modules/emotion/linux-gnu-*/module.so
191 %{_datadir}/%{name}
192
193 %files devel
194 %defattr(644,root,root,755)
195 %attr(755,root,root) %{_libdir}/libemotion.so
196 %{_libdir}/libemotion.la
197 %{_includedir}/emotion-1
198 %{_pkgconfigdir}/emotion.pc
199
200 %if %{with static_libs}
201 %files static
202 %defattr(644,root,root,755)
203 %{_libdir}/libemotion.a
204 %endif
205
206 %if %{with gstreamer}
207 %files decoder-gstreamer
208 %defattr(644,root,root,755)
209 %attr(755,root,root) %{_libdir}/%{name}/gstreamer.so
210 %endif
211
212 %if %{with xine}
213 %files decoder-xine
214 %defattr(644,root,root,755)
215 %attr(755,root,root) %{_libdir}/%{name}/xine.so
216 %endif
217
218 %if %{with vlc}
219 %files decoder-vlc
220 %defattr(644,root,root,755)
221 %attr(755,root,root) %{_libdir}/%{name}/utils/em_generic_vlc
222 %endif
This page took 0.108124 seconds and 3 git commands to generate.