]> git.pld-linux.org Git - packages/ekg2.git/blob - ekg2.spec
added gcc-c++ BR as configure is looking for cc1plus file
[packages/ekg2.git] / ekg2.spec
1 #
2 # Conditional build:
3 %bcond_with     yesterday_snapshot      # Build most current ekg2 snapshot
4                                         # (must use ./builder -n5 or plain rpmbuild)
5 %bcond_without  aspell                  # Don't build in spell-checking support with aspell
6 %bcond_with     ioctl_daemon            # With (suid-root) ioctl daemon
7
8 %if %{with yesterday_snapshot}
9 %define         _snap %(date +%%Y%%m%%d -d yesterday)
10 %else
11 %define         _snap 20040817
12 %endif
13
14 Summary:        A client compatible with Gadu-Gadu
15 Summary(de):    Einen client kompatibel zu Gadu-Gadu
16 Summary(it):    Esperimentale cliente di Gadu-Gadu
17 Summary(pl):    Eksperymentalny Klient Gadu-Gadu
18 Name:           ekg2
19 Version:        2.0
20 Release:        0.%{_snap}.1
21 License:        GPL v2+
22 Group:          Applications/Communications
23 Source0:        http://www.ekg2.org/archive/%{name}-%{_snap}.tar.gz
24 # Source0-md5:  0dc34153b9121a790ef99927e6e61922
25 URL:            http://www.ekg2.org/
26 BuildRequires:  libgadu-devel
27 BuildRequires:  libgsm-devel
28 BuildRequires:  ncurses-devel
29 BuildRequires:  openssl-devel >= 0.9.7d
30 BuildRequires:  gpm-devel
31 BuildRequires:  expat-devel
32 BuildRequires:  libjpeg-devel
33 BuildRequires:  gcc-c++
34 %{?with_aspell:BuildRequires:   aspell-devel}
35 BuildRequires:  gnutls-devel
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %description
39 A client compatible with Gadu-Gadu and Jabber.
40
41 %description -l de
42 Einen client kompatibel zu Gadu-Gadu und Jabber.
43
44 %description -l it
45 Esperimentale cliente di Gadu-Gadu.
46
47 %description -l pl
48 Eksperymentalny Klient Gadu-Gadu. W wersji drugiej obs³uguje zarówno
49 Gadu-Gadu jak i Jabbera. Planowana tak¿e obs³uga ICQ.
50
51 %prep
52 %setup -q -n %{name}-%{_snap}
53
54 %build
55 %configure \
56         --with%{!?with_aspell:out}-aspell
57 %{__make}
58
59 %install
60 rm -rf $RPM_BUILD_ROOT
61
62 %{__make} install \
63         DESTDIR=$RPM_BUILD_ROOT
64 %{!?with_ioctl_daemon:rm $RPM_BUILD_ROOT%{_libdir}/%{name}/plugins/ioctld.*}
65
66 rm -rf docs/{CVS,.cvsignore,Makefile*}
67 mv -f README README-main
68
69 %clean
70 rm -rf $RPM_BUILD_ROOT
71
72 %files
73 %defattr(644,root,root,755)
74 %doc NEWS* README-main docs/*
75 %attr(755,root,root) %{_bindir}/*
76 %dir %{_libdir}/%{name}
77 %dir %{_libdir}/%{name}/plugins
78 %attr(755,root,root) %{_libdir}/%{name}/plugins/*.so
79 %{?with_ioctl_daemon:%attr(4755,root,root) %{_libdir}/ioctld}
80 %{_datadir}/%{name}
This page took 0.066485 seconds and 4 git commands to generate.