]> git.pld-linux.org Git - packages/ekg2.git/blob - ekg2.spec
- BR sed 4.0
[packages/ekg2.git] / ekg2.spec
1 #
2 # Conditional build:
3 %bcond_with     yesterday_snapshot      # Build most current ekg2 snapshot
4                                         # (must use ./builder -n5 or plain rpmbuild)
5 %bcond_without  aspell                  # Don't build in spell-checking support with aspell
6 %bcond_without  xosd                    # Don't build xosd plugin
7 %bcond_with     ioctl_daemon            # With (suid-root) ioctl daemon
8
9 %if %{with yesterday_snapshot}
10 %define         _snap %(date +%%Y%%m%%d -d yesterday)
11 %else
12 %define         _snap 20041110
13 %endif
14
15 Summary:        A client compatible with Gadu-Gadu
16 Summary(de):    Einen client kompatibel zu Gadu-Gadu
17 Summary(it):    Esperimentale cliente di Gadu-Gadu
18 Summary(pl):    Eksperymentalny Klient Gadu-Gadu
19 Name:           ekg2
20 Version:        2.0
21 Release:        0.%{_snap}.1
22 License:        GPL v2+
23 Group:          Applications/Communications
24 Source0:        http://www.ekg2.org/archive/%{name}-%{_snap}.tar.gz
25 # Source0-md5:  172ba865b4f77265b68a4bf62d74812e
26 URL:            http://www.ekg2.org/
27 %{?with_aspell:BuildRequires:   aspell-devel}
28 BuildRequires:  autoconf
29 BuildRequires:  automake
30 BuildRequires:  expat-devel
31 BuildRequires:  gettext-devel
32 BuildRequires:  gnutls-devel >= 1.0.0
33 BuildRequires:  gpm-devel
34 BuildRequires:  libgadu-devel
35 BuildRequires:  libgsm-devel
36 BuildRequires:  libjpeg-devel
37 BuildRequires:  libltdl-devel
38 BuildRequires:  libtool
39 BuildRequires:  ncurses-devel
40 BuildRequires:  openssl-devel >= 0.9.7d
41 BuildRequires:  sed >= 4.0
42 %{?with_xosd:BuildRequires:     xosd-devel}
43 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
44
45 %description
46 A client compatible with Gadu-Gadu and Jabber.
47
48 %description -l de
49 Einen client kompatibel zu Gadu-Gadu und Jabber.
50
51 %description -l it
52 Esperimentale cliente di Gadu-Gadu.
53
54 %description -l pl
55 Eksperymentalny Klient Gadu-Gadu. W wersji drugiej obs³uguje zarówno
56 Gadu-Gadu jak i Jabbera. Planowana tak¿e obs³uga ICQ.
57
58 %prep
59 %setup -q -n %{name}-%{_snap}
60
61 sed -i -e 's/AC_LIBLTDL_CONVENIENCE/AC_LIBLTDL_INSTALLABLE/' configure.ac
62
63 %build
64 %{__libtoolize} --ltdl
65 cd libltdl
66 %{__aclocal}
67 %{__autoconf}
68 %{__autoheader}
69 %{__automake}
70 cd ..
71 %{__aclocal} -I m4
72 %{__autoconf}
73 %{__autoheader}
74 %{__automake}
75 %configure \
76         --with%{!?with_aspell:out}-aspell \
77         --with%{!?with_xosd:out}-xosd
78         
79 %{__make}
80
81 %install
82 rm -rf $RPM_BUILD_ROOT
83
84 %{__make} install \
85         DESTDIR=$RPM_BUILD_ROOT
86 %{!?with_ioctl_daemon:rm $RPM_BUILD_ROOT%{_libdir}/%{name}/plugins/ioctld.*}
87
88 rm -rf docs/{CVS,.cvsignore,Makefile*}
89 mv -f README README-main
90
91 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/plugins/*.la
92
93 %find_lang %{name}
94
95 %clean
96 rm -rf $RPM_BUILD_ROOT
97
98 %files -f %{name}.lang
99 %defattr(644,root,root,755)
100 %doc NEWS* README-main docs/*
101 %attr(755,root,root) %{_bindir}/*
102 %dir %{_libdir}/%{name}
103 %dir %{_libdir}/%{name}/plugins
104 %attr(755,root,root) %{_libdir}/%{name}/plugins/*.so
105 %{?with_ioctl_daemon:%attr(4755,root,root) %{_libdir}/ioctld}
106 %{_datadir}/%{name}
This page took 0.041395 seconds and 4 git commands to generate.