]> git.pld-linux.org Git - packages/ekg2.git/blob - ekg2.spec
- Update to current snapshot
[packages/ekg2.git] / ekg2.spec
1 #
2 # Conditional build:
3 %bcond_with     yesterday_snapshot      # Build most current ekg2 snapshot
4                                         # (must use ./builder -n5 or plain rpmbuild)
5 %bcond_without  aspell                  # Don't build in spell-checking support with aspell
6 %bcond_with     ioctl_daemon            # With (suid-root) ioctl daemon
7
8 %if %{with yesterday_snapshot}
9 %define         _snap %(date +%%Y%%m%%d -d yesterday)
10 %else
11 %define         _snap 20041108
12 %endif
13
14 Summary:        A client compatible with Gadu-Gadu
15 Summary(de):    Einen client kompatibel zu Gadu-Gadu
16 Summary(it):    Esperimentale cliente di Gadu-Gadu
17 Summary(pl):    Eksperymentalny Klient Gadu-Gadu
18 Name:           ekg2
19 Version:        2.0
20 Release:        0.%{_snap}.1
21 License:        GPL v2+
22 Group:          Applications/Communications
23 Source0:        http://www.ekg2.org/archive/%{name}-%{_snap}.tar.gz
24 # Source0-md5:  e40382711d5f5b894c75b55e6b54845d
25 URL:            http://www.ekg2.org/
26 %{?with_aspell:BuildRequires:   aspell-devel}
27 BuildRequires:  autoconf
28 BuildRequires:  automake
29 BuildRequires:  expat-devel
30 BuildRequires:  gettext-devel
31 BuildRequires:  gnutls-devel >= 1.0.0
32 BuildRequires:  gpm-devel
33 BuildRequires:  libgadu-devel
34 BuildRequires:  libgsm-devel
35 BuildRequires:  libjpeg-devel
36 BuildRequires:  libltdl-devel
37 BuildRequires:  libtool
38 BuildRequires:  ncurses-devel
39 BuildRequires:  openssl-devel >= 0.9.7d
40 BuildRequires:  xosd-devel
41 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
42
43 %description
44 A client compatible with Gadu-Gadu and Jabber.
45
46 %description -l de
47 Einen client kompatibel zu Gadu-Gadu und Jabber.
48
49 %description -l it
50 Esperimentale cliente di Gadu-Gadu.
51
52 %description -l pl
53 Eksperymentalny Klient Gadu-Gadu. W wersji drugiej obs³uguje zarówno
54 Gadu-Gadu jak i Jabbera. Planowana tak¿e obs³uga ICQ.
55
56 %prep
57 %setup -q -n %{name}-%{_snap}
58
59 %{__perl} -pi -e 's/AC_LIBLTDL_CONVENIENCE/AC_LIBLTDL_INSTALLABLE/' configure.ac
60
61 %build
62 %{__libtoolize} --ltdl
63 cd libltdl
64 %{__aclocal}
65 %{__autoconf}
66 %{__autoheader}
67 %{__automake}
68 cd ..
69 %{__aclocal} -I m4
70 %{__autoconf}
71 %{__autoheader}
72 %{__automake}
73 %configure \
74         --with%{!?with_aspell:out}-aspell
75 %{__make}
76
77 %install
78 rm -rf $RPM_BUILD_ROOT
79
80 %{__make} install \
81         DESTDIR=$RPM_BUILD_ROOT
82 %{!?with_ioctl_daemon:rm $RPM_BUILD_ROOT%{_libdir}/%{name}/plugins/ioctld.*}
83
84 rm -rf docs/{CVS,.cvsignore,Makefile*}
85 mv -f README README-main
86
87 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/plugins/*.la
88
89 %find_lang %{name}
90
91 %clean
92 rm -rf $RPM_BUILD_ROOT
93
94 %files -f %{name}.lang
95 %defattr(644,root,root,755)
96 %doc NEWS* README-main docs/*
97 %attr(755,root,root) %{_bindir}/*
98 %dir %{_libdir}/%{name}
99 %dir %{_libdir}/%{name}/plugins
100 %attr(755,root,root) %{_libdir}/%{name}/plugins/*.so
101 %{?with_ioctl_daemon:%attr(4755,root,root) %{_libdir}/ioctld}
102 %{_datadir}/%{name}
This page took 0.287577 seconds and 4 git commands to generate.