]> git.pld-linux.org Git - packages/ecryptfs-utils.git/blob - ecryptfs-utils.spec
rebuild with openssl 3.0.0
[packages/ecryptfs-utils.git] / ecryptfs-utils.spec
1 #
2 # Conditional build:
3 %bcond_with     gui             # GTK+ GUI components (non-existing as of 111)
4 %bcond_without  static_libs     # static library
5 #
6 Summary:        The eCryptfs mount helper and support libraries
7 Summary(pl.UTF-8):      Narzędzie pomocnicze i biblioteki do montowania eCryptfs
8 Name:           ecryptfs-utils
9 Version:        111
10 Release:        4
11 License:        GPL v2+
12 Group:          Base
13 #Source0Download: https://launchpad.net/ecryptfs/+download
14 Source0:        https://launchpad.net/ecryptfs/trunk/%{version}/+download/%{name}_%{version}.orig.tar.gz
15 # Source0-md5:  83513228984f671930752c3518cac6fd
16 Patch0:         %{name}-sh.patch
17 Patch1:         %{name}-83-fixsalt.patch
18 Patch2:         %{name}-83-splitnss.patch
19 Patch3:         %{name}-84-fixsigness.patch
20 Patch4:         openssl.patch
21 URL:            http://ecryptfs.org/
22 BuildRequires:  autoconf >= 2.59
23 BuildRequires:  automake
24 BuildRequires:  gettext-tools
25 BuildRequires:  glib2-devel >= 2.0
26 BuildRequires:  gpgme-devel
27 %{?with_gui:BuildRequires:      gtk+2-devel >= 2.0}
28 BuildRequires:  intltool >= 0.41.0
29 BuildRequires:  keyutils-devel >= 1.0
30 BuildRequires:  libtool
31 BuildRequires:  nss-devel >= 3
32 BuildRequires:  openssl-devel >= 0.9.7
33 BuildRequires:  pam-devel
34 BuildRequires:  perl-tools-pod
35 BuildRequires:  pkcs11-helper-devel >= 1.04
36 BuildRequires:  pkgconfig
37 BuildRequires:  python-devel >= 1:2.5
38 BuildRequires:  python-modules >= 1:2.5
39 BuildRequires:  rpm-pythonprov
40 BuildRequires:  rpmbuild(macros) >= 1.219
41 BuildRequires:  swig >= 1.3.31
42 BuildRequires:  swig-python >= 1.3.31
43 BuildRequires:  trousers-devel
44 Requires:       uname(release) >= 2.6.19
45 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
46
47 # python module
48 %define         skip_post_check_so      _libecryptfs.so.0.0.0
49
50 %description
51 eCryptfs is a stacked cryptographic filesystem that ships in Linux
52 kernel versions 2.6.19 and above. This package provides the mount
53 helper and supporting libraries to perform key management and mount
54 functions.
55
56 Install ecryptfs-utils if you would like to mount eCryptfs.
57
58 %description -l pl.UTF-8
59 eCryptfs to stakowalny kryptograficzny system plików dostępny w jądrze
60 Linuksa od wersji 2.6.19. Ten pakiet udostępnia narzędzie pomocnicze
61 dla programu mount oraz wspierające je biblioteki wykonujące
62 zarządzanie kluczami i funkcje związane z montowaniem.
63
64 Pakiet ecryptfs-utils należy zainstalować, aby montować eCryptfs.
65
66 %package devel
67 Summary:        The eCryptfs userspace development package
68 Summary(pl.UTF-8):      Pakiet programistyczny przestrzeni użytkownika dla eCryptfs
69 Group:          Development/Libraries
70 Requires:       %{name} = %{version}-%{release}
71 Requires:       keyutils-devel >= 1.0
72 Requires:       nss-devel >= 3
73
74 %description devel
75 Userspace development files for eCryptfs.
76
77 %description devel -l pl.UTF-8
78 Pliki programistyczne przestrzeni użytkownika dla eCryptfs.
79
80 %package static
81 Summary:        Static eCryptfs library
82 Summary(pl.UTF-8):      Statyczna biblioteka eCryptfs
83 Group:          Development/Libraries
84 Requires:       %{name}-devel = %{version}-%{release}
85
86 %description static
87 Static eCryptfs library.
88
89 %description static -l pl.UTF-8
90 Statyczna biblioteka eCryptfs.
91
92 %package -n pam-pam_ecryptfs
93 Summary:        eCryptfs PAM module
94 Summary(pl.UTF-8):      Moduł PAM eCryptfs
95 Group:          Base
96 Requires:       %{name} = %{version}-%{release}
97
98 %description -n pam-pam_ecryptfs
99 eCryptfs PAM module.
100
101 %description -n pam-pam_ecryptfs -l pl.UTF-8
102 Moduł PAM eCryptfs.
103
104 %package -n python-ecryptfs
105 Summary:        Python bindings for the eCryptfs utils
106 Summary(pl.UTF-8):      Wiązania Pythona do narzędzi eCryptfs
107 Group:          Libraries/Python
108 Requires:       %{name} = %{version}-%{release}
109 Obsoletes:      ecryptfs-utils-python
110
111 %description -n python-ecryptfs
112 This package contains a module that permits applications written in
113 the Python programming language to use the interface supplied by the
114 ecryptfs-utils library.
115
116 %description -n python-ecryptfs -l pl.UTF-8
117 Ten pakiet zawiera moduł pozwalający aplikacjom napisanym w Pythonie
118 na korzystanie z interfejsu dostarczanego przez bibliotekę
119 ecryptfs-utils.
120
121 %prep
122 %setup -q
123 %patch0 -p1
124 %patch1 -p1
125 %patch2 -p1
126 %patch3 -p1
127 %patch4 -p1
128
129 %build
130 %{__libtoolize}
131 %{__aclocal} -I m4
132 %{__autoconf}
133 %{__autoheader}
134 %{__automake}
135 %configure \
136         --enable-gpg \
137         %{?with_gui:--enable-gui} \
138         --enable-nss \
139         --enable-openssl \
140         --enable-pam \
141         --enable-pkcs11-helper \
142         --enable-tspi \
143         %{?with_static_libs:--enable-static}
144
145 %{__make}
146
147 %install
148 rm -rf $RPM_BUILD_ROOT
149
150 %{__make} -j1 install \
151         DESTDIR=$RPM_BUILD_ROOT
152
153 # obsoleted by pkg-config
154 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libecryptfs.la
155
156 %{__rm} $RPM_BUILD_ROOT%{py_sitedir}/%{name}/_libecryptfs.la \
157         %{?with_static_libs:$RPM_BUILD_ROOT%{py_sitedir}/%{name}/_libecryptfs.a}
158 %py_postclean
159
160 %find_lang %{name}
161
162 %clean
163 rm -rf $RPM_BUILD_ROOT
164
165 %pre
166 %groupadd -g 260 ecryptfs
167
168 %postun
169 /sbin/ldconfig
170 if [ "$1" = "0" ]; then
171         %groupremove ecryptfs
172 fi
173
174 %post   -p /sbin/ldconfig
175
176 %files -f %{name}.lang
177 %defattr(644,root,root,755)
178 %doc AUTHORS ChangeLog NEWS README THANKS doc/{ecryptfs-faq.html,ecryptfs-pkcs11-helper-doc.txt}
179 %attr(755,root,root) /sbin/mount.ecryptfs
180 %attr(4754,root,ecryptfs) /sbin/mount.ecryptfs_private
181 %attr(755,root,root) /sbin/umount.ecryptfs_private
182 %attr(755,root,root) /sbin/umount.ecryptfs
183 %attr(755,root,root) %{_bindir}/ecryptfs-*
184 %attr(755,root,root) %{_bindir}/ecryptfsd
185 %attr(755,root,root) %{_libdir}/libecryptfs.so.*.*.*
186 %attr(755,root,root) %ghost %{_libdir}/libecryptfs.so.1
187 %dir %{_libdir}/ecryptfs
188 %attr(755,root,root) %{_libdir}/ecryptfs/libecryptfs_key_mod_gpg.so
189 %attr(755,root,root) %{_libdir}/ecryptfs/libecryptfs_key_mod_openssl.so
190 %attr(755,root,root) %{_libdir}/ecryptfs/libecryptfs_key_mod_passphrase.so
191 %attr(755,root,root) %{_libdir}/ecryptfs/libecryptfs_key_mod_pkcs11_helper.so
192 %attr(755,root,root) %{_libdir}/ecryptfs/libecryptfs_key_mod_tspi.so
193 %{_datadir}/%{name}
194 %{_mandir}/man1/ecryptfs-*.1*
195 %{_mandir}/man1/mount.ecryptfs_private.1*
196 %{_mandir}/man1/umount.ecryptfs_private.1*
197 %{_mandir}/man7/ecryptfs.7*
198 %{_mandir}/man8/ecryptfs-*.8*
199 %{_mandir}/man8/ecryptfsd.8*
200 %{_mandir}/man8/mount.ecryptfs.8*
201 %{_mandir}/man8/umount.ecryptfs.8*
202
203 %files devel
204 %defattr(644,root,root,755)
205 %attr(755,root,root) %{_libdir}/libecryptfs.so
206 %{_includedir}/ecryptfs.h
207 %{_pkgconfigdir}/libecryptfs.pc
208
209 %if %{with static_libs}
210 %files static
211 %defattr(644,root,root,755)
212 %{_libdir}/libecryptfs.a
213 %endif
214
215 %files -n pam-pam_ecryptfs
216 %defattr(644,root,root,755)
217 %attr(755,root,root) /%{_lib}/security/pam_ecryptfs.so
218 %{_mandir}/man8/pam_ecryptfs.8*
219
220 %files -n python-ecryptfs
221 %defattr(644,root,root,755)
222 %dir %{py_sitedir}/%{name}
223 %attr(755,root,root) %{py_sitedir}/%{name}/_libecryptfs.so*
224 %dir %{py_sitescriptdir}/%{name}
225 %{py_sitescriptdir}/%{name}/*.py[co]
This page took 0.075771 seconds and 3 git commands to generate.