]> git.pld-linux.org Git - packages/dpkg.git/blob - dpkg.spec
c3a1cb86fe29575da70fa7cd398d9fe45a837ee9
[packages/dpkg.git] / dpkg.spec
1 %include        /usr/lib/rpm/macros.perl
2 Summary:        Package maintenance system for Debian Linux
3 Summary(pl.UTF-8):      Program do obsługi pakietów Debiana
4 Name:           dpkg
5 Version:        1.16.10
6 Release:        2
7 License:        GPL v2+
8 Group:          Applications/File
9 Source0:        ftp://ftp.debian.org/debian/pool/main/d/dpkg/%{name}_%{version}.tar.xz
10 # Source0-md5:  a20a06a5272717274a8b009368f237da
11 URL:            http://packages.debian.org/search?keywords=dpkg
12 BuildRequires:  bzip2-devel
13 BuildRequires:  gettext-devel >= 0.18
14 BuildRequires:  libselinux-devel
15 BuildRequires:  perl-tools-pod
16 BuildRequires:  pkgconfig
17 BuildRequires:  rpm-perlprov
18 BuildRequires:  tar >= 1:1.22
19 BuildRequires:  xz
20 BuildRequires:  xz-devel
21 BuildRequires:  zlib-devel
22 Requires:       perl-base
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 # blacklist false positives
26 %define         _noautoreq_perl         extra file in Tie::ExtraHash
27
28 %description
29 This package contains the programs to handle deb packages known from
30 Debian.
31
32 %description -l pl.UTF-8
33 Ten pakiet zawiera narzędzia do obsługi pakietów deb znanych z
34 Debiana.
35
36 %package -n libdpkg-devel
37 Summary:        dpkg library and header files
38 Summary(pl.UTF-8):      Biblioteka i pliki nagłówkowe dpkg
39 Group:          Development/Libraries
40 Requires:       bzip2-devel
41 Requires:       xz-devel
42 Requires:       zlib-devel
43
44 %description -n libdpkg-devel
45 dpkg library and header files.
46
47 %description -n libdpkg-devel -l pl.UTF-8
48 Biblioteka i pliki nagłówkowe dpkg.
49
50 %prep
51 %setup -q
52
53 %build
54 %configure \
55         PO4A="true" \
56         --disable-dselect \
57         --disable-install-info \
58         --disable-silent-rules \
59         --disable-start-stop-daemon \
60         --with-admindir=/var/lib/%{name}
61
62 %{__make}
63
64 %install
65 rm -rf $RPM_BUILD_ROOT
66
67 %{__make} install \
68         DESTDIR=$RPM_BUILD_ROOT
69
70 %{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/alternatives/README
71
72 # dpkg for main part, dpkg-dev for perl-based build script
73 # don't use --all-name to avoid e.g. dselect inclusion
74 %find_lang dpkg
75 %find_lang dpkg-dev
76 cat dpkg-dev.lang >>dpkg.lang
77
78 %clean
79 rm -rf $RPM_BUILD_ROOT
80
81 %files -f dpkg.lang
82 %defattr(644,root,root,755)
83 %doc AUTHORS ChangeLog README THANKS TODO
84 %attr(755,root,root) %{_bindir}/dpkg*
85 %attr(755,root,root) %{_bindir}/update-alternatives
86 %dir %{_sysconfdir}/alternatives
87 %dir %{_sysconfdir}/dpkg
88 %dir %{_sysconfdir}/dpkg/dpkg.cfg.d
89
90 %dir %{_libdir}/dpkg
91 %dir %{_libdir}/dpkg/parsechangelog
92 %attr(755,root,root) %{_libdir}/dpkg/parsechangelog/debian
93 %dir %{_datadir}/dpkg
94 %{_datadir}/dpkg/abitable
95 %{_datadir}/dpkg/cputable
96 %{_datadir}/dpkg/ostable
97 %{_datadir}/dpkg/triplettable
98 %{_datadir}/dpkg/*.mk
99
100 %{perl_vendorlib}/Dpkg.pm
101 %{perl_vendorlib}/Dpkg
102
103 %dir /var/lib/dpkg
104 %dir /var/lib/dpkg/alternatives
105 %dir /var/lib/dpkg/info
106 %dir /var/lib/dpkg/parts
107 %dir /var/lib/dpkg/updates
108
109 %{_mandir}/man1/dpkg*.1*
110 %{_mandir}/man3/Dpkg::*.3*
111 %{_mandir}/man5/deb*.5*
112 %{_mandir}/man5/dpkg.cfg.5*
113 %{_mandir}/man8/dpkg-*.8*
114 %{_mandir}/man8/update-alternatives.8*
115 %lang(de) %{_mandir}/de/man1/dpkg*.1*
116 %lang(de) %{_mandir}/de/man5/deb*.5*
117 %lang(de) %{_mandir}/de/man5/dpkg.cfg.5*
118 %lang(de) %{_mandir}/de/man8/dpkg-*.8*
119 %lang(de) %{_mandir}/de/man8/update-alternatives.8*
120 %lang(es) %{_mandir}/es/man1/dpkg*.1*
121 %lang(es) %{_mandir}/es/man5/deb*.5*
122 %lang(es) %{_mandir}/es/man5/dpkg.cfg.5*
123 %lang(es) %{_mandir}/es/man8/dpkg-*.8*
124 %lang(es) %{_mandir}/es/man8/update-alternatives.8*
125 %lang(fr) %{_mandir}/fr/man1/dpkg*.1*
126 %lang(fr) %{_mandir}/fr/man5/deb*.5*
127 %lang(fr) %{_mandir}/fr/man5/dpkg.cfg.5*
128 %lang(fr) %{_mandir}/fr/man8/dpkg-*.8*
129 %lang(fr) %{_mandir}/fr/man8/update-alternatives.8*
130 %lang(hu) %{_mandir}/hu/man5/dpkg.cfg.5*
131 %lang(ja) %{_mandir}/ja/man1/dpkg*.1*
132 %lang(ja) %{_mandir}/ja/man5/deb*.5*
133 %lang(ja) %{_mandir}/ja/man5/dpkg.cfg.5*
134 %lang(ja) %{_mandir}/ja/man8/dpkg*.8*
135 %lang(ja) %{_mandir}/ja/man8/update-alternatives.8*
136 %lang(pl) %{_mandir}/pl/man1/dpkg*.1*
137 %lang(pl) %{_mandir}/pl/man5/deb*.5*
138 %lang(pl) %{_mandir}/pl/man5/dpkg.cfg.5*
139 %lang(pl) %{_mandir}/pl/man8/dpkg-*.8*
140 %lang(pl) %{_mandir}/pl/man8/update-alternatives.8*
141 %lang(sv) %{_mandir}/sv/man1/dpkg*.1*
142 %lang(sv) %{_mandir}/sv/man5/deb*.5*
143 %lang(sv) %{_mandir}/sv/man5/dpkg.cfg.5*
144 %lang(sv) %{_mandir}/sv/man8/dpkg-*.8*
145 %lang(sv) %{_mandir}/sv/man8/update-alternatives.8*
146
147 %files -n libdpkg-devel
148 %defattr(644,root,root,755)
149 %{_libdir}/libdpkg.a
150 %{_includedir}/dpkg
151 %{_pkgconfigdir}/libdpkg.pc
This page took 0.066795 seconds and 3 git commands to generate.