]> git.pld-linux.org Git - packages/dpkg.git/blob - dpkg.spec
3416f82888777c44e9949aaf9bdcad1129294e2e
[packages/dpkg.git] / dpkg.spec
1 #
2 # Conditional build:
3 %bcond_with     alternatives    # build alternatives package
4
5 %include        /usr/lib/rpm/macros.perl
6 Summary:        Package maintenance system for Debian Linux
7 Summary(pl.UTF-8):      Program do obsługi pakietów Debiana
8 Name:           dpkg
9 Version:        1.18.4
10 Release:        3
11 License:        GPL v2+
12 Group:          Applications/File
13 Source0:        ftp://ftp.debian.org/debian/pool/main/d/dpkg/%{name}_%{version}.tar.xz
14 # Source0-md5:  e95b513c89693f6ec3ab53b6b1c3defd
15 Patch0:         %{name}-md5.patch
16 URL:            http://packages.debian.org/search?keywords=dpkg
17 BuildRequires:  bzip2-devel
18 BuildRequires:  gettext-tools >= 0.18.2
19 BuildRequires:  libselinux-devel
20 BuildRequires:  perl-tools-pod
21 BuildRequires:  pkgconfig
22 BuildRequires:  rpm-perlprov
23 BuildRequires:  rpmbuild(macros) >= 1.654
24 BuildRequires:  tar >= 1:1.22
25 BuildRequires:  xz
26 BuildRequires:  xz-devel
27 BuildRequires:  zlib-devel
28 Requires:       perl-base
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 # blacklist false positives
32 %define         _noautoreq_perl         extra file in Tie::ExtraHash
33
34 %description
35 This package contains the programs to handle deb packages known from
36 Debian.
37
38 %description -l pl.UTF-8
39 Ten pakiet zawiera narzędzia do obsługi pakietów deb znanych z
40 Debiana.
41
42 %package -n libdpkg-devel
43 Summary:        dpkg library and header files
44 Summary(pl.UTF-8):      Biblioteka i pliki nagłówkowe dpkg
45 Group:          Development/Libraries
46 Requires:       bzip2-devel
47 Requires:       xz-devel
48 Requires:       zlib-devel
49
50 %description -n libdpkg-devel
51 dpkg library and header files.
52
53 %description -n libdpkg-devel -l pl.UTF-8
54 Biblioteka i pliki nagłówkowe dpkg.
55
56 %package alternatives
57 Summary:        Maintain symbolic links determining default commands
58 Summary(pl.UTF-8):      Utrzymywanie dowiązań symbolicznych określających domyślne polecenia
59 Group:          Applications/System
60 Requires:       %{name} = %{version}-%{release}
61
62 %description alternatives
63 alternatives creates, removes, maintains and displays information
64 about the symbolic links comprising the alternatives system. The
65 alternatives system is a reimplementation of the Debian alternatives
66 system.
67
68 %description alternatives -l pl.UTF-8
69 alternatives tworzy, usuwa, utrzymuje i wyświetla informacje o
70 dowiązaniach symbolicznych obejmujących system alternatyw. System
71 alternatyw to reimplementacja systemu alternatyw ("alternatives") z
72 Debiana.
73
74 %prep
75 %setup -q
76 %patch0 -p1
77
78 %build
79 # "ac_cv_header_md5_h=no" to disable error on md5.h from libmd5
80 # (dpkg expects this header from FreeBSD-compatible libmd, having different API)
81 %configure \
82         ac_cv_header_md5_h=no \
83         PO4A="true" \
84         --disable-dselect \
85         %{!?with_alternatives:--disable-update-alternatives} \
86         --disable-silent-rules \
87         --disable-start-stop-daemon \
88         --with-admindir=/var/lib/%{name}
89
90 %{__make}
91
92 %install
93 rm -rf $RPM_BUILD_ROOT
94 %{__make} install \
95         DESTDIR=$RPM_BUILD_ROOT
96
97 %if %{with alternatives}
98 %{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/alternatives/README
99 %endif
100
101 # obsoleted by pkg-config
102 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libdpkg.la
103
104 # dpkg for main part, dpkg-dev for perl-based build script
105 # don't use --all-name to avoid e.g. dselect inclusion
106 %find_lang dpkg
107 %find_lang dpkg-dev
108 cat dpkg-dev.lang >>dpkg.lang
109
110 %clean
111 rm -rf $RPM_BUILD_ROOT
112
113 %files -f dpkg.lang
114 %defattr(644,root,root,755)
115 %doc AUTHORS ChangeLog README THANKS TODO
116 %attr(755,root,root) %{_bindir}/dpkg*
117 %dir %{_sysconfdir}/dpkg
118 %dir %{_sysconfdir}/dpkg/dpkg.cfg.d
119
120 %dir %{_libdir}/dpkg
121 %dir %{_libdir}/dpkg/parsechangelog
122 %attr(755,root,root) %{_libdir}/dpkg/parsechangelog/debian
123 %dir %{_datadir}/dpkg
124 %{_datadir}/dpkg/abitable
125 %{_datadir}/dpkg/cputable
126 %{_datadir}/dpkg/ostable
127 %{_datadir}/dpkg/triplettable
128 %{_datadir}/dpkg/*.mk
129
130 %{perl_vendorlib}/Dpkg.pm
131 %{perl_vendorlib}/Dpkg
132
133 %dir /var/lib/dpkg
134 %dir /var/lib/dpkg/info
135 %dir /var/lib/dpkg/parts
136 %dir /var/lib/dpkg/updates
137
138 %{_mandir}/man1/dpkg*.1*
139 %{_mandir}/man3/Dpkg.3*
140 %{_mandir}/man3/Dpkg::*.3*
141 %{_mandir}/man5/deb*.5*
142 %{_mandir}/man5/dpkg.cfg.5*
143 %lang(de) %{_mandir}/de/man1/dpkg*.1*
144 %lang(de) %{_mandir}/de/man5/deb*.5*
145 %lang(de) %{_mandir}/de/man5/dpkg.cfg.5*
146 %lang(es) %{_mandir}/es/man1/dpkg*.1*
147 %lang(es) %{_mandir}/es/man5/deb*.5*
148 %lang(es) %{_mandir}/es/man5/dpkg.cfg.5*
149 %lang(fr) %{_mandir}/fr/man1/dpkg*.1*
150 %lang(fr) %{_mandir}/fr/man5/deb*.5*
151 %lang(fr) %{_mandir}/fr/man5/dpkg.cfg.5*
152 %lang(hu) %{_mandir}/hu/man5/dpkg.cfg.5*
153 %lang(it) %{_mandir}/it/man1/dpkg*.1*
154 %lang(it) %{_mandir}/it/man5/deb*.5*
155 %lang(it) %{_mandir}/it/man5/dpkg.cfg.5*
156 %lang(ja) %{_mandir}/ja/man1/dpkg*.1*
157 %lang(ja) %{_mandir}/ja/man5/deb*.5*
158 %lang(ja) %{_mandir}/ja/man5/dpkg.cfg.5*
159 %lang(pl) %{_mandir}/pl/man1/dpkg*.1*
160 %lang(pl) %{_mandir}/pl/man5/deb*.5*
161 %lang(pl) %{_mandir}/pl/man5/dpkg.cfg.5*
162 %lang(sv) %{_mandir}/sv/man1/dpkg*.1*
163 %lang(sv) %{_mandir}/sv/man5/deb*.5*
164 %lang(sv) %{_mandir}/sv/man5/dpkg.cfg.5*
165
166 %files -n libdpkg-devel
167 %defattr(644,root,root,755)
168 %{_libdir}/libdpkg.a
169 %{_includedir}/dpkg
170 %{_pkgconfigdir}/libdpkg.pc
171
172 %if %{with alternatives}
173 %files alternatives
174 %defattr(644,root,root,755)
175 %dir %{_sysconfdir}/alternatives
176 %attr(755,root,root) %{_bindir}/update-alternatives
177 %{_mandir}/man1/update-alternatives.1*
178 %lang(de) %{_mandir}/de/man1/update-alternatives.1*
179 %lang(es) %{_mandir}/es/man1/update-alternatives.1*
180 %lang(fr) %{_mandir}/fr/man1/update-alternatives.1*
181 %lang(it) %{_mandir}/it/man1/update-alternatives.1*
182 %lang(ja) %{_mandir}/ja/man1/update-alternatives.1*
183 %lang(pl) %{_mandir}/pl/man1/update-alternatives.1*
184 %lang(sv) %{_mandir}/sv/man1/update-alternatives.1*
185 %dir /var/lib/dpkg/alternatives
186 %endif
This page took 0.029197 seconds and 2 git commands to generate.