]> git.pld-linux.org Git - SPECS.git/blob - doublecpp.spec
SPECS updated Tue 30 Apr 15:13:02 CEST 2024
[SPECS.git] / doublecpp.spec
1 Summary:        Doublecpp - double dispatch in C++
2 Summary(pl.UTF-8):      Doublecpp - podwójna dyspozycja w C++
3 Name:           doublecpp
4 Version:        0.6.3
5 Release:        1
6 License:        GPL v2+
7 Group:          Development/Tools
8 Source0:        http://downloads.sourceforge.net/doublecpp/%{name}-%{version}.tar.gz
9 # Source0-md5:  0537ff74de82901f2e3bd92aaa677b3d
10 Patch0:         %{name}-includes.patch
11 URL:            http://doublecpp.sourceforge.net/
12 BuildRequires:  libstdc++-devel
13 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
14
15 %description
16 Doublecpp is a preprocessor for C++ that handles a new linguistic
17 construct for defining branches of a multi-method. The "right" branch
18 of such a method will be selected dynamically at run-time according to
19 the actual type of the object on which the method is invoked and to
20 the actual type of the first argument: double dispatch.
21
22 %description -l pl.UTF-8
23 Doublecpp to preprocesor dla C++ obsługujący nową konstrukcję językową
24 do definiowania odgałęzień multi-metody. Właściwa gałąź takiej metody
25 jest wybierana dynamicznie w czasie działania zgodnie z typem obiektu,
26 z jakim została wywołana metoda oraz typem pierwszego argumentu:
27 podwójna dyspozycja.
28
29 %prep
30 %setup -q
31 %patch0 -p1
32
33 %build
34 %configure \
35         %{!?with_static_libs:--disable-static}
36 %{__make}
37
38 %install
39 rm -rf $RPM_BUILD_ROOT
40
41 %{__make} install \
42         DESTDIR=$RPM_BUILD_ROOT
43
44 # packaged as %doc
45 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/doublecpp
46
47 %clean
48 rm -rf $RPM_BUILD_ROOT
49
50 %post   -p /sbin/ldconfig
51 %postun -p /sbin/ldconfig
52
53 %files
54 %defattr(644,root,root,755)
55 %doc AUTHORS ChangeLog NEWS README TODO doc/doublecpp.html
56 %attr(755,root,root) %{_bindir}/doublecpp
This page took 0.516685 seconds and 3 git commands to generate.