]> git.pld-linux.org Git - packages/doomsday.git/blob - doomsday.spec
- up to 1.9.0-beta6.7
[packages/doomsday.git] / doomsday.spec
1 # TODO
2 # - icons for desktop files
3
4 %define         subver  beta6.7
5 %define         rel             1
6 Summary:        jDoom, jHeretic and jHexen for Linux
7 Summary(pl.UTF-8):      jDoom, jHeretic i jHexen dla Linuksa
8 Name:           doomsday
9 Version:        1.9.0
10 Release:        0.%{subver}.%{rel}
11 License:        GPL v2 / CC 3.0 (icons)
12 Group:          Applications/Games
13 Source0:        http://dl.sourceforge.net/project/deng/Doomsday%20Engine/%{version}-%{subver}/deng-%{version}-%{subver}.tar.gz
14 # Source0-md5:  9c706df9a3f078b9b62af842e09b088e
15 Source1:        http://www.iconarchive.com/icons/3xhumed/mega-games-pack-26/Doom-1-48x48.png
16 # Source1-md5:  b7b7a9389eba56679e5db65d95c06803
17 Source2:        http://www.iconarchive.com/icons/3xhumed/mega-games-pack-23/Hexen-1-48x48.png
18 # Source2-md5:  573845e6e747f68617ac67f3a87dc78e
19 Source3:        http://www.iconarchive.com/icons/3xhumed/mega-games-pack-28/Heretic-I-1-48x48.png
20 # Source3-md5:  c89e36c49eabe2846137f313a5250308
21 URL:            http://www.doomsdayhq.com/
22 BuildRequires:  OpenAL-devel
23 BuildRequires:  OpenGL-GLU-devel
24 BuildRequires:  OpenGL-devel
25 BuildRequires:  SDL-devel >= 1.2.0
26 BuildRequires:  SDL_mixer-devel
27 BuildRequires:  SDL_net-devel
28 BuildRequires:  cmake >= 2.4
29 BuildRequires:  curl-devel
30 BuildRequires:  rpmbuild(macros) >= 1.213
31 BuildRequires:  zip
32 Requires:       TiMidity++
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %description
36 jDoom, jHeretic and jHexen for Linux.
37
38 %description -l pl.UTF-8
39 jDoom, jHeretic i jHexen dla Linuksa.
40
41 %prep
42 %setup -q -n deng-%{version}-%{subver}
43
44 %build
45 install -d build
46 cd build
47 %cmake \
48         -DCMAKE_INSTALL_PREFIX=%{_prefix} \
49         -DCURSES_INCLUDE_PATH=/usr/include/ncurses \
50         -Dlibdir=%{_libdir} \
51         ../doomsday
52 %{__make}
53
54 %install
55 rm -rf $RPM_BUILD_ROOT
56 install -d $RPM_BUILD_ROOT%{_desktopdir}
57
58 %{__make} -C build install \
59         DESTDIR=$RPM_BUILD_ROOT
60
61 install -d $RPM_BUILD_ROOT%{_pixmapsdir}
62 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_pixmapsdir}/doom.png
63 cp -a %{SOURCE2} $RPM_BUILD_ROOT%{_pixmapsdir}/hexen.png
64 cp -a %{SOURCE3} $RPM_BUILD_ROOT%{_pixmapsdir}/heretic.png
65
66 cat <<EOF > $RPM_BUILD_ROOT%{_desktopdir}/%{name}-doom.desktop
67 [Desktop Entry]
68 Name=Doom
69 Comment=Doom for linux
70 Exec=doomsday -game jdoom
71 Icon=doom.png
72 Terminal=false
73 Type=Application
74 Categories=Game;FirstPersonGame;
75 Encoding=UTF-8
76 # vi: encoding=utf-8
77 EOF
78
79 cat <<EOF > $RPM_BUILD_ROOT%{_desktopdir}/%{name}-hexen.desktop
80 [Desktop Entry]
81 Name=Hexen
82 Comment=Hexen for linux
83 Exec=doomsday -game jhexen
84 Icon=hexen.png
85 Terminal=false
86 Type=Application
87 Categories=Game;FirstPersonGame;
88 Encoding=UTF-8
89 # vi: encoding=utf-8
90 EOF
91
92 cat <<EOF > $RPM_BUILD_ROOT%{_desktopdir}/%{name}-heretic.desktop
93 [Desktop Entry]
94 Name=Heretic
95 Comment=Heretic for linux
96 Exec=doomsday -game jheretic
97 Icon=heretic.png
98 Terminal=false
99 Type=Application
100 Categories=Game;FirstPersonGame;
101 Encoding=UTF-8
102 # vi: encoding=utf-8
103 EOF
104
105 %clean
106 rm -rf $RPM_BUILD_ROOT
107
108 %post
109 if [ "$1" = "1" ]; then
110         %banner -e %{name} <<-EOF
111         To run doomsday you need some WAD file: either freedoom package
112         or some shareware or commercial WAD from Doom or Heretic:
113         Doom.wad, Doom1.wad, Doom2.wad, Tnt.wad, Plutonia.wad,
114         Heretic.wad or Heretic1.wad.
115         When you have them, run doomsday with:
116         doomsday -game [ jdoom | jheretic | jhexen ]
117 EOF
118 fi
119
120 %files
121 %defattr(644,root,root,755)
122 %doc doomsday/build/README
123 %attr(755,root,root) %{_bindir}/doomsday
124 %attr(755,root,root) %{_libdir}/libdpdehread.so
125 %attr(755,root,root) %{_libdir}/libdpwadmapconverter.so
126 %attr(755,root,root) %{_libdir}/libjdoom.so
127 %attr(755,root,root) %{_libdir}/libjheretic.so
128 %attr(755,root,root) %{_libdir}/libjhexen.so
129 %{_datadir}/deng
130 %{_desktopdir}/*.desktop
131 %{_pixmapsdir}/*.png
This page took 0.061592 seconds and 4 git commands to generate.