]> git.pld-linux.org Git - packages/djvulibre.git/blob - djvulibre.spec
bc6489a2c295ec57c4c82182d93aa88ac01df0cc
[packages/djvulibre.git] / djvulibre.spec
1 # TODO: use system qt qt.qm files instead of included copies
2 #
3 # Conditional build:
4 %define         base_ver        3.5.25
5 %define         minor_ver       .3
6 #
7 Summary:        DjVu viewers, encoders and utilities
8 Summary(pl.UTF-8):      DjVu - przeglądarki, dekodery oraz narzędzia
9 Name:           djvulibre
10 Version:        %{base_ver}%{minor_ver}
11 Release:        1
12 License:        GPL v2+
13 Group:          Applications/Graphics
14 Source0:        http://downloads.sourceforge.net/djvu/%{name}-%{version}.tar.gz
15 # Source0-md5:  5f45d6cd5700b4dd31b1eb963482089b
16 Patch0:         %{name}-opt.patch
17 Patch1:         djvulibre-3.5.22-cdefs.patch
18 URL:            http://djvu.sourceforge.net/
19 BuildRequires:  autoconf >= 2.50
20 BuildRequires:  automake
21 BuildRequires:  libjpeg-devel
22 BuildRequires:  libstdc++-devel
23 BuildRequires:  pkgconfig
24 BuildRequires:  rpmbuild(macros) >= 1.357
25 Obsoletes:      djvu
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 DjVu is a web-centric format and software platform for distributing
30 documents and images. DjVu content downloads faster, displays and
31 renders faster, looks nicer on a screen, and consume less client
32 resources than competing formats. DjVu was originally developed at
33 AT&T Labs-Research by Leon Bottou, Yann LeCun, Patrick Haffner, and
34 many others. In March 2000, AT&T sold DjVu to LizardTech Inc. who now
35 distributes Windows/Mac plug-ins, and commercial encoders (mostly on
36 Windows).
37
38 In an effort to promote DjVu as a Web standard, the LizardTech
39 management was enlightened enough to release the reference
40 implementation of DjVu under the GNU GPL in October 2000. DjVuLibre
41 (which means free DjVu), is an enhanced version of that code
42 maintained by the original inventors of DjVu. It is compatible with
43 version 3.5 of the LizardTech DjVu software suite.
44
45 This package of DjVulibre 3.5 contains:
46 - A full-fledged wavelet-based compressor for pictures.
47 - A simple compressor for bitonal (black and white) scanned pages.
48 - A compressor for palettized images (a la GIF/PNG).
49 - A set of utilities to manipulate and assemble DjVu images and
50   documents.
51 - A set of decoders to convert DjVu to a number of other formats.
52 - An up-to-date version of the C++ DjVu Reference Library.
53
54 %description -l pl.UTF-8
55 DjVu jest przeznaczonym głównie dla WWW formatem i platformą
56 programową do dystrybucji dokumentów i obrazków. Dane w DjVu ściągają
57 się szybciej, wyświetlają szybciej, wyglądają ładniej na ekranie i
58 zajmują mniej zasobów po stronie klienckiej niż inne formaty. DjVu
59 oryginalnie został stworzony w AT&T Labs-Research przez Leona Bottou,
60 Yanna LeCun, Patricka Haffnera i wielu innych. W marcu 2000 AT&T
61 sprzedało DjVu firmie LizardTech Inc., które teraz rozpowszechnia
62 wtyczki dla Windows i Maca oraz komercyjne kodery (głównie dla
63 Windows).
64
65 Aby wypromować DjVu jako sieciowy standard, LizardTech udostępnił
66 wzorcową implementację DjVu na licencji GPL w październiku 2000.
67 DjVuLibre (czyli wolne DjVu) jest rozszerzoną wersją tego kodu
68 rozwijaną przez pomysłodawców DjVu. Jest kompatybilna z wersją 3.5
69 oprogramowania LizardTech DjVu.
70
71 Ten pakiet zawiera: bibliotekę w C++, zestaw kompresorów, dekoderów i
72 narzędzi do plików w formacie DjV
73
74 %package devel
75 Summary:        Header file for DjVu library
76 Summary(pl.UTF-8):      Plik nagłówkowy biblioteki DjVu
77 Group:          Development/Libraries
78 Requires:       %{name} = %{version}-%{release}
79 Requires:       libjpeg-devel
80 Requires:       libstdc++-devel
81
82 %description devel
83 Header file for DjVu library.
84
85 %description devel -l pl.UTF-8
86 Plik nagłówkowy biblioteki DjVu.
87
88 %prep
89 %setup -q -n %{name}-%{base_ver}
90 %patch0 -p1
91 %patch1 -p1
92
93 %build
94 cp -f /usr/share/automake/config.sub config
95 %{__aclocal} -I config
96 %{__autoconf}
97 %configure \
98         PTHREAD_LIBS="-lpthread" \
99         --disable-desktopfiles
100
101 %{__make} -j1
102
103 %install
104 rm -rf $RPM_BUILD_ROOT
105 install -d $RPM_BUILD_ROOT%{_browserpluginsdir}
106
107 %{__make} install \
108         DESTDIR=$RPM_BUILD_ROOT \
109         plugindir=%{_browserpluginsdir}
110
111 %clean
112 rm -rf $RPM_BUILD_ROOT
113
114 %post   -p /sbin/ldconfig
115 %postun -p /sbin/ldconfig
116
117 %files
118 %defattr(644,root,root,755)
119 %doc COPYRIGHT NEWS README doc/*
120 %attr(755,root,root) %{_bindir}/any2djvu
121 %attr(755,root,root) %{_bindir}/bzz
122 %attr(755,root,root) %{_bindir}/c44
123 %attr(755,root,root) %{_bindir}/cjb2
124 %attr(755,root,root) %{_bindir}/cpaldjvu
125 %attr(755,root,root) %{_bindir}/csepdjvu
126 %attr(755,root,root) %{_bindir}/ddjvu
127 %attr(755,root,root) %{_bindir}/djvm
128 %attr(755,root,root) %{_bindir}/djvmcvt
129 %attr(755,root,root) %{_bindir}/djvu*
130 %attr(755,root,root) %{_libdir}/libdjvulibre.so.*.*.*
131 %attr(755,root,root) %ghost %{_libdir}/libdjvulibre.so.21
132 %{_mandir}/man1/any2djvu.1*
133 %{_mandir}/man1/bzz.1*
134 %{_mandir}/man1/c44.1*
135 %{_mandir}/man1/cjb2.1*
136 %{_mandir}/man1/cpaldjvu.1*
137 %{_mandir}/man1/csepdjvu.1*
138 %{_mandir}/man1/ddjvu.1*
139 %{_mandir}/man1/djvm.1*
140 %{_mandir}/man1/djvmcvt.1*
141 %{_mandir}/man1/djvu*.1*
142 %dir %{_datadir}/djvu
143 %dir %{_datadir}/djvu/osi
144 %{_datadir}/djvu/osi/languages.xml
145 %lang(cs) %{_datadir}/djvu/osi/cs
146 %lang(de) %{_datadir}/djvu/osi/de
147 %{_datadir}/djvu/osi/en
148 %lang(fr) %{_datadir}/djvu/osi/fr
149 %lang(ja) %{_datadir}/djvu/osi/ja
150 %lang(zh) %{_datadir}/djvu/osi/zh
151 %{_datadir}/djvu/pubtext
152
153 %files devel
154 %defattr(644,root,root,755)
155 %attr(755,root,root) %{_libdir}/libdjvulibre.so
156 %{_libdir}/libdjvulibre.la
157 %{_includedir}/libdjvu
158 %{_pkgconfigdir}/ddjvuapi.pc
This page took 0.037245 seconds and 2 git commands to generate.