]> git.pld-linux.org Git - SPECS.git/blob - distrobuilder.spec
SPECS updated Tue 30 Apr 15:06:09 CEST 2024
[SPECS.git] / distrobuilder.spec
1 Summary:        System container image builder for LXC and LXD
2 Name:           distrobuilder
3 Version:        1.0
4 Release:        1
5 License:        Apache v2.0
6 Group:          Applications/System
7 Source0:        https://linuxcontainers.org/downloads/distrobuilder/%{name}-%{version}.tar.gz
8 # Source0-md5:  24e2202ce18dbe16e8f653b39389d1be
9 URL:            http://linuxcontainers.org/distrobuilder/
10 BuildRequires:  rpmbuild(macros) >= 1.228
11 Requires:       rsync
12 Requires:       squashfs
13 ExclusiveArch:  %{ix86} %{x8664} %{arm}
14 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16 %define         _enable_debug_packages 0
17 %define         goinstall go install -ldflags "${LDFLAGS:-} -B 0x$(head -c20 /dev/urandom|od -An -tx1|tr -d ' \\n')" -a -v -x
18
19 %description
20 Distrobuilder builds images based on image definition is a YAML
21 document which describes the source of the image, its package manager,
22 what packages to install/remove for specific image variants, os
23 releases and architectures, as well as additional files to generate
24 and arbitrary actions to execute as part of the image build process.
25
26 The output is either a plain root filesystem, a LXD image or a LXC
27 image.
28
29 %prep
30 %setup -q
31
32 %build
33 export GOPATH=$(pwd)/_dist
34 export GOBIN=$GOPATH/bin
35
36 %goinstall ./...
37
38 %install
39 rm -rf $RPM_BUILD_ROOT
40 install -d $RPM_BUILD_ROOT%{_bindir}
41 install _dist/bin/distrobuilder $RPM_BUILD_ROOT%{_bindir}/
42
43 %clean
44 rm -rf $RPM_BUILD_ROOT
45
46 %files
47 %defattr(644,root,root,755)
48 %doc README.md doc/*
49 %attr(755,root,root) %{_bindir}/%{name}
This page took 0.461373 seconds and 3 git commands to generate.