]> git.pld-linux.org Git - packages/distcc.git/blob - distcc.spec
- massive attack: adding Source-md5
[packages/distcc.git] / distcc.spec
1 Summary:        Program to distribute compilation of C or C++
2 Summary(pl):    Program do rozdzielania kompilacji programów w C lub C++
3 Name:           distcc
4 Group:          Development/Languages
5 Version:        2.4
6 Release:        1
7 License:        GPL
8 URL:            http://distcc.samba.org
9 Source0:        http://distcc.samba.org/ftp/distcc/%{name}-%{version}.tar.bz2
10 # Source0-md5:  e996c2dd500c3d693f507c88b3c565bb
11 Source1:        %{name}.inetd
12 Source2:        %{name}.init
13 Source3:        %{name}.sh
14 Source4:        %{name}.csh
15 Source5:        %{name}.config
16 Patch0:         %{name}-user.patch
17 Patch1:         %{name}-hostopt.patch
18 BuildRequires:  popt-devel
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 distcc is a program to distribute compilation of C or C++ code across
23 several machines on a network. distcc should always generate the same
24 results as a local compile, is simple to install and use, and is often
25 two or more times faster than a local compile.
26
27 %description -l pl
28 distcc jest programem pozwalaj±cym na dystrybucjê kompilacji C lub C++
29 na kilka maszyn w sieci. distcc powinien zawsze generowaæ takie same
30 rezultaty jak lokalna kompilacja, jest prosty w instalacji i u¿yciu
31 oraz bardzo czêsto dwa lub wiêcej razy szybszy ni¿ lokalna kompilacja.
32
33 %package common
34 Summary:        Common files for inetd and standalone versions of distcc
35 Summary(pl):    Pliki wspólne dla wersji inetd i standalone distcc
36 Group:          Daemons
37 Requires:       gcc
38 Requires:       gcc-c++
39 Obsoletes:      %{name} < %{name}-2.1-2
40
41 %description common
42 distcc is a program to distribute compilation of C or C++ code across
43 several machines on a network. distcc should always generate the same
44 results as a local compile, is simple to install and use, and is often
45 two or more times faster than a local compile.
46
47 %description -l pl common
48 distcc jest programem pozwalaj±cym na dystrybucjê kompilacji C lub C++
49 na kilka maszyn w sieci. distcc powinien zawsze generowaæ takie same
50 rezultaty jak lokalna kompilacja, jest prosty w instalacji i u¿yciu
51 oraz bardzo czêsto dwa lub wiêcej razy szybszy ni¿ lokalna kompilacja.
52
53
54 %package inetd
55 Summary:        inetd configs for distcc
56 Summary(pl):    Pliki konfiguracyjne do u¿ycia distcc poprzez inetd
57 Group:          Daemons
58 PreReq:         %{name}-common = %{version}
59 PreReq:         rc-inetd
60 Obsoletes:      %{name} < %{name}-2.1-2
61
62 %description inetd
63 distcc configs for running from inetd.
64
65 %description inetd -l pl
66 Pliki konfiguracyjna distcc do startowania demona poprzez inetd.
67
68 %package standalone
69 Summary:        standalone daemon configs for distcc
70 Summary(pl):    Pliki konfiguracyjne do startowania distcc w trybie standalone
71 Group:          Daemons
72 PreReq:         %{name}-common = %{version}
73 PreReq:         rc-scripts
74 Requires(post,preun):   /sbin/chkconfig
75 Obsoletes:      %{name} < %{name}-2.1-2
76
77 %description standalone
78 distcc configs for running as a standalone daemon.
79
80 %description standalone -l pl
81 Pliki konfiguracyjne distcc do startowania demona w trybie
82 standalone.
83
84 %prep
85 %setup -q
86
87 %patch -p1
88 %patch1 -p0
89
90 %build
91 %configure
92 %{__make}
93
94 %install
95 rm -rf $RPM_BUILD_ROOT
96 install -d $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd \
97            $RPM_BUILD_ROOT/etc/rc.d/init.d \
98            $RPM_BUILD_ROOT/etc/profile.d
99
100 %{__make} DESTDIR=$RPM_BUILD_ROOT install
101
102 install %{SOURCE1} $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/distccd
103 install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/distcc
104 install %{SOURCE3} %{SOURCE4} $RPM_BUILD_ROOT/etc/profile.d
105 install %{SOURCE5} $RPM_BUILD_ROOT/etc/sysconfig/distccd
106
107 %clean
108 rm -rf $RPM_BUILD_ROOT
109
110 %post inetd
111 if [ -f /var/lock/subsys/rc-inetd ]; then
112         /etc/rc.d/init.d/rc-inetd reload 1>&2
113 else
114         echo "Type \"/etc/rc.d/init.d/rc-inetd start\" to start inet server" 1>&2
115 fi
116
117 %postun inetd
118 if [ -f /var/lock/subsys/rc-inetd ]; then
119         /etc/rc.d/init.d/rc-inetd reload
120 fi
121
122 %post standalone
123 /sbin/chkconfig --add distcc
124 if [ -f /var/lock/subsys/distccd ]; then
125         /etc/rc.d/init.d/distcc restart 1>&2
126 else
127         echo "Run \"/etc/rc.d/init.d/distcc start\" to start distcc daemon."
128 fi
129
130 %preun standalone
131 if [ "$1" = "0" ]; then
132         if [ -f /var/lock/subsys/distccd ]; then
133                 /etc/rc.d/init.d/distcc stop 1>&2
134         fi
135         /sbin/chkconfig --del distcc
136 fi
137
138 %files common
139 %defattr(644,root,root,755)
140 %doc AUTHORS NEWS README linuxdoc/html/*
141 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) /etc/sysconfig/distccd
142 %attr(755,root,root) %{_bindir}/*
143 %attr(644,root,root) %{_mandir}/man?/*
144 %attr(644,root,root) /etc/profile.d/*sh
145
146 %files inetd
147 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) /etc/sysconfig/rc-inetd/distccd
148
149 %files standalone
150 %attr(755,root,root) /etc/rc.d/init.d/distcc
This page took 0.316805 seconds and 4 git commands to generate.