]> git.pld-linux.org Git - packages/distcc.git/blob - distcc.spec
- next typo
[packages/distcc.git] / distcc.spec
1 Summary:        Program to distribute compilation of C or C++
2 Summary(pl):    Program do rozdzielania kompilacji programów w C lub C++
3 Name:           distcc
4 Group:          Development/Languages
5 Version:        2.2
6 Release:        2
7 License:        GPL
8 URL:            http://distcc.samba.org
9 Source0:        http://distcc.samba.org/ftp/distcc/%{name}-%{version}.tar.bz2
10 Source1:        %{name}.inetd
11 Source2:        %{name}.init
12 Source3:        %{name}.sh
13 Source4:        %{name}.csh
14 Source5:        %{name}.config
15 Patch0:         %{name}-user.patch
16 Patch1:         %{name}-hostfile.patch
17 Patch2:         %{name}-hostopt.patch
18 BuildRequires:  popt-devel
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 distcc is a program to distribute compilation of C or C++ code across
23 several machines on a network. distcc should always generate the same
24 results as a local compile, is simple to install and use, and is often
25 two or more times faster than a local compile.
26
27 %description -l pl
28 distcc jest programem pozwalaj±cym na dystrybucjê kompilacji C lub C++
29 na kilka maszyn w sieci. distcc powinien zawsze generowaæ takie same
30 rezultaty jak lokalna kompilacja, jest prosty w instalacji i u¿yciu
31 oraz bardzo czêsto dwa lub wiêcej razy szybszy ni¿ lokalna kompilacja.
32
33 %package common
34 Summary:        Common files for inetd and standalone versions of distcc
35 Summary(pl):    Pliki wspólne dla wersji inetd i standalone distcc
36 Group:          Daemons
37 Requires:       gcc
38 Requires:       gcc-c++
39 Obsoletes:      %{name} < %{name}-2.1-2
40
41 %description common
42 distcc is a program to distribute compilation of C or C++ code across
43 several machines on a network. distcc should always generate the same
44 results as a local compile, is simple to install and use, and is often
45 two or more times faster than a local compile.
46
47 %description -l pl common
48 distcc jest programem pozwalaj±cym na dystrybucjê kompilacji C lub C++
49 na kilka maszyn w sieci. distcc powinien zawsze generowaæ takie same
50 rezultaty jak lokalna kompilacja, jest prosty w instalacji i u¿yciu
51 oraz bardzo czêsto dwa lub wiêcej razy szybszy ni¿ lokalna kompilacja.
52
53
54 %package inetd
55 Summary:        inetd configs for distcc
56 Summary(pl):    Pliki konfiguracyjne do u¿ycia distcc poprzez inetd
57 Group:          Daemons
58 PreReq:         %{name}-common = %{version}
59 PreReq:         rc-inetd
60 Obsoletes:      %{name} < %{name}-2.1-2
61
62 %description inetd
63 distcc configs for running from inetd.
64
65 %description inetd -l pl
66 Pliki konfiguracyjna distcc do startowania demona poprzez inetd.
67
68 %package standalone
69 Summary:        standalone daemon configs for distcc
70 Summary(pl):    Pliki konfiguracyjne do startowania distcc w trybie standalone
71 Group:          Daemons
72 PreReq:         %{name}-common = %{version}
73 PreReq:         rc-scripts
74 Requires(post,preun):   /sbin/chkconfig
75 Obsoletes:      %{name} < %{name}-2.1-2
76
77 %description standalone
78 distcc configs for running as a standalone daemon.
79
80 %description standalone -l pl
81 Pliki konfiguracyjne distcc do startowania demona w trybie
82 standalone.
83
84 %prep
85 %setup -q
86
87 %patch -p1
88 %patch1 -p1
89 %patch2 -p0
90
91 %build
92 %configure
93 %{__make}
94
95 %install
96 rm -rf $RPM_BUILD_ROOT
97 install -d $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd \
98            $RPM_BUILD_ROOT/etc/rc.d/init.d \
99            $RPM_BUILD_ROOT/etc/profile.d
100
101 %{__make} DESTDIR=$RPM_BUILD_ROOT install
102
103 install %{SOURCE1} $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/distccd
104 install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/distcc
105 install %{SOURCE3} %{SOURCE4} $RPM_BUILD_ROOT/etc/profile.d
106 install %{SOURCE5} $RPM_BUILD_ROOT/etc/sysconfig/distccd
107
108 %clean
109 rm -rf $RPM_BUILD_ROOT
110
111 %post inetd
112 if [ -f /var/lock/subsys/rc-inetd ]; then
113         /etc/rc.d/init.d/rc-inetd reload 1>&2
114 else
115         echo "Type \"/etc/rc.d/init.d/rc-inetd start\" to start inet server" 1>&2
116 fi
117
118 %postun inetd
119 if [ -f /var/lock/subsys/rc-inetd ]; then
120         /etc/rc.d/init.d/rc-inetd reload
121 fi
122
123 %post standalone
124 /sbin/chkconfig --add distcc
125 if [ -f /var/lock/subsys/distccd ]; then
126         /etc/rc.d/init.d/distcc restart 1>&2
127 else
128         echo "Run \"/etc/rc.d/init.d/distcc start\" to start distcc daemon."
129 fi
130
131 %preun standalone
132 if [ "$1" = "0" ]; then
133         if [ -f /var/lock/subsys/distccd ]; then
134                 /etc/rc.d/init.d/distcc stop 1>&2
135         fi
136         /sbin/chkconfig --del distcc
137 fi
138
139 %files common
140 %defattr(644,root,root,755)
141 %doc AUTHORS NEWS README linuxdoc/html/*
142 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) /etc/sysconfig/distcc
143 %attr(755,root,root) %{_bindir}/*
144 %attr(644,root,root) %{_mandir}/man?/*
145 %attr(644,root,root) /etc/profile.d/*sh
146
147 %files inetd
148 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) /etc/sysconfig/rc-inetd/distccd
149
150 %files standalone
151 %attr(755,root,root) /etc/rc.d/init.d/distcc
This page took 0.070329 seconds and 3 git commands to generate.