]> git.pld-linux.org Git - packages/distcc.git/blob - distcc.spec
- cleanups, moved R: from non-existent base to -common
[packages/distcc.git] / distcc.spec
1 Summary:        Program to distribute compilation of C or C++
2 Summary(pl):    Program do rozdzielania kompilacji programów w C lub C++
3 Name:           distcc
4 Group:          Development/Languages
5 Version:        2.1
6 Release:        2
7 License:        GPL
8 URL:            http://distcc.samba.org
9 Source0:        http://distcc.samba.org/ftp/distcc/%{name}-%{version}.tar.bz2
10 Source1:        %{name}.inetd
11 Source2:        %{name}.init
12 Source3:        %{name}.sh
13 Source4:        %{name}.csh
14 Patch0:         %{name}-user.patch
15 Patch1:         %{name}-hostfile.patch
16 Patch2:         %{name}-hostopt.patch
17 BuildRequires:  popt-devel
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 distcc is a program to distribute compilation of C or C++ code across
22 several machines on a network. distcc should always generate the same
23 results as a local compile, is simple to install and use, and is often
24 two or more times faster than a local compile.
25
26 %description -l pl
27 distcc jest programem pozwalaj±cym na dystrybucjê kompilacji C lub C++
28 na kilka maszyn w sieci. distcc powinien zawsze generowaæ takie same
29 rezultaty jak lokalna kompilacja, jest prosty w instalacji i u¿yciu
30 oraz bardzo czêsto dwa lub wiêcej razy szybszy ni¿ lokalna kompilacja.
31
32 %package common
33 Summary:        Common files for inetd and standalone versions of distcc
34 Summary(pl):    Pliki wspólne dla wersji inetd i standalone distcc
35 Group:          Daemons
36 Requires:       gcc
37 Requires:       gcc-c++
38 Obsoletes:      %{name} < %{name}-2.1-2
39
40 %description common
41 distcc is a program to distribute compilation of C or C++ code across
42 several machines on a network. distcc should always generate the same
43 results as a local compile, is simple to install and use, and is often
44 two or more times faster than a local compile.
45
46 %description -l pl common
47 distcc jest programem pozwalaj±cym na dystrybucjê kompilacji C lub C++
48 na kilka maszyn w sieci. distcc powinien zawsze generowaæ takie same
49 rezultaty jak lokalna kompilacja, jest prosty w instalacji i u¿yciu
50 oraz bardzo czêsto dwa lub wiêcej razy szybszy ni¿ lokalna kompilacja.
51
52
53 %package inetd
54 Summary:        inetd configs for distcc
55 Summary(pl):    Pliki konfiguracyjne do u¿ycia distcc poprzez inetd
56 Group:          Daemons
57 PreReq:         %{name}-common = %{version}
58 PreReq:         rc-inetd
59 Obsoletes:      %{name} < %{name}-2.1-2
60
61 %description inetd
62 distcc configs for running from inetd.
63
64 %description inetd -l pl
65 Pliki konfiguracyjna distcc do startowania demona poprzez inetd.
66
67 %package standalone
68 Summary:        standalone daemon configs for distcc
69 Summary(pl):    Pliki konfiguracyjne do startowania distcc w trybie standalone
70 Group:          Daemons
71 PreReq:         %{name}-common = %{version}
72 PreReq:         rc-scripts
73 Requires(post,preun):   /sbin/chkconfig
74 Obsoletes:      %{name} < %{name}-2.1-2
75
76 %description standalone
77 distcc configs for running as a standalone daemon.
78
79 %description standalone -l pl
80 Pliki konfiguracyjne distcc do startowania demona w trybie
81 standalone.
82
83 %prep
84 %setup -q
85
86 %patch -p1
87 %patch1 -p1
88 %patch2 -p0
89
90 %build
91 %configure
92 %{__make}
93
94 %install
95 rm -rf $RPM_BUILD_ROOT
96 install -d $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd \
97            $RPM_BUILD_ROOT/etc/rc.d/init.d \
98            $RPM_BUILD_ROOT/etc/profile.d
99
100 %{__make} DESTDIR=$RPM_BUILD_ROOT install
101
102 install %{SOURCE1} $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/distccd
103 install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/distcc
104 install %{SOURCE3} %{SOURCE4} $RPM_BUILD_ROOT/etc/profile.d
105
106 %clean
107 rm -rf $RPM_BUILD_ROOT
108
109 %post inetd
110 if [ -f /var/lock/subsys/rc-inetd ]; then
111         /etc/rc.d/init.d/rc-inetd reload 1>&2
112 else
113         echo "Type \"/etc/rc.d/init.d/rc-inetd start\" to start inet server" 1>&2
114 fi
115
116 %postun inetd
117 if [ -f /var/lock/subsys/rc-inetd ]; then
118         /etc/rc.d/init.d/rc-inetd reload
119 fi
120
121 %post standalone
122 /sbin/chkconfig --add distcc
123 if [ -f /var/lock/subsys/distccd ]; then
124         /etc/rc.d/init.d/distcc restart 1>&2
125 else
126         echo "Run \"/etc/rc.d/init.d/distcc start\" to start distcc daemon."
127 fi
128
129 %preun standalone
130 if [ "$1" = "0" ]; then
131         if [ -f /var/lock/subsys/distccd ]; then
132                 /etc/rc.d/init.d/distcc stop 1>&2
133         fi
134         /sbin/chkconfig --del distcc
135 fi
136
137 %files common
138 %defattr(644,root,root,755)
139 %doc AUTHORS NEWS README linuxdoc/html/*
140 %attr(755,root,root) %{_bindir}/*
141 %attr(644,root,root) %{_mandir}/man?/*
142 %attr(644,root,root) /etc/profile.d/*sh
143
144 %files inetd
145 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) /etc/sysconfig/rc-inetd/distccd
146
147 %files standalone
148 %attr(755,root,root) /etc/rc.d/init.d/distcc
This page took 0.060654 seconds and 3 git commands to generate.