]> git.pld-linux.org Git - SPECS.git/blob - distcache.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / distcache.spec
1 Summary:        Distributed SSL session cache
2 Summary(pl.UTF-8):      Rozproszona pamięć podręczna sesji SSL
3 Name:           distcache
4 Version:        1.4.5
5 Release:        0.5
6 License:        LGPL
7 Group:          Daemons
8 Source0:        http://dl.sourceforge.net/distcache/%{name}-%{version}.tar.bz2
9 # Source0-md5:  bad485801024f711ad72e83ba1adcd7d
10 Source1:        dc_server.init
11 Source2:        dc_client.init
12 Source3:        %{name}.sysconfig
13 Patch0:         %{name}-setuid.patch
14 URL:            http://www.distcache.org/
15 BuildRequires:  rpmbuild(macros) >= 1.228
16 BuildRequires:  autoconf >= 2.50
17 BuildRequires:  automake >= 1:1.7
18 BuildRequires:  libtool
19 BuildRequires:  openssl-devel
20 Requires(post,preun):   /sbin/chkconfig
21 Requires:       %{name}-libs = %{version}-%{release}
22 Requires:       rc-scripts
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 The distcache package provides a variety of functionality for enabling
27 a network-based session caching system, primarily for (though not
28 restricted to) SSL/TLS session caching.
29
30 %description -l pl.UTF-8
31 Pakiet distcache udostępnia rozmaitą funkcjonalność mającą umożliwić
32 działanie sieciowego systemu pamięci podręcznej sesji, głównie (choć
33 niekoniecznie tylko) w celu zapamiętywania sesji SSL/TLS.
34
35 %package libs
36 Summary:        Shared distcache distributed session cache libraries
37 Summary(pl.UTF-8):      Współdzielone biblioteki rozproszonej pamięci podręcznej sesji
38 Group:          Libraries
39
40 %description libs
41 This package includes the shared libraries that implement the
42 necessary network functionality, the session caching protocol, and
43 APIs for applications wishing to use a distributed session cache, or
44 indeed even to implement a storage mechanism for a session cache
45 server.
46
47 %description libs -l pl.UTF-8
48 Ten pakiet zawiera współdzielone biblioteki implementujące potrzebną
49 funkcjonalność sieciową, protokół zapamiętywania sesji oraz API dla
50 aplikacji chcących korzystać z rozproszonej pamięci podręcznej sesji
51 lub mających samemu implementować mechanizm przechowywania danych dla
52 serwera pamięci podręcznej sesji.
53
54 %package devel
55 Summary:        Header files for distcache distributed session cache library
56 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki rozproszonej pamięci podręcznej sesji distcache
57 Group:          Development/Libraries
58 Requires:       %{name}-libs = %{version}-%{release}
59
60 %description devel
61 This package includes the header files for the libraries that
62 implement the necessary network functionality, the session caching
63 protocol, and APIs for applications wishing to use a distributed
64 session cache, or indeed even to implement a storage mechanism for a
65 session cache server.
66
67 %description devel -l pl.UTF-8
68 Ten pakiet zawiera pliki nagłówkowe bibliotek implementujących
69 potrzebną funkcjonalność sieciową, protokół zapamiętywania sesji oraz
70 API dla aplikacji chcących korzystać z rozproszonej pamięci podręcznej
71 sesji lub mających samemu implementować mechanizm przechowywania
72 danych dla serwera pamięci podręcznej sesji.
73
74 %package static
75 Summary:        Static distcache distributed session cache library
76 Summary(pl.UTF-8):      Statyczne biblioteki rozproszonej pamięci podręcznej sesji
77 Group:          Development/Libraries
78 Requires:       %{name}-devel = %{version}-%{release}
79
80 %description static
81 This package includes the static libraries that implement the
82 necessary network functionality, the session caching protocol, and
83 APIs for applications wishing to use a distributed session cache, or
84 indeed even to implement a storage mechanism for a session cache
85 server.
86
87 %description static -l pl.UTF-8
88 Ten pakiet zawiera statyczne biblioteki implementujące potrzebną
89 funkcjonalność sieciową, protokół zapamiętywania sesji oraz API dla
90 aplikacji chcących korzystać z rozproszonej pamięci podręcznej sesji
91 lub mających samemu implementować mechanizm przechowywania danych dla
92 serwera pamięci podręcznej sesji.
93
94 %prep
95 %setup -q
96 %patch0 -p1
97
98 %build
99 %{__libtoolize}
100 %{__aclocal}
101 %{__autoconf}
102 %{__automake}
103 %configure \
104         --enable-shared
105 %{__make}
106
107 %install
108 rm -rf $RPM_BUILD_ROOT
109
110 %{__make} install \
111         DESTDIR=$RPM_BUILD_ROOT
112
113 %{__make} -C ssl install \
114         DESTDIR=$RPM_BUILD_ROOT
115
116 install -d $RPM_BUILD_ROOT/etc/{sysconfig,rc.d/init.d}
117 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/dc_server
118 install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/dc_client
119 install %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/distcache
120
121 # Unpackaged files
122 rm -f $RPM_BUILD_ROOT%{_bindir}/{nal_test,piper}
123
124 %clean
125 rm -rf $RPM_BUILD_ROOT
126
127 %post   libs -p /sbin/ldconfig
128 %postun libs -p /sbin/ldconfig
129
130 %post
131 /sbin/chkconfig --add dc_server
132 /sbin/chkconfig --add dc_client
133 %service dc_server restart "Distcache SSL Session Cache Server"
134 %service dc_client restart "Distcache SSL Session Cache Client Proxy"
135
136 %preun
137 if [ "$1" = "0" ]; then
138         /sbin/chkconfig --del dc_server
139         /sbin/chkconfig --del dc_client
140         %service -q dc_server stop
141         %service -q dc_client stop
142 fi
143
144 %files
145 %defattr(644,root,root,755)
146 %doc ANNOUNCE CHANGES README LICENSE FAQ
147 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/*
148 %attr(755,root,root) %{_bindir}/sslswamp
149 %attr(755,root,root) %{_bindir}/dc_*
150 %attr(754,root,root) /etc/rc.d/init.d/dc_*
151 %{_datadir}/swamp
152 %{_mandir}/man1/*
153 %{_mandir}/man8/*
154
155 %files libs
156 %defattr(644,root,root,755)
157 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
158
159 %files devel
160 %defattr(644,root,root,755)
161 %attr(755,root,root) %{_libdir}/lib*.so
162 %{_libdir}/lib*.la
163 %{_includedir}/distcache
164 %{_includedir}/libnal
165 %{_mandir}/man2/*
166
167 %files static
168 %defattr(644,root,root,755)
169 %{_libdir}/lib*.a
This page took 0.468055 seconds and 3 git commands to generate.