]> git.pld-linux.org Git - SPECS.git/blob - dhcpv6.spec
SPECS updated Mon 29 Apr 22:05:02 CEST 2024
[SPECS.git] / dhcpv6.spec
1 # NEWS
2 #
3 # IMPORTANT! Tuesday, September 22, 2009: No new development will be happening on
4 # this project. dhcpv6 has been obsoleted by ISC dhcp version 4.1.0 and later.
5 # Previous stable versions will receive security and bug fixes and periodic new
6 # releases may be made for older distributions, but as for new development, the
7 # project is shut down.
8 #
9 Summary:        DHCPv6 - DHCP server and client for IPv6
10 Summary(pl.UTF-8):      DHCPv6 - serwer i klient DHCP dla IPv6
11 Name:           dhcpv6
12 Version:        1.2.0
13 Release:        0.2
14 Epoch:          1
15 License:        GPL v2+
16 Group:          Networking/Daemons
17 Source0:        https://fedorahosted.org/releases/d/h/dhcpv6/%{name}-%{version}.tar.gz
18 # Source0-md5:  d537416b33002f56912b7f27477d8d35
19 Source1:        dhcp6s.init
20 Source2:        dhcp6c.init
21 BuildRequires:  restore-compatability
22 URL:            https://fedorahosted.org/dhcpv6/
23 BuildRequires:  autoconf >= 2.61
24 BuildRequires:  automake
25 BuildRequires:  bison
26 BuildRequires:  flex
27 BuildRequires:  libnl-devel >= 1.1
28 BuildRequires:  libtool
29 BuildRequires:  pkgconfig
30 BuildRequires:  rpmbuild(macros) >= 1.268
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 Implements the Dynamic Host Configuration Protocol (DHCP) for Internet
35 Protocol version 6 (IPv6) networks in accordance with RFC 3315:
36 Dynamic Host Configuration Protocol for IPv6 (DHCPv6).
37
38 %description -l pl.UTF-8
39 Ten pakiet jest implementacją protokołu Dynamic Host Configuration
40 Protocol (DHCP) dla sieci IPv6 zgodnie z RFC 3315: Dynamic Host
41 Configuration Protocol for IPv6 (DHCPv6).
42
43 %package client
44 Summary:        DHCPv6 client
45 Summary(pl.UTF-8):      Klient DHCPv6
46 Group:          Applications/Networking
47 Requires(post,preun):   /sbin/chkconfig
48 Requires:       rc-scripts
49
50 %description client
51 Provides the client for the DHCPv6 protocol (RFC 3315) to support
52 dynamic configuration of IPv6 addresses and parameters.
53
54 %description client -l pl.UTF-8
55 Ten pakiet dostarcza klienta protokołu DHCPv6 (RFC 3315) do obsługi
56 dynamicznej konfiguracji adresów i parametrów sieci iPv6.
57
58 %package relay
59 Summary:        DHCPv6 relay agent
60 Summary(pl.UTF-8):      Agent przekazujący DHCPv6
61 Group:          Applications/Networking
62 Requires(post,preun):   /sbin/chkconfig
63 Requires:       rc-scripts
64
65 %description relay
66 dhcp6r acts as DHCPv6 relay agent forwarding DHCPv6 messages from
67 clients to servers and vice versa.
68
69 %description relay -l pl.UTF-8
70 dhcp6r służy jako agent przekazujący komunikaty DHCPv6 od klientów do
71 serwerów i z powrotem.
72
73 %package server
74 Summary:        DHCPv6 server daemon
75 Summary(pl.UTF-8):      Demon serwera DHCPv6
76 Group:          Applications/Networking
77 Requires(post,preun):   /sbin/chkconfig
78 Requires:       rc-scripts
79
80 %description server
81 dhcp6s is an implementation of the DHCPv6 server.
82
83 %description server -l pl.UTF-8
84 dhcp6s to implementacja serwera DHCPv6.
85
86 %prep
87 %setup -q
88
89 %build
90 %{__libtoolize}
91 %{__aclocal} -I m4
92 %{__autoconf}
93 %{__automake}
94 %configure
95
96 %{__make}
97
98 %install
99 rm -rf $RPM_BUILD_ROOT
100 install -d $RPM_BUILD_ROOT{%{_localstatedir}/lib/dhcpv6,/etc/{rc.d/init.d,sysconfig}}
101
102 %{__make} install \
103         INSTALL_USER=$(id -u) \
104         INSTALL_GROUP=$(id -g) \
105         DESTDIR=$RPM_BUILD_ROOT
106
107 install %{SOURCE1}      $RPM_BUILD_ROOT/etc/rc.d/init.d/dhcp6s
108 install %{SOURCE2}      $RPM_BUILD_ROOT/etc/rc.d/init.d/dhcp6c
109
110 mkdir -p $RPM_BUILD_ROOT/var/run/dhcpv6
111
112 %clean
113 rm -rf $RPM_BUILD_ROOT
114
115 %post client
116 /sbin/chkconfig --add dhcp6c
117 %service dhcp6c restart
118
119 %post relay
120 /sbin/chkconfig --add dhcp6r
121 %service dhcp6r restart
122
123 %post server
124 /sbin/chkconfig --add dhcp6s
125 %service dhcp6s restart
126
127 %preun client
128 if [ "$1" = "0" ]; then
129         %service dhcp6c stop
130         /sbin/chkconfig --del dhcp6c
131 fi
132
133 %preun relay
134 if [ "$1" = "0" ]; then
135         %service dhcp6r stop
136         /sbin/chkconfig --del dhcp6r
137 fi
138
139 %preun server
140 if [ "$1" = "0" ]; then
141         %service dhcp6s stop
142         /sbin/chkconfig --del dhcp6s
143 fi
144
145 %files client
146 %defattr(644,root,root,755)
147 %attr(755,root,root) %{_sbindir}/dhcp6c
148 %attr(754,root,root) /etc/rc.d/init.d/dhcp6c
149 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/dhcp6c.conf
150 %{_mandir}/man8/dhcp6c.8*
151 %{_mandir}/man5/dhcp6c.conf.5*
152
153 %files relay
154 %defattr(644,root,root,755)
155 %attr(755,root,root) %{_sbindir}/dhcp6r
156 %attr(754,root,root) /etc/rc.d/init.d/dhcp6r
157 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/dhcp6r
158 %{_mandir}/man8/dhcp6r.8*
159
160 %files server
161 %defattr(644,root,root,755)
162 %doc AUTHORS README TODO
163 %attr(755,root,root) %{_sbindir}/dhcp6s
164 %attr(754,root,root) /etc/rc.d/init.d/dhcp6s
165 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/dhcp6s
166 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/dhcp6s.conf
167 %{_mandir}/man8/dhcp6s.8*
168 %{_mandir}/man5/dhcp6s.conf.5*
169 %attr(750,root,root) %dir %{_localstatedir}/lib/dhcpv6
170 %attr(755,root,root) %dir %{_localstatedir}/run/dhcpv6
This page took 1.0247 seconds and 3 git commands to generate.