]> git.pld-linux.org Git - packages/deluge.git/blob - deluge.spec
- use source that exists
[packages/deluge.git] / deluge.spec
1 Summary:        A Python BitTorrent client with support for UPnP and DHT
2 Summary(pl.UTF-8):      Klient BitTorrenta napisany w pythonie ze wspraciem dla UPnP i DHT
3 Name:           deluge
4 Version:        0.5.0
5 Release:        0.1
6 License:        GPL
7 Group:          X11/Applications/Networking
8 URL:            http://deluge-torrent.org/
9 Source0:        http://deluge-torrent.org/downloads/%{name}-%{version}.tar.gz
10 # Source0-md5:  d83e6ee573ac9e2e8d11bc3f446da3f8
11 #Source1:       %{name}-fixed-setup.py
12 BuildRequires:  boost-program_options-devel
13 BuildRequires:  boost-regex-devel
14 BuildRequires:  desktop-file-utils
15 BuildRequires:  libtool
16 BuildRequires:  python-devel
17 BuildRequires:  rb_libtorrent-devel
18 Requires:       /bin/sh
19 Requires:       python-dbus
20 Requires:       python-pygtk-glade
21 Requires:       python-pyxdg
22 Requires:       rb_libtorrent
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 Deluge is a new BitTorrent client, created using Python and GTK+. It
27 is intended to bring a native, full-featured client to Linux GTK+
28 desktop environments such as GNOME and XFCE. It supports features such
29 as DHT (Distributed Hash Tables) and UPnP (Universal Plug-n-Play) that
30 allow one to more easily share BitTorrent data even from behind a
31 router with virtually zero configuration of port-forwarding.
32
33 %prep
34 %setup -q
35
36 %build
37 ## We forcibly don't store the installation directory during the build, so
38 ## we need to ensure that it is properly inserted into the code as required.
39 %{__sed} -i -e "s:INSTALL_PREFIX = '@datadir@':INSTALL_PREFIX = '%{_usr}':" \
40         src/dcommon.py
41 %ifarch x86_64 ppc64 sparc64
42         CFLAGS="%{optflags} -DAMD64" %{__python} setup.py build
43 %else
44         CFLAGS="%{optflags}" %{__python} setup.py build
45 %endif
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49 %{__python} setup.py install -O1 --skip-build --root $RPM_BUILD_ROOT
50
51 ## ...then strip the unneeded shebang lines from some of the plugins...
52 # this seems, wrong, we don't pkg the .py
53 # and if we do chmod -x on files should not fill autodeps
54 #sed -i 1d $RPM_BUILD_ROOT%{py_sitedir}/%{name}/{delugegtk.py,delugeplugins.py}
55
56 %find_lang %{name}
57
58 %clean
59 rm -rf $RPM_BUILD_ROOT
60
61 %files -f %{name}.lang
62 %defattr(644,root,root,755)
63 %doc LICENSE
64 %attr(755,root,root) %{_bindir}/%{name}
65 %dir %{py_sitedir}/%{name}
66 %{py_sitedir}/%{name}/*.py[co]
67 %attr(755,root,root) %{py_sitedir}/%{name}/*.so
68 %{py_sitedir}/%{name}-%{version}-py2.5.egg-info
69 %{_desktopdir}/%{name}.desktop
70 %{_pixmapsdir}/%{name}.xpm
71 %{_datadir}/%{name}
This page took 0.05129 seconds and 3 git commands to generate.