]> git.pld-linux.org Git - SPECS.git/blob - dax-svg.spec
SPECS updated Tue 30 Apr 15:13:02 CEST 2024
[SPECS.git] / dax-svg.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static libraries
4 #
5 Summary:        SVG loading and drawing library
6 Summary(pl.UTF-8):      Biblioteka do wczytywania i rysowania obrazów SVG
7 Name:           dax-svg
8 Version:        0.1.0
9 %define snap    20100802
10 %define gitref  c8dc7638977f5b09d3d709b4c0119adf892ba10c
11 Release:        0.%{snap}.1
12 License:        LGPL v2.1
13 Group:          Libraries
14 Source0:        https://github.com/dlespiau/dax-svg/archive/%{gitref}/%{name}-%{snap}.tar.gz
15 # Source0-md5:  a4484dc120da5babc3bf9e76c2eaf523
16 Patch0:         %{name}-clutter.patch
17 Patch1:         %{name}-gjs.patch
18 Patch2:         %{name}-pc.patch
19 Patch3:         %{name}-install.patch
20 URL:            https://github.com/dlespiau/dax-svg/
21 BuildRequires:  autoconf >= 2.59
22 BuildRequires:  automake >= 1:1.10
23 BuildRequires:  clutter-devel >= 1.3.2
24 BuildRequires:  clutter-gst-devel >= 3.0
25 BuildRequires:  gjs-devel >= 1.0
26 BuildRequires:  glib2-devel >= 1:2.22
27 BuildRequires:  gobject-introspection-devel >= 0.6.14
28 BuildRequires:  libtool >= 2:2.2.6
29 BuildRequires:  libxml2-devel >= 2.0
30 BuildRequires:  mozjs24-devel
31 BuildRequires:  mx-devel >= 1.0
32 BuildRequires:  pkgconfig
33 Requires:       clutter >= 1.3.2
34 Requires:       glib2 >= 1:2.22
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %description
38 SVG loading and drawing library.
39
40 %description -l pl.UTF-8
41 Biblioteka do wczytywania i rysowania obrazów SVG.
42
43 %package devel
44 Summary:        Header files for Dax library
45 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Dax
46 Group:          Development/Libraries
47 Requires:       %{name} = %{version}-%{release}
48 Requires:       clutter-devel >= 1.3.2
49 Requires:       clutter-gst-devel >= 3.0
50 Requires:       gjs-devel >= 1.0
51 Requires:       glib2-devel >= 1:2.22
52 Requires:       libxml2-devel >= 2.0
53 Requires:       mozjs24-devel
54 Requires:       mx-devel >= 1.0
55
56 %description devel
57 Header files for Dax library.
58
59 %description devel -l pl.UTF-8
60 Pliki nagłówkowe biblioteki Dax.
61
62 %package static
63 Summary:        Static Dax library
64 Summary(pl.UTF-8):      Statyczna biblioteka Dax
65 Group:          Development/Libraries
66 Requires:       %{name}-devel = %{version}-%{release}
67
68 %description static
69 Static Dax library.
70
71 %description static -l pl.UTF-8
72 Statyczna biblioteka Dax.
73
74 %prep
75 %setup -q -n %{name}-%{gitref}
76 %patch0 -p1
77 %patch1 -p1
78 %patch2 -p1
79 %patch3 -p1
80
81 %build
82 %{__libtoolize}
83 %{__aclocal} -I build/autotools
84 %{__autoconf}
85 %{__autoheader}
86 %{__automake}
87 %configure \
88         --disable-silent-rules \
89         %{?with_static_libs:--enable-static}
90 %{__make}
91
92 %install
93 rm -rf $RPM_BUILD_ROOT
94
95 %{__make} install \
96         DESTDIR=$RPM_BUILD_ROOT
97
98 # obsoleted by pkg-config
99 %{__rm} $RPM_BUILD_ROOT%{_libdir}/lib*.la
100
101 %clean
102 rm -rf $RPM_BUILD_ROOT
103
104 %post   -p /sbin/ldconfig
105 %postun -p /sbin/ldconfig
106
107 %files
108 %defattr(644,root,root,755)
109 %attr(755,root,root) %{_bindir}/dax-viewer
110 %attr(755,root,root) %{_libdir}/libdax-0.2.so.*.*.*
111 %attr(755,root,root) %ghost %{_libdir}/libdax-0.2.so.0
112 %attr(755,root,root) %{_libdir}/libdox-0.2.so.*.*.*
113 %attr(755,root,root) %ghost %{_libdir}/libdox-0.2.so.0
114 %{_libdir}/girepository-1.0/Dax-0.2.typelib
115 %{_libdir}/girepository-1.0/Dox-0.2.typelib
116
117 %files devel
118 %defattr(644,root,root,755)
119 %attr(755,root,root) %{_libdir}/libdax-0.2.so
120 %attr(755,root,root) %{_libdir}/libdox-0.2.so
121 %{_includedir}/dax-0.2
122 %{_includedir}/dox-0.2
123 %{_datadir}/gir-1.0/Dax-0.2.gir
124 %{_datadir}/gir-1.0/Dox-0.2.gir
125 %{_pkgconfigdir}/dax-0.2.pc
126 %{_pkgconfigdir}/dox-0.2.pc
127
128 %if %{with static_libs}
129 %files static
130 %defattr(644,root,root,755)
131 %{_libdir}/libdax-0.2.a
132 %{_libdir}/libdox-0.2.a
133 %endif
This page took 1.426455 seconds and 3 git commands to generate.