]> git.pld-linux.org Git - packages/dahdi-tools.git/blob - dahdi-tools.spec
- updated to 2.6.2
[packages/dahdi-tools.git] / dahdi-tools.spec
1 # TODO:
2 # warning: Installed (but unpackaged) file(s) found:
3 #    /etc/hotplug/usb/xpp_fxloader
4 #    /etc/hotplug/usb/xpp_fxloader.usermap
5 #
6 %include        /usr/lib/rpm/macros.perl
7 Summary:        DAHDI telephony device support
8 Summary(pl.UTF-8):      Obsługa urządzeń telefonicznych DAHDI
9 Name:           dahdi-tools
10 Version:        2.6.2
11 Release:        1
12 License:        GPL v2
13 Group:          Base/Kernel
14 Source0:        http://downloads.digium.com/pub/telephony/dahdi-tools/%{name}-%{version}.tar.gz
15 # Source0-md5:  bd23765d25869d9bad70849e762b171b
16 Source1:        dahdi.init
17 Source2:        dahdi.sysconfig
18 Patch0:         %{name}-as-needed.patch
19 Patch1:         %{name}-perl-path.patch
20 Patch2:         %{name}-includes.patch
21 URL:            http://www.asterisk.org/
22 BuildRequires:  dahdi-linux-devel >= 2.3.0
23 BuildRequires:  newt-devel
24 BuildRequires:  perl-base
25 BuildRequires:  perl-tools-pod
26 BuildRequires:  rpm-perlprov >= 4.1-13
27 BuildRequires:  rpmbuild(macros) >= 1.379
28 Obsoletes:      dahdi-tools-utils
29 Obsoletes:      zaptel
30 Obsoletes:      zaptel-utils
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 DAHDI telephony device driver.
35
36 %description -l pl.UTF-8
37 Sterownik do urządzeń telefonicznych DAHDI.
38
39 %package devel
40 Summary:        DAHDI development headers
41 Summary(pl.UTF-8):      Pliki nagłówkowe DAHDI
42 Group:          Development/Libraries
43 Requires:       %{name} = %{version}-%{release}
44 Requires:       dahdi-linux-devel
45 Obsoletes:      zaptel-devel
46
47 %description devel
48 DAHDI development headers.
49
50 %description devel -l pl.UTF-8
51 Pliki nagłówkowe DAHDI.
52
53 %package static
54 Summary:        DAHDI static library
55 Summary(pl.UTF-8):      Biblioteka statyczna DAHDI
56 Group:          Development/Libraries
57 Requires:       %{name}-devel = %{version}-%{release}
58
59 %description static
60 DAHDI static library.
61
62 %description static -l pl.UTF-8
63 Biblioteka statyczna DAHDI.
64
65 %package perl
66 Summary:        DAHDI utility programs written in Perl
67 Summary(pl.UTF-8):      Programy narzędziowe DAHDI napisane w Perlu
68 Group:          Applications/Communications
69 Requires:       perl-Dahdi = %{version}-%{release}
70
71 %description perl
72 DAHDI utility programs written in Perl.
73
74 %description perl -l pl.UTF-8
75 Programy narzędziowe DAHDI napisane w Perlu.
76
77 %package init
78 Summary:        DAHDI init scripts
79 Summary(pl.UTF-8):      Skrypty inicjalizujące DAHDI
80 Group:          Applications/Communications
81 Requires(post,preun):   /sbin/chkconfig
82 Requires:       %{name} = %{version}-%{release}
83 Requires:       rc-scripts
84 Obsoletes:      zaptel-init
85
86 %description init
87 DAHDI boot-time initialization.
88
89 %description init -l pl.UTF-8
90 Inicjalizacja DAHDI w czasie startu systemu.
91
92 %package -n perl-Dahdi
93 Summary:        Perl interface to DAHDI
94 Summary(pl.UTF-8):      Perlowy interfejs do DAHDI
95 Group:          Development/Languages/Perl
96 # needs dahdi_scan
97 Requires:       %{name} = %{version}-%{release}
98
99 %description -n perl-Dahdi
100 Perl inferface to DAHDI.
101
102 %description -n perl-Dahdi -l pl.UTF-8
103 Perlowy interfejs do DAHDI.
104
105 %prep
106 %setup -q
107 %patch0 -p1
108 %patch1 -p1
109 %patch2 -p1
110
111 cat > download-logger <<'EOF'
112 #!/bin/sh
113 # keep log of files make wanted to download in firmware/ dir
114 echo "$@" >> download.log
115 EOF
116 chmod a+rx download-logger
117
118 %build
119 %configure
120 %{__make} \
121         CC="%{__cc}" \
122         OPTFLAGS="%{rpmcppflags} %{rpmcflags}"
123
124 %install
125 rm -rf $RPM_BUILD_ROOT
126
127 install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig}
128
129 %{__make} -j1 install \
130         DESTDIR=$RPM_BUILD_ROOT
131 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/dahdi
132 install %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/dahdi
133 touch $RPM_BUILD_ROOT%{_sysconfdir}/dahdi.conf
134
135 %clean
136 rm -rf $RPM_BUILD_ROOT
137
138 %post init
139 /sbin/chkconfig --add dahdi
140 %service dahdi restart
141
142 %preun init
143 if [ "$1" = "0" ]; then
144         %service dahdi stop
145         /sbin/chkconfig --del dahdi
146 fi
147
148 %files
149 %defattr(644,root,root,755)
150 %doc README
151 %attr(600,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/dahdi.conf
152 %dir %{_sysconfdir}/dahdi
153 %attr(600,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/dahdi/system.conf
154 #/etc/hotplug/usb/xpp_fxloader
155 #/etc/hotplug/usb/xpp_fxloader.usermap
156 %attr(755,root,root) %{_sbindir}/astribank_*
157 %attr(755,root,root) %{_sbindir}/dahdi_cfg
158 %attr(755,root,root) %{_sbindir}/dahdi_maint
159 %attr(755,root,root) %{_sbindir}/dahdi_monitor
160 %attr(755,root,root) %{_sbindir}/dahdi_scan
161 %attr(755,root,root) %{_sbindir}/dahdi_speed
162 %attr(755,root,root) %{_sbindir}/dahdi_test
163 %attr(755,root,root) %{_sbindir}/dahdi_tool
164 %attr(755,root,root) %{_sbindir}/fpga_load
165 %attr(755,root,root) %{_sbindir}/fxotune
166 %attr(755,root,root) %{_sbindir}/sethdlc
167 %attr(755,root,root) %{_libdir}/libtonezone.so.1.*
168 %attr(755,root,root) %ghost %{_libdir}/libtonezone.so.1
169 %attr(755,root,root) %{_libdir}/libtonezone.so.2.*
170 %attr(755,root,root) %ghost %{_libdir}/libtonezone.so.2
171 %{_datadir}/dahdi
172 %{_mandir}/man8/astribank_*.8*
173 %{_mandir}/man8/dahdi_cfg.8*
174 %{_mandir}/man8/dahdi_maint.8*
175 %{_mandir}/man8/dahdi_monitor.8*
176 %{_mandir}/man8/dahdi_scan.8*
177 %{_mandir}/man8/dahdi_test.8*
178 %{_mandir}/man8/dahdi_tool.8*
179 %{_mandir}/man8/fpga_load.8*
180 %{_mandir}/man8/fxotune.8*
181
182 %files devel
183 %defattr(644,root,root,755)
184 %attr(755,root,root) %{_libdir}/libtonezone.so
185 %{_includedir}/dahdi/tonezone.h
186
187 %files static
188 %defattr(644,root,root,755)
189 %{_libdir}/libtonezone.a
190
191 %files perl
192 %defattr(644,root,root,755)
193 %attr(755,root,root) %{_sbindir}/dahdi_genconf
194 %attr(755,root,root) %{_sbindir}/dahdi_hardware
195 %attr(755,root,root) %{_sbindir}/dahdi_registration
196 %attr(755,root,root) %{_sbindir}/lsdahdi
197 %attr(755,root,root) %{_sbindir}/twinstar
198 %attr(755,root,root) %{_sbindir}/xpp_blink
199 %attr(755,root,root) %{_sbindir}/xpp_sync
200 %{_mandir}/man8/dahdi_genconf.8*
201 %{_mandir}/man8/dahdi_hardware.8*
202 %{_mandir}/man8/dahdi_registration.8*
203 %{_mandir}/man8/lsdahdi.8*
204 %{_mandir}/man8/twinstar.8*
205 %{_mandir}/man8/xpp_blink.8*
206 %{_mandir}/man8/xpp_sync.8*
207
208 %files init
209 %defattr(644,root,root,755)
210 %attr(754,root,root) /etc/rc.d/init.d/dahdi
211 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/dahdi
212
213 %files -n perl-Dahdi
214 %defattr(644,root,root,755)
215 %{perl_vendorlib}/Dahdi
216 %{perl_vendorlib}/Dahdi.pm
This page took 0.229122 seconds and 3 git commands to generate.