]> git.pld-linux.org Git - packages/ctags.git/blob - ctags.spec
- updated to 5.2 (many bug fixes).
[packages/ctags.git] / ctags.spec
1 Summary:        Exuberant ctags -- C cross-reference tool
2 Summary(de):    Exuberant ctags - C-Cross-Reference-Tool 
3 Summary(es):    Ctags ¡exuberantes! Herramienta de referencia cruzada para C
4 Summary(fr):    ctags exubérant
5 Summary(pl):    ctags - generator list odwo³añ
6 Summary(pt_BR): Ctags exuberantes! Ferramenta de referência cruzada para C
7 Summary(tr):    C dili için çapraz-baþvuru (cross-reference) aracý
8 Name:           ctags
9 Version:        5.2
10 Release:        1
11 License:        GPL
12 Group:          Development/Tools
13 Group(de):      Entwicklung/Werkzeuge
14 Group(fr):      Development/Outils
15 Group(pl):      Programowanie/Narzêdzia
16 Source0:        ftp://ftp.sourceforge.net/pub/sourceforge/%{name}/%{name}-%{version}.tar.gz
17 URL:            http://ctags.sourceforge.net/
18 BuildRequires:  autoconf
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 Ctags generates an index (or tag) file of C language objects found in
23 C source and header files. The index makes it easy for text editors or
24 other utilities to locate the indexed items. Ctags can also generate a
25 cross reference file which lists information about the various objects
26 found in a set of C language files in human readable form. Exuberant
27 Ctags improves on ctags because it can find all types of C language
28 tags, including macro definitions, enumerated values (values inside
29 enum{...}), function and method definitions, enum/struct/union tags,
30 external function prototypes, typedef names and variable declarations.
31 Exuberant Ctags is far less likely to be fooled by code containing #if
32 preprocessor conditional constructs than ctags. Exuberant ctags
33 supports output of emacs style TAGS files and can be used to print out
34 a list of selected objects found in source files.
35
36 %description -l de
37 #if-Präprozessor-Bedingungen enthält, dank eines konditionalen
38 Ein verbessertes ctags, das tags für alle möglichen tag-Typen
39 generiert: Makrodefinitionen, aufgezählte Werte (Werte in enum{...}),
40 Funktions- und Methodendefinitionen, enum/struct/union-tags, externe
41 Funktionsprototypen (wahlweise), typedefs und variable Deklarationen.
42 Es läßt sich weit weniger gut durch Code täuschen, der
43 Pfadauswahlalgorithmus, der komplizierte Entscheidungen trifft, und
44 eines Ausweiche-Algorithmus, der ins Spiel kommt, wenn der erste dem
45 Problem nicht gewachsen ist. Kann auch benutzt werden, um eine Liste
46 ausgewählter Objekte, die in Quelldateien gefunden wurden,
47 auszudrucken.
48
49 %description -l es
50 Un ctags mejor que crea tags para todos los tipos posibles de tag:
51 definiciones de macro, valores enumerados, definiciones de función y
52 método, tags enum/struct/union, prototipos de función externa
53 (opcional), typedefs y declaraciones variables. Es más difícil de ser
54 engañado en códigos que contenga la directiva condicional #if para el
55 preprocesador, pues utiliza un algoritmo condicional de camino para
56 solucionar decisiones complicadas, y un algoritmo de rescate cuando
57 este falla. También puede ser usado para enseñar una lista de objetos
58 seleccionados que esté en los archivos fuente.
59
60 %description -l fr
61 un ctags amélioré générant des tags pour tous les types de tags
62 possibles : définitions de macros, valeurs énumérées (valeurs dans
63 enum{...}), définitions de fonctions et de méthodes, enum/struct/union
64 tags, prototypes de fonctions externes (optionnel), typedefs, et
65 déclarations de variables. Peut aussi être utilisé pour afficher une
66 liste des objets choisis trouvés dans les fichiers source.
67
68 %description -l pl
69 Generator tabeli odwo³añ dla: makr, zmiennych, funkcji i procedur,
70 definicji typów, metod (C++) itp. U¿ywany do generacji listy
71 wyspecyfikowanych obiektów znalezionych w plikach ¼ród³owych. Tablica
72 owych odwo³añ mo¿e byæ wykorzystywana przez wiekszosæ standardowych
73 edytorów tekstu (vim, joe, emacs), do przemieszczania siê w ¼ród³ach
74 miêdzy deklaracj± i u¿yciem danego symbolu.
75
76 %description -l pt_BR
77 Um ctags melhor que gera tags para todos os tipos possíveis de tag:
78 definições de macro, valores enumerados, definições de função e
79 método, tags enum/struct/union, protótipos de função externa
80 (opcional), typedefs e declarações variáveis. É mais difícil de ser
81 enganado em códigos que contenha a diretiva condicional #if para o
82 pré-processador, pois utiliza um algoritmo condicional de caminho para
83 resolver decisões complicadas, e um algoritmo de resgate quando este
84 falha. Também pode ser usado para mostrar uma lista de objetos
85 selecionados que estejam nos arquivos fonte.
86
87 %description -l tr
88 Olabilecek her türlü etiket çeþitleri - makro tanýmlamalarý, sayýlý
89 (enumerated) deðerler, fonksiyon ve yöntem (method) tanýmlamalarý, tip
90 ve deðiþken tanýmlarý - için etiketler üretir. Kaynak kodlarýnda
91 bulunan, seçilmiþ nesnelerin listesinin çýktýsýný yazýcýdan almak için
92 de kullanýlabilir.
93
94 %prep
95 %setup -q
96
97 %build
98 autoconf
99 cp -f %{_datadir}/automake/install-sh .
100 cp -f %{_datadir}/automake/config.sub .
101 %configure
102
103 %{__make}
104
105 %install
106 rm -rf $RPM_BUILD_ROOT
107
108 %{__make} install \
109         prefix=$RPM_BUILD_ROOT%{_prefix} \
110         bindir=$RPM_BUILD_ROOT%{_bindir} \
111         mandir=$RPM_BUILD_ROOT%{_mandir} 
112
113 rm -f $RPM_BUILD_ROOT%{_mandir}/man1/etags.1
114 echo ".so ctags.1" > $RPM_BUILD_ROOT%{_mandir}/man1/etags.1
115
116 gzip -9nf FAQ NEWS QUOTES README
117
118 %clean
119 rm -rf $RPM_BUILD_ROOT
120
121 %files
122 %defattr(644,root,root,755)
123 %doc *.gz
124 %attr(755,root,root) %{_bindir}/*
125 %{_mandir}/man1/*
This page took 0.046899 seconds and 3 git commands to generate.