]> git.pld-linux.org Git - packages/crun.git/blob - crun.spec
11508c0db99ac9e98a47c844b7b26b291c604181
[packages/crun.git] / crun.spec
1 %ifarch %{x8664} %{armv7} %{armv8} aarch64 ppc64
2 %define         with_criu       1
3 %endif
4
5 %ifarch %{ix86} %{x8664} %{arm} aarch64 mips64 mips64le ppc64 ppc64le s390x
6 %define         with_man        1
7 %endif
8
9 Summary:        OCI runtime written in C
10 Name:           crun
11 Version:        0.21
12 Release:        1
13 License:        GPL v3+
14 Group:          Applications/System
15 Source0:        https://github.com/containers/crun/releases/download/%{version}/%{name}-%{version}.tar.xz
16 # Source0-md5:  591b985e05c992809f0d51253e15d004
17 URL:            https://github.com/containers/crun
18 BuildRequires:  autoconf >= 2.69
19 BuildRequires:  automake >= 1:1.11.2
20 %{?with_criu:BuildRequires:     criu-devel >= 3.15}
21 %{?with_man:BuildRequires:      go-md2man}
22 BuildRequires:  libcap-devel
23 BuildRequires:  libseccomp-devel
24 BuildRequires:  libselinux-devel
25 BuildRequires:  libtool
26 BuildRequires:  pkgconfig
27 BuildRequires:  python3
28 BuildRequires:  python3-devel
29 BuildRequires:  rpmbuild(macros) >= 2.007
30 BuildRequires:  systemd-devel
31 BuildRequires:  tar >= 1:1.22
32 BuildRequires:  xz
33 BuildRequires:  yajl-devel >= 2.0.0
34 %{?with_criu:Requires:  criu-libs >= 3.15}
35 Requires:       yajl >= 2.0.0
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %description
39 crun is a runtime for running OCI containers.
40
41 %prep
42 %setup -q
43
44 %build
45 %{__libtoolize}
46 %{__aclocal}
47 %{__autoconf}
48 %{__autoheader}
49 %{__automake}
50 %configure \
51         --disable-silent-rules
52
53 %{__make}
54
55 %install
56 rm -rf $RPM_BUILD_ROOT
57
58 %{__make} install \
59         DESTDIR=$RPM_BUILD_ROOT
60
61 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libcrun.{a,la}
62
63 %clean
64 rm -rf $RPM_BUILD_ROOT
65
66 %files
67 %defattr(644,root,root,755)
68 %doc README.md
69 %attr(755,root,root) %{_bindir}/crun
70 %{?with_man:%{_mandir}/man1/crun.1*}
This page took 0.063144 seconds and 3 git commands to generate.