]> git.pld-linux.org Git - packages/crossmingw32-fontconfig.git/blob - crossmingw32-fontconfig.spec
- release2 (libstdc++ rebuild)
[packages/crossmingw32-fontconfig.git] / crossmingw32-fontconfig.spec
1 %define         realname   fontconfig
2 Summary:        Font configuration and customization tools - cross MinGW32 versoin
3 Summary(pl.UTF-8):      Narzędzia do konfigurowania fontów - wersja skrośna dla MinGW32
4 Name:           crossmingw32-%{realname}
5 Version:        2.13.0
6 Release:        2
7 License:        MIT
8 Group:          Development/Libraries
9 Source0:        https://www.freedesktop.org/software/fontconfig/release/%{realname}-%{version}.tar.bz2
10 # Source0-md5:  60d2394a79d3b2e5db2daea55193fa47
11 Patch0:         %{realname}-bitstream-cyberbit.patch
12 URL:            http://fontconfig.org/
13 BuildRequires:  autoconf >= 2.61
14 BuildRequires:  automake >= 1:1.11
15 BuildRequires:  crossmingw32-expat
16 BuildRequires:  crossmingw32-freetype >= 2.8.1
17 BuildRequires:  crossmingw32-gcc
18 BuildRequires:  gettext-tools >= 0.19.8
19 BuildRequires:  libtool >= 2:2.2
20 BuildRequires:  pkgconfig >= 1:0.15
21 BuildRequires:  sed >= 4.0
22 Requires:       crossmingw32-expat
23 Requires:       crossmingw32-freetype >= 2.8.1
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %define         no_install_post_strip   1
27
28 %define         target                  i386-mingw32
29 %define         target_platform         i386-pc-mingw32
30
31 %define         _sysprefix              /usr
32 %define         _prefix                 %{_sysprefix}/%{target}
33 %define         _libdir                 %{_prefix}/lib
34 %define         _pkgconfigdir           %{_prefix}/lib/pkgconfig
35 %define         _dlldir                 /usr/share/wine/windows/system
36 %define         __cc                    %{target}-gcc
37 %define         __cxx                   %{target}-g++
38 %define         __pkgconfig_provides    %{nil}
39 %define         __pkgconfig_requires    %{nil}
40
41 %ifnarch %{ix86}
42 # arch-specific flags (like alpha's -mieee) are not valid for i386 gcc
43 %define         optflags        -O2
44 %endif
45 # -z options are invalid for mingw linker, most of -f options are Linux-specific
46 %define         filterout_ld    -Wl,-z,.*
47 %define         filterout_c     -f[-a-z0-9=]*
48
49 %description
50 Fontconfig is designed to locate fonts within the system and select
51 them according to requirements specified by applications.
52
53 This package contains the cross version for Win32.
54
55 %description -l pl.UTF-8
56 Fontconfig jest biblioteką przeznaczoną do lokalizowania fontów w
57 systemie i wybierania ich w zależności od potrzeb aplikacji.
58
59 Paket ten zawiera wersję skrośną dla Win32.
60
61 %package static
62 Summary:        Static freetype library (cross MinGW32 version)
63 Summary(pl.UTF-8):      Statyczna biblioteka freetype (wersja skrośna MinGW32)
64 Group:          Development/Libraries
65 Requires:       %{name} = %{version}-%{release}
66
67 %description static
68 Static freetype library (cross MinGW32 version).
69
70 %description static -l pl.UTF-8
71 Statyczna biblioteka freetype (wersja skrośna MinGW32).
72
73 %package dll
74 Summary:        DLL freetype library for Windows
75 Summary(pl.UTF-8):      Biblioteka DLL freetype dla Windows
76 Group:          Applications/Emulators
77 Requires:       crossmingw32-expat-dll
78 Requires:       crossmingw32-freetype-dll >= 2.8.1
79 Requires:       wine
80
81 %description dll
82 DLL freetype library for Windows.
83
84 %description dll -l pl.UTF-8
85 Biblioteka DLL freetype dla Windows.
86
87 %prep
88 %setup -q -n %{realname}-%{version}
89 %patch0 -p1
90
91 # uses POSIX-specific dirent interfaces
92 %{__sed} -i -e 's/test-migration//' test/Makefile.am
93
94 %build
95 export PKG_CONFIG_LIBDIR=%{_prefix}/lib/pkgconfig
96 %{__gettextize}
97 %{__libtoolize}
98 %{__aclocal} -I m4
99 %{__autoconf}
100 %{__autoheader}
101 %{__automake}
102 %configure \
103         --target=%{target} \
104         --host=%{target} \
105         --with-arch=%{target} \
106         --with-freetype-config="pkg-config freetype2" \
107         --disable-docs \
108         --disable-silent-rules \
109         --enable-static
110
111 %{__make}
112
113 %install
114 rm -rf $RPM_BUILD_ROOT
115
116 # fc_cachedir=/dummy is to avoid creating ${DESTDIR}LOCAL_APPDATA_FONTCONFIG_CACHE dir
117 %{__make} -j1 install \
118         DESTDIR=$RPM_BUILD_ROOT \
119         fc_cachedir=/dummy
120
121 install -d $RPM_BUILD_ROOT%{_dlldir}
122 %{__mv} $RPM_BUILD_ROOT%{_prefix}/bin/*.dll $RPM_BUILD_ROOT%{_dlldir}
123
124 %if 0%{!?debug:1}
125 %{target}-strip --strip-unneeded -R.comment -R.note $RPM_BUILD_ROOT%{_dlldir}/*.dll
126 %{target}-strip -g -R.comment -R.note $RPM_BUILD_ROOT%{_libdir}/*.a
127 %endif
128
129 # runtime
130 %{__rm} -r $RPM_BUILD_ROOT/etc/fonts \
131         $RPM_BUILD_ROOT%{_datadir}/{fontconfig,locale,xml/fontconfig}
132 %{__rm} $RPM_BUILD_ROOT%{_bindir}/fc-*.exe
133 # if needed, use ITS data from native package
134 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/gettext/its
135
136 %clean
137 rm -rf $RPM_BUILD_ROOT
138
139 %files
140 %defattr(644,root,root,755)
141 %doc AUTHORS COPYING ChangeLog README
142 %{_libdir}/libfontconfig.dll.a
143 %{_libdir}/libfontconfig.la
144 %{_libdir}/fontconfig.def
145 %dir %{_includedir}/fontconfig
146 %{_includedir}/fontconfig/*.h
147 %{_pkgconfigdir}/fontconfig.pc
148
149 %files static
150 %defattr(644,root,root,755)
151 %{_libdir}/libfontconfig.a
152
153 %files dll
154 %defattr(644,root,root,755)
155 %{_dlldir}/libfontconfig-*.dll
This page took 0.036436 seconds and 4 git commands to generate.