]> git.pld-linux.org Git - packages/criterion.git/blob - criterion.spec
- initial
[packages/criterion.git] / criterion.spec
1 Summary:        A cross-platform C and C++ unit testing framework for the 21th century
2 Name:           criterion
3 Version:        2.3.3
4 Release:        1
5 License:        LGPL v2.1+
6 Group:          Libraries
7 Source0:        https://github.com/Snaipe/Criterion/releases/download/v%{version}/%{name}-v%{version}.tar.bz2
8 # Source0-md5:  0305dbb5e00f04fd65b22e9ad82ba952
9 URL:            https://github.com/Snaipe/Criterion
10 BuildRequires:  cmake >= 2.8.0
11 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
12
13 %description
14 A dead-simple, yet extensible, C and C++ unit testing framework.
15
16 %package devel
17 Summary:        Header files for criterion library
18 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki criterion
19 Group:          Development/Libraries
20 Requires:       %{name} = %{version}-%{release}
21 Requires:       libstdc++-devel
22
23 %description devel
24 Header files for criterion library.
25
26 %description devel -l pl.UTF-8
27 Pliki nagłówkowe biblioteki criterion.
28
29 %prep
30 %setup -q -n %{name}-v%{version}
31
32 %build
33 install -d build
34 cd build
35 %cmake ..
36 %{__make}
37
38 %install
39 rm -rf $RPM_BUILD_ROOT
40
41 %{__make} -C build install \
42         DESTDIR=$RPM_BUILD_ROOT
43
44 install -d $RPM_BUILD_ROOT%{_libdir}
45 mv $RPM_BUILD_ROOT{%{_prefix}/lib/*,%{_libdir}}
46
47 %find_lang Criterion
48
49 %clean
50 rm -rf $RPM_BUILD_ROOT
51
52 %post   -p /sbin/ldconfig
53 %postun -p /sbin/ldconfig
54
55
56 %files -f Criterion.lang
57 %defattr(644,root,root,755)
58 %doc ChangeLog doc/*.txt
59 %attr(755,root,root) %{_libdir}/libcriterion.so.*.*.*
60 %attr(755,root,root) %ghost %{_libdir}/libcriterion.so.3
61
62 %files devel
63 %defattr(644,root,root,755)
64 %attr(755,root,root) %{_libdir}/libcriterion.so
65 %{_includedir}/criterion
66 %{_npkgconfigdir}/criterion.pc
This page took 0.093754 seconds and 4 git commands to generate.