]> git.pld-linux.org Git - packages/createrepo_c.git/blob - createrepo_c.spec
- added no-c23 patch (don't require C23 unnamed parameters compiler feature)
[packages/createrepo_c.git] / createrepo_c.spec
1 # TODO:
2 # - drpm support?
3 #
4 # Conditional build:
5 %bcond_with     rpm5    # build with rpm5, tests may fail (rpm.org vs rpm5 compat problems?)
6 %bcond_without  tests   # make tests
7
8 Summary:        Creates a common metadata repository
9 Summary(pl.UTF-8):      Tworzenie wspólnego repozytorium metadanych
10 Name:           createrepo_c
11 Version:        0.21.1
12 Release:        1
13 License:        GPL v2+
14 Group:          Applications/System
15 #Source0Download: https://github.com/rpm-software-management/createrepo_c/releases
16 Source0:        https://github.com/rpm-software-management/createrepo_c/archive/%{version}/%{name}-%{version}.tar.gz
17 # Source0-md5:  1c7de898d4c13901aae8b672bd1e812e
18 Patch0:         %{name}-rpm5.patch
19 Patch1:         %{name}-no-c23.patch
20 URL:            https://github.com/rpm-software-management/createrepo_c
21 BuildRequires:  bash-completion-devel >= 1:2.0
22 BuildRequires:  bzip2-devel
23 BuildRequires:  cmake >= 2.8.12
24 BuildRequires:  curl-devel
25 BuildRequires:  doxygen
26 #BuildRequires: drpm-devel
27 BuildRequires:  glib2-devel >= 1:2.22.0
28 BuildRequires:  libmagic-devel >= 5.40-2
29 BuildRequires:  libmodulemd-devel
30 BuildRequires:  libxml2-devel >= 2
31 BuildRequires:  openssl-devel
32 BuildRequires:  pkgconfig
33 %{?with_tests:BuildRequires:    python-nose}
34 BuildRequires:  python3-devel >= 1:3.2
35 BuildRequires:  python3-modules
36 %{?with_tests:BuildRequires:    python3-nose}
37 BuildRequires:  rpm-build >= 4.6
38 BuildRequires:  rpm-devel
39 BuildRequires:  rpm-pythonprov
40 BuildRequires:  rpmbuild(macros) >= 1.673
41 BuildRequires:  sphinx-pdg
42 BuildRequires:  sqlite3-devel >= 3
43 BuildRequires:  xz-devel
44 BuildRequires:  zchunk-devel
45 BuildRequires:  zlib-devel
46 %{?with_tests:BuildRequires:    zchunk}
47 Requires:       %{name}-libs = %{version}-%{release}
48 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
49
50 %description
51 C implementation of Createrepo. This utility will generate a common
52 metadata repository from a directory of RPM packages.
53
54 %description -l pl.UTF-8
55 Implementacja w C programu Createrepo. To narzędzie generuje wspólne
56 repozytorium metadanych z katalogu pakietów RPM.
57
58 %package libs
59 Summary:        Library for repodata manipulation
60 Summary(pl.UTF-8):      Biblioteka do operacji na danych repozytorium
61 Group:          Libraries
62 Requires:       glib2 >= 1:2.22.0
63
64 %description libs
65 This package contains the createrepo_c library for applications to
66 easy manipulate with a repodata.
67
68 %description libs -l pl.UTF-8
69 Ten pakiet zawiera bibliotekę createrepo_c, pozwalającą aplikacjom na
70 łatwe operowanie na danych repozytorium (repodata).
71
72 %package devel
73 Summary:        Header files for createrepo_c library
74 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki createrepo_c
75 Group:          Development/Libraries
76 Requires:       %{name}-libs = %{version}-%{release}
77 Requires:       bzip2-devel
78 Requires:       curl-devel
79 Requires:       expat-devel
80 Requires:       glib2-devel >= 1:2.22.0
81 Requires:       libmagic-devel
82 Requires:       libxml2-devel >= 2
83 Requires:       rpm-devel
84 Requires:       sqlite3-devel >= 3
85 Requires:       xz-devel
86 Requires:       zlib-devel
87
88 %description devel
89 This package contains the createrepo_c C header files. These
90 development files are for easy manipulation with a repodata.
91
92 %description devel -l pl.UTF-8
93 Ten pakiet zawiera pliki nagłówkowe C biblioteki createrepo_c. Mają na
94 celu łatwe operowanie na danych repozytorium (repodata).
95
96 %package apidocs
97 Summary:        API documentation for createrepo_c library
98 Summary(pl.UTF-8):      Dokumentacja API biblioteki createrepo_c
99 Group:          Documentation
100 BuildArch:      noarch
101
102 %description apidocs
103 API documentation for createrepo_c library.
104
105 %description apidocs -l pl.UTF-8
106 Dokumentacja API biblioteki createrepo_c.
107
108 %package -n python3-createrepo_c
109 Summary:        Python 3 bindings for the createrepo_c library
110 Summary(pl.UTF-8):      Wiązania Pythona 3 do biblioteki createrepo_c
111 Group:          Development/Languages/Python
112 Requires:       %{name}-libs = %{version}-%{release}
113 Obsoletes:      python-createrepo_c < 0.17.6
114
115 %description -n python3-createrepo_c
116 Python 3 bindings for the createrepo_c library.
117
118 %description -n python3-createrepo_c -l pl.UTF-8
119 Wiązania Pythona 3 do biblioteki createrepo_c.
120
121 %package -n bash-completion-createrepo_c
122 Summary:        Bash completion for createrepo_c commands
123 Summary(pl.UTF-8):      Bashowe uzupełnianie dla poleceń createrepo_c
124 Group:          Applications/Shells
125 Requires:       %{name} = %{version}-%{release}
126 Requires:       bash-completion >= 1:2.0
127 BuildArch:      noarch
128
129 %description -n bash-completion-createrepo_c
130 Bash completion for createrepo_c commands (createrepo_c, mergerepo_c,
131 modifyrepo_c).
132
133 %description -n bash-completion-createrepo_c -l pl.UTF-8
134 Bashowe uzupełnianie dla poleceń createrepo_c (createrepo_c,
135 mergerepo_c, modifyrepo_c).
136
137 %prep
138 %setup -q
139 %{?with_rpm5:%patch0 -p1}
140 %patch1 -p1
141
142 %build
143 install -d build
144 cd build
145 %cmake .. \
146         -DBASHCOMP_DIR=%{bash_compdir} \
147         -DPYTHON_DESIRED=3
148
149 %{__make}
150 %{__make} doc
151
152 %if %{with tests}
153 %{__make} tests
154 %{__make} test \
155         ARGS="-V"
156 %endif
157
158 %install
159 rm -rf $RPM_BUILD_ROOT
160
161 %{__make} -C build install \
162         DESTDIR=$RPM_BUILD_ROOT
163
164 %py3_comp $RPM_BUILD_ROOT%{py3_sitedir}/createrepo_c
165 %py3_ocomp $RPM_BUILD_ROOT%{py3_sitedir}/createrepo_c
166
167 %clean
168 rm -rf $RPM_BUILD_ROOT
169
170 %post   libs -p /sbin/ldconfig
171 %postun libs -p /sbin/ldconfig
172
173 %files
174 %defattr(644,root,root,755)
175 %attr(755,root,root) %{_bindir}/createrepo_c
176 %attr(755,root,root) %{_bindir}/mergerepo_c
177 %attr(755,root,root) %{_bindir}/modifyrepo_c
178 %attr(755,root,root) %{_bindir}/sqliterepo_c
179 %{_mandir}/man8/createrepo_c.8*
180 %{_mandir}/man8/mergerepo_c.8*
181 %{_mandir}/man8/modifyrepo_c.8*
182 %{_mandir}/man8/sqliterepo_c.8*
183
184 %files libs
185 %defattr(644,root,root,755)
186 %doc AUTHORS README.md
187 %attr(755,root,root) %{_libdir}/libcreaterepo_c.so.*.*.*
188 %attr(755,root,root) %ghost %{_libdir}/libcreaterepo_c.so.0
189
190 %files devel
191 %defattr(644,root,root,755)
192 %attr(755,root,root) %{_libdir}/libcreaterepo_c.so
193 %{_pkgconfigdir}/createrepo_c.pc
194 %{_includedir}/createrepo_c
195
196 %files apidocs
197 %defattr(644,root,root,755)
198 %doc build/doc/html
199
200 %files -n python3-createrepo_c
201 %defattr(644,root,root,755)
202 %dir %{py3_sitedir}/createrepo_c
203 %attr(755,root,root) %{py3_sitedir}/createrepo_c/_createrepo_c.so
204 %{py3_sitedir}/createrepo_c/__init__.py
205 %{py3_sitedir}/createrepo_c/__pycache__
206 %{py3_sitedir}/createrepo_c-%{version}-py*.egg-info
207
208 %files -n bash-completion-createrepo_c
209 %defattr(644,root,root,755)
210 %{bash_compdir}/createrepo_c
211 %{bash_compdir}/mergerepo_c
212 %{bash_compdir}/modifyrepo_c
213 %{bash_compdir}/sqliterepo_c
This page took 0.048964 seconds and 3 git commands to generate.