]> git.pld-linux.org Git - SPECS.git/blob - cpudyn.spec
SPECS updated Tue 30 Apr 15:06:09 CEST 2024
[SPECS.git] / cpudyn.spec
1 Summary:        A tools to control CPU frequency
2 Summary(pl.UTF-8):      Narzędzia do kontroli częstotliwości procesora
3 Name:           cpudyn
4 Version:        1.0.1
5 Release:        2
6 License:        GPL
7 Group:          Daemons
8 Source0:        http://mnm.uib.es/~gallir/cpudyn/download/%{name}-%{version}.tgz
9 # Source0-md5:  670d32eb953f99ba04aee44848864228
10 Source1:        %{name}.init
11 Source2:        %{name}.conf
12 URL:            http://mnm.uib.es/~gallir/cpudyn/
13 BuildRequires:  rpmbuild(macros) >= 1.268
14 Requires(post,preun):   /sbin/chkconfig
15 Requires:       rc-scripts
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %define         _sbindir        /sbin
19
20 %description
21 This program control the speed in Intel SpeedStep, Pentium 4 Mobile
22 and PowerPC machines with the cpufreq compiled in the kernel.
23
24 Tested with 2.4, Pentium 3 Speedstep Laptop (Dell Latitude), Pentium 4
25 Mobile Laptop (Dell Inspiron), AMD Power Now, Apple iBook, IBM
26 Thinkpad. cpudyn is just a user space program, so it will work on
27 every processor supported by the kernel's cpufreq driver.
28
29 %description -l pl.UTF-8
30 Ten program kontroluje prędkość procesorów Intel SpeedStep, Pentium 4
31 Mobile oraz PowerPC (o ile kernel został skompilowany z obsługą
32 cpufreq).
33
34 Program ten został przetestowany na jądrze 2.4, na Pentium 3 SpeedStep
35 (Dell Latitude), Pentium 4 Mobile (Dell Inspiron), AMD Power Now,
36 Apple iBook, IBM Thinkpad. cpudyn jest programem userspace, więc
37 będzie współpracował z każdym procesorem wspieranym przez sterownik
38 cpufreq.
39
40 %prep
41 %setup -q -n %{name}
42
43 %build
44 %{__make} \
45         CC="%{__cc}" \
46         CFLAGS="%{rpmcflags} -Wall"
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50 install -d $RPM_BUILD_ROOT{%{_sbindir},%{_sysconfdir},/etc/rc.d/init.d/,%{_mandir}/man8}
51
52 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/cpudynd
53 install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/cpudyn.conf
54 install cpudynd $RPM_BUILD_ROOT%{_sbindir}
55 install cpudynd.8 $RPM_BUILD_ROOT%{_mandir}/man8
56
57 %clean
58 rm -rf $RPM_BUILD_ROOT
59
60 %post
61 /sbin/chkconfig --add cpudynd
62 %service cpudynd restart
63
64 %preun
65 if [ "$1" = "0" ]; then
66         %service cpudynd stop
67         /sbin/chkconfig --del cpudynd
68 fi
69
70 %files
71 %defattr(644,root,root,755)
72 %doc README faq.html
73 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/cpudyn.conf
74 %attr(755,root,root) %{_sbindir}/cpudynd
75 %attr(754,root,root) /etc/rc.d/init.d/cpudynd
76 %{_mandir}/man8/*
This page took 0.124933 seconds and 3 git commands to generate.