]> git.pld-linux.org Git - packages/colord-gtk.git/blob - colord-gtk.spec
noarch vala subpackage
[packages/colord-gtk.git] / colord-gtk.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # do not build and package API docs
4 %bcond_without  static_libs     # don't build static libraries
5 %bcond_without  gtk2            # additional GTK+ 2.x version of library
6 %bcond_without  vala            # don't build Vala API
7
8 %define colord_ver      0.1.27
9 Summary:        GTK helper library for colord
10 Summary(pl.UTF-8):      Biblioteka pomocniczna GTK dla colord
11 Name:           colord-gtk
12 Version:        0.1.26
13 Release:        4
14 License:        LGPL v2.1+ (library), GPL v2+ (cd-convert utility)
15 Group:          X11/Libraries
16 Source0:        http://www.freedesktop.org/software/colord/releases/%{name}-%{version}.tar.xz
17 # Source0-md5:  bb9d6f3c037152ad791003375aa6c16c
18 URL:            http://www.freedesktop.org/software/colord/
19 BuildRequires:  autoconf >= 2.63
20 BuildRequires:  automake >= 1:1.9
21 BuildRequires:  colord-devel >= %{colord_ver}
22 BuildRequires:  gettext-tools >= 0.17
23 BuildRequires:  glib2-devel >= 1:2.28.0
24 BuildRequires:  gobject-introspection-devel >= 0.9.8
25 %{?with_gtk2:BuildRequires:     gtk+2-devel >= 2.0}
26 BuildRequires:  gtk+3-devel >= 3.0
27 BuildRequires:  gtk-doc >= 1.9
28 BuildRequires:  intltool >= 0.40.0
29 BuildRequires:  lcms2-devel >= 2.2
30 BuildRequires:  libtool >= 2:2.0
31 BuildRequires:  pkgconfig
32 BuildRequires:  rpmbuild(macros) >= 1.644
33 %if %{with vala}
34 BuildRequires:  vala
35 BuildRequires:  vala-colord >= %{colord_ver}
36 %endif
37 Requires:       colord-libs >= %{colord_ver}
38 Requires:       glib2 >= 1:2.28.0
39 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41 %description
42 GTK helper library for colord.
43
44 %description -l pl.UTF-8
45 Biblioteka pomocniczna GTK dla colord.
46
47 %package devel
48 Summary:        Header files for colord-gtk library
49 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki colord-gtk
50 Group:          X11/Development/Libraries
51 Requires:       %{name} = %{version}-%{release}
52 Requires:       colord-devel >= %{colord_ver}
53 Requires:       glib2-devel >= 1:2.28.0
54 Requires:       gtk+3-devel >= 3.0
55
56 %description devel
57 Header files for colord-gtk library.
58
59 %description devel -l pl.UTF-8
60 Pliki nagłówkowe biblioteki colord-gtk.
61
62 %package static
63 Summary:        Static colord-gtk library
64 Summary(pl.UTF-8):      Statyczna biblioteka colord-gtk
65 Group:          X11/Development/Libraries
66 Requires:       %{name}-devel = %{version}-%{release}
67
68 %description static
69 Static colord-gtk library.
70
71 %description static -l pl.UTF-8
72 Statyczna biblioteka colord-gtk.
73
74 %package apidocs
75 Summary:        colord-gtk API documentation
76 Summary(pl.UTF-8):      Dokumentacja API colord-gtk
77 Group:          Documentation
78 Requires:       gtk-doc-common
79
80 %description apidocs
81 colord-gtk API documentation.
82
83 %description apidocs -l pl.UTF-8
84 Dokumentacja API colord-gtk.
85
86 %package -n vala-colord-gtk
87 Summary:        colord-gtk API for Vala language
88 Summary(pl.UTF-8):      API colord-gtk dla języka Vala
89 Group:          X11/Development/Libraries
90 Requires:       %{name}-devel = %{version}-%{release}
91 Requires:       vala-colord >= %{colord_ver}
92 %if "%{_rpmversion}" >= "5"
93 BuildArch:      noarch
94 %endif
95
96 %description -n vala-colord-gtk
97 colord-gtk API for Vala language.
98
99 %description -n vala-colord-gtk -l pl.UTF-8
100 API colord-gtk dla języka Vala.
101
102 %package -n colord-gtk2
103 Summary:        GTK 2 helper library for colord
104 Summary(pl.UTF-8):      Biblioteka pomocniczna GTK 2 dla colord
105 Group:          X11/Libraries
106 Requires:       colord-libs >= %{colord_ver}
107 Requires:       glib2 >= 1:2.28.0
108
109 %description -n colord-gtk2
110 GTK 2 helper library for colord.
111
112 %description -n colord-gtk2 -l pl.UTF-8
113 Biblioteka pomocniczna GTK 2 dla colord.
114
115 %package -n colord-gtk2-devel
116 Summary:        Development files for colord-gtk2 library
117 Summary(pl.UTF-8):      Pliki programistyczne biblioteki colord-gtk2
118 Group:          X11/Development/Libraries
119 Requires:       %{name}-devel = %{version}-%{release}
120 Requires:       colord-gtk2 = %{version}-%{release}
121 Requires:       gtk+2-devel >= 2.0
122
123 %description -n colord-gtk2-devel
124 Development files for colord-gtk2 library.
125
126 %description -n colord-gtk2-devel -l pl.UTF-8
127 Pliki programistyczne biblioteki colord-gtk2.
128
129 %package -n colord-gtk2-static
130 Summary:        Static colord-gtk2 library
131 Summary(pl.UTF-8):      Statyczna biblioteka colord-gtk2
132 Group:          X11/Development/Libraries
133 Requires:       colord-gtk2-devel = %{version}-%{release}
134
135 %description -n colord-gtk2-static
136 Static colord-gtk2 library.
137
138 %description -n colord-gtk2-static -l pl.UTF-8
139 Statyczna biblioteka colord-gtk2.
140
141 %prep
142 %setup -q
143
144 %build
145 %{__intltoolize}
146 %{__libtoolize}
147 %{__aclocal} -I m4
148 %{__autoconf}
149 %{__autoheader}
150 %{__automake}
151 %configure \
152         --disable-silent-rules \
153         %{__enable_disable apidocs gtk-doc} \
154         %{?with_gtk2:--enable-gtk2} \
155         %{__enable_disable static_libs static} \
156         %{?with_vala:--enable-vala} \
157         --with-html-dir=%{_gtkdocdir}
158
159 # docs build seems racy
160 %{__make} -j1
161
162 %install
163 rm -rf $RPM_BUILD_ROOT
164
165 %{__make} install \
166         DESTDIR=$RPM_BUILD_ROOT
167
168 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
169
170 # only empty translation exists atm. (as of 0.1.26)
171 #find_lang %{name}
172
173 %clean
174 rm -rf $RPM_BUILD_ROOT
175
176 %post   -p /sbin/ldconfig
177 %postun -p /sbin/ldconfig
178
179 %post   -n colord-gtk2 -p /sbin/ldconfig
180 %postun -n colord-gtk2 -p /sbin/ldconfig
181
182 %files
183 %defattr(644,root,root,755)
184 # -f %{name}.lang
185 %defattr(644,root,root,755)
186 %doc AUTHORS MAINTAINERS NEWS README TODO
187 %attr(755,root,root) %{_bindir}/cd-convert
188 %attr(755,root,root) %{_libdir}/libcolord-gtk.so.*.*.*
189 %attr(755,root,root) %ghost %{_libdir}/libcolord-gtk.so.1
190 %{_libdir}/girepository-1.0/ColordGtk-1.0.typelib
191 %{_mandir}/man1/cd-convert.1*
192
193 %files devel
194 %defattr(644,root,root,755)
195 %attr(755,root,root) %{_libdir}/libcolord-gtk.so
196 %{_includedir}/colord-1/colord-gtk.h
197 %{_includedir}/colord-1/colord-gtk
198 %{_datadir}/gir-1.0/ColordGtk-1.0.gir
199 %{_pkgconfigdir}/colord-gtk.pc
200
201 %if %{with static_libs}
202 %files static
203 %defattr(644,root,root,755)
204 %{_libdir}/libcolord-gtk.a
205 %endif
206
207 %if %{with apidocs}
208 %files apidocs
209 %defattr(644,root,root,755)
210 %{_gtkdocdir}/colord-gtk
211 %endif
212
213 %if %{with vala}
214 %files -n vala-colord-gtk
215 %defattr(644,root,root,755)
216 %{_datadir}/vala/vapi/colord-gtk.vapi
217 %endif
218
219 %if %{with gtk2}
220 %files -n colord-gtk2
221 %defattr(644,root,root,755)
222 %attr(755,root,root) %{_libdir}/libcolord-gtk2.so.*.*.*
223 %attr(755,root,root) %ghost %{_libdir}/libcolord-gtk2.so.1
224
225 %files -n colord-gtk2-devel
226 %defattr(644,root,root,755)
227 %attr(755,root,root) %{_libdir}/libcolord-gtk2.so
228 %{_pkgconfigdir}/colord-gtk2.pc
229
230 %if %{with static_libs}
231 %files -n colord-gtk2-static
232 %defattr(644,root,root,755)
233 %{_libdir}/libcolord-gtk2.a
234 %endif
235 %endif
This page took 0.958362 seconds and 4 git commands to generate.