]> git.pld-linux.org Git - packages/colord-gtk.git/blob - colord-gtk.spec
- updated to 0.1.24
[packages/colord-gtk.git] / colord-gtk.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # do not build and package API docs
4 %bcond_without  static_libs     # don't build static libraries
5 %bcond_without  vala            # don't build Vala API
6 #
7 %define colord_ver      0.1.23
8 Summary:        GTK helper library for colord
9 Summary(pl.UTF-8):      Biblioteka pomocniczna GTK dla colord
10 Name:           colord-gtk
11 Version:        0.1.24
12 Release:        1
13 License:        GPL v2+ and LGPL v2+
14 Group:          Libraries
15 Source0:        http://www.freedesktop.org/software/colord/releases/%{name}-%{version}.tar.xz
16 # Source0-md5:  c2c63d7da6e9d512cc95c676661e35f0
17 URL:            http://www.freedesktop.org/software/colord/
18 BuildRequires:  autoconf >= 2.63
19 BuildRequires:  automake >= 1:1.9
20 BuildRequires:  colord-devel >= %{colord_ver}
21 BuildRequires:  gettext-devel >= 0.17
22 BuildRequires:  glib2-devel >= 1:2.28.0
23 BuildRequires:  gobject-introspection-devel >= 0.9.8
24 BuildRequires:  gtk+3-devel >= 3.0
25 BuildRequires:  gtk-doc >= 1.9
26 BuildRequires:  intltool >= 0.40.0
27 BuildRequires:  lcms2-devel >= 2.2
28 BuildRequires:  libtool >= 2:2.0
29 BuildRequires:  pkgconfig
30 BuildRequires:  rpmbuild(macros) >= 1.644
31 %if %{with vala}
32 BuildRequires:  vala
33 BuildRequires:  vala-colord >= %{colord_ver}
34 %endif
35 Requires:       colord-libs >= %{colord_ver}
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %description
39 GTK helper library for colord.
40
41 %description -l pl.UTF-8
42 Biblioteka pomocniczna GTK dla colord.
43
44 %package devel
45 Summary:        Header files for colord-gtk library
46 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki colord-gtk
47 Group:          Development/Libraries
48 Requires:       %{name} = %{version}-%{release}
49 Requires:       colord-devel >= %{colord_ver}
50 Requires:       gtk+3-devel >= 3.0
51
52 %description devel
53 Header files for colord-gtk library.
54
55 %description devel -l pl.UTF-8
56 Pliki nagłówkowe biblioteki colord-gtk.
57
58 %package static
59 Summary:        Static colord-gtk library
60 Summary(pl.UTF-8):      Statyczna biblioteka colord-gtk
61 Group:          Development/Libraries
62 Requires:       %{name}-devel = %{version}-%{release}
63
64 %description static
65 Static colord-gtk library.
66
67 %description static -l pl.UTF-8
68 Statyczna biblioteka colord-gtk.
69
70 %package apidocs
71 Summary:        colord-gtk API documentation
72 Summary(pl.UTF-8):      Dokumentacja API colord-gtk
73 Group:          Documentation
74 Requires:       gtk-doc-common
75
76 %description apidocs
77 colord-gtk API documentation.
78
79 %description apidocs -l pl.UTF-8
80 Dokumentacja API colord-gtk.
81
82 %package -n vala-colord-gtk
83 Summary:        colord-gtk API for Vala language
84 Summary(pl.UTF-8):      API colord-gtk dla języka Vala
85 Group:          Development/Libraries
86 Requires:       %{name}-devel = %{version}-%{release}
87 Requires:       vala-colord >= %{colord_ver}
88
89 %description -n vala-colord-gtk
90 colord-gtk API for Vala language.
91
92 %description -n vala-colord-gtk -l pl.UTF-8
93 API colord-gtk dla języka Vala.
94
95 %prep
96 %setup -q
97
98 %build
99 %{__intltoolize}
100 %{__libtoolize}
101 %{__aclocal} -I m4
102 %{__autoconf}
103 %{__autoheader}
104 %{__automake}
105 %configure \
106         --disable-silent-rules \
107         %{__enable_disable apidocs gtk-doc} \
108         %{__enable_disable static_libs static} \
109         %{?with_vala:--enable-vala} \
110         --with-html-dir=%{_gtkdocdir}
111
112 %{__make}
113
114 %install
115 rm -rf $RPM_BUILD_ROOT
116
117 %{__make} install \
118         DESTDIR=$RPM_BUILD_ROOT
119
120 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
121
122 # only empty translation exists atm. (as of 0.1.22)
123 #find_lang %{name}
124
125 %clean
126 rm -rf $RPM_BUILD_ROOT
127
128 %post   -p /sbin/ldconfig
129 %postun -p /sbin/ldconfig
130
131 %files
132 # -f %{name}.lang
133 %defattr(644,root,root,755)
134 %doc AUTHORS MAINTAINERS NEWS README TODO
135 %attr(755,root,root) %{_libdir}/libcolord-gtk.so.*.*.*
136 %attr(755,root,root) %ghost %{_libdir}/libcolord-gtk.so.1
137 %{_libdir}/girepository-1.0/ColordGtk-1.0.typelib
138
139 %files devel
140 %defattr(644,root,root,755)
141 %attr(755,root,root) %{_libdir}/libcolord-gtk.so
142 %{_includedir}/colord-1/colord-gtk.h
143 %{_includedir}/colord-1/colord-gtk
144 %{_datadir}/gir-1.0/ColordGtk-1.0.gir
145 %{_pkgconfigdir}/colord-gtk.pc
146
147 %if %{with static_libs}
148 %files static
149 %defattr(644,root,root,755)
150 %{_libdir}/libcolord-gtk.a
151 %endif
152
153 %if %{with apidocs}
154 %files apidocs
155 %defattr(644,root,root,755)
156 %{_gtkdocdir}/colord-gtk
157 %endif
158
159 %if %{with vala}
160 %files -n vala-colord-gtk
161 %defattr(644,root,root,755)
162 %{_datadir}/vala/vapi/colord-gtk.vapi
163 %endif
This page took 0.117091 seconds and 3 git commands to generate.