]> git.pld-linux.org Git - packages/cogl.git/blob - cogl.spec
3f509620122667f2907ee22b58d20fc782aec3ca
[packages/cogl.git] / cogl.spec
1 #
2 # Conditional build
3 %bcond_without  static_libs     # static libraries
4 %bcond_with     gdkpixbuf       # gdk-pixbuf for image loading [instead of stb_image]
5 #
6 Summary:        A library for using 3D graphics hardware to draw pretty pictures
7 Summary(pl.UTF-8):      Biblioteka do rysowania ładnych obrazków przy użyciu sprzętowej grafiki 3D
8 Name:           cogl
9 Version:        1.14.0
10 Release:        1
11 License:        LGPL v2+
12 Group:          Libraries
13 Source0:        http://ftp.gnome.org/pub/GNOME/sources/cogl/1.14/%{name}-%{version}.tar.xz
14 # Source0-md5:  7eabaf4241c0b87cc9e3b0fa23fd0315
15 URL:            http://www.clutter-project.org/
16 BuildRequires:  OpenGL-GLX-devel
17 BuildRequires:  autoconf >= 2.59
18 BuildRequires:  automake >= 1:1.11
19 BuildRequires:  cairo-devel >= 1.10
20 %{?with_gdkpixbuf:BuildRequires:        gdk-pixbuf2-devel >= 2.0}
21 BuildRequires:  gettext-devel >= 0.18.1
22 BuildRequires:  glib2-devel >= 1:2.32.0
23 BuildRequires:  gobject-introspection-devel >= 0.9.5
24 BuildRequires:  gtk-doc >= 1.13
25 BuildRequires:  libdrm-devel
26 BuildRequires:  libtool >= 2:2.2.6
27 BuildRequires:  pango-devel >= 1:1.20
28 BuildRequires:  pkgconfig
29 BuildRequires:  tar >= 1:1.22
30 BuildRequires:  xorg-lib-libX11-devel
31 BuildRequires:  xorg-lib-libXcomposite-devel >= 0.4
32 BuildRequires:  xorg-lib-libXdamage-devel
33 BuildRequires:  xorg-lib-libXext-devel
34 BuildRequires:  xorg-lib-libXfixes-devel >= 3
35 BuildRequires:  xorg-lib-libXrandr-devel >= 1.2
36 BuildRequires:  xz
37 Requires:       cairo >= 1.10
38 Requires:       glib2 >= 1:2.32.0
39 Requires:       pango >= 1:1.20
40 Requires:       xorg-lib-libXcomposite >= 0.4
41 Requires:       xorg-lib-libXfixes >= 3
42 Requires:       xorg-lib-libXrandr >= 1.2
43 Suggests:       OpenGL
44 Conflicts:      clutter < 1.8.0
45 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
46
47 %description
48 Cogl is a small open source library for using 3D graphics hardware to
49 draw pretty pictures. The API departs from the flat state machine
50 style of OpenGL and is designed to make it easy to write orthogonal
51 components that can render without stepping on each others toes.
52
53 %description -l pl.UTF-8
54 Cogl to mała biblioteka o otwartych źródłach, pozwalająca na rysowanie
55 ładnych rysunków przy użyciu sprzętu graficznego 3D. API wywodzi się z
56 automatu skończonego w stylu OpenGL i zostało tak zaprojektowane, aby
57 ułatwić pisanie ortogonalnych komponentów, potrafiących renderować bez
58 przeszkadzania sobie nawzajem.
59
60 %package devel
61 Summary:        Header files for cogl library
62 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki cogl
63 Group:          Development/Libraries
64 Requires:       %{name} = %{version}-%{release}
65 Requires:       cairo-devel >= 1.10
66 %{?with_gdkpixbuf:Requires:     gdk-pixbuf2-devel >= 2.0}
67 Requires:       glib2-devel >= 1:2.32.0
68 Requires:       gobject-introspection-devel >= 0.9.5
69 Requires:       libdrm-devel
70 Requires:       pango-devel >= 1:1.20
71 Requires:       xorg-lib-libXcomposite-devel >= 0.4
72 Requires:       xorg-lib-libXdamage-devel
73 Requires:       xorg-lib-libXext-devel
74 Requires:       xorg-lib-libXfixes-devel >= 3
75 Requires:       xorg-lib-libXrandr-devel >= 1.2
76 Conflicts:      clutter-devel < 1.8.0
77
78 %description devel
79 Header files for building and developing applications with cogl.
80
81 %description devel -l pl.UTF-8
82 Pliki nagłówkowe do tworzenia aplikacji z użyciem biblioteki cogl.
83
84 %package static
85 Summary:        Static cogl libraries
86 Summary(pl.UTF-8):      Statyczne biblioteki cogl
87 Group:          Development/Libraries
88 Requires:       %{name}-devel = %{version}-%{release}
89 Conflicts:      clutter-static < 1.8.0
90
91 %description static
92 Static cogl libraries.
93
94 %description static -l pl.UTF-8
95 Statyczne biblioteki cogl.
96
97 %package doc
98 Summary:        API documentation for cogl
99 Summary(pl.UTF-8):      Dokumentacja API cogl
100 Group:          Documentation
101
102 %description doc
103 This package contains API documentation for cogl.
104
105 %description doc -l pl.UTF-8
106 Ten pakiet zawiera dokumentację API cogl.
107
108 %prep
109 %setup -q
110
111 %build
112 %{__gettextize}
113 %{__libtoolize}
114 %{__aclocal} -I build/autotools
115 %{__autoconf}
116 %{__autoheader}
117 %{__automake}
118 %configure \
119         %{!?with_gdkpixbuf:--disable-gdk-pixbuf} \
120         --disable-silent-rules \
121         --enable-cairo \
122         --enable-cogl-pango \
123         --enable-glx \
124         --enable-gtk-doc \
125         --enable-introspection \
126         %{?with_static_libs:--enable-static} \
127         --with-html-dir=%{_gtkdocdir}
128 %{__make}
129
130 %install
131 rm -rf $RPM_BUILD_ROOT
132
133 %{__make} install \
134         DESTDIR=$RPM_BUILD_ROOT
135
136 # obsoleted by pkg-config
137 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libcogl.la
138 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libcogl-pango.la
139
140 %find_lang %{name}
141
142 %clean
143 rm -rf $RPM_BUILD_ROOT
144
145 %post   -p /sbin/ldconfig
146 %postun -p /sbin/ldconfig
147
148 %files -f %{name}.lang
149 %defattr(644,root,root,755)
150 %doc ChangeLog NEWS README
151 %attr(755,root,root) %{_libdir}/libcogl.so.*.*.*
152 %attr(755,root,root) %ghost %{_libdir}/libcogl.so.12
153 %attr(755,root,root) %{_libdir}/libcogl-pango.so.*.*.*
154 %attr(755,root,root) %ghost %{_libdir}/libcogl-pango.so.12
155 %{_libdir}/girepository-1.0/Cogl-1.0.typelib
156 %{_libdir}/girepository-1.0/CoglPango-1.0.typelib
157
158 %files devel
159 %defattr(644,root,root,755)
160 %attr(755,root,root) %{_libdir}/libcogl.so
161 %attr(755,root,root) %{_libdir}/libcogl-pango.so
162 %{_includedir}/cogl
163 %{_pkgconfigdir}/cogl-1.0.pc
164 %{_pkgconfigdir}/cogl-2.0-experimental.pc
165 %{_pkgconfigdir}/cogl-gl-1.0.pc
166 %{_pkgconfigdir}/cogl-pango-1.0.pc
167 %{_pkgconfigdir}/cogl-pango-2.0-experimental.pc
168 %{_datadir}/gir-1.0/Cogl-1.0.gir
169 %{_datadir}/gir-1.0/CoglPango-1.0.gir
170
171 %if %{with static_libs}
172 %files static
173 %defattr(644,root,root,755)
174 %{_libdir}/libcogl.a
175 %{_libdir}/libcogl-pango.a
176 %endif
177
178 %files doc
179 %defattr(644,root,root,755)
180 %{_gtkdocdir}/cogl
181 %{_gtkdocdir}/cogl-2.0-experimental
This page took 0.075922 seconds and 2 git commands to generate.