]> git.pld-linux.org Git - packages/clearsilver.git/blob - clearsilver.spec
9846a9f2d5f6a2b616aa81f3875a75e15353e026
[packages/clearsilver.git] / clearsilver.spec
1 Summary:        ClearSilver HTML template system
2 Name:           clearsilver
3 Version:        0.9.13
4 Release:        0.1
5 License:        Apache License style
6 Group:          Development/Libraries
7 URL:            http://www.clearsilver.net/
8 Source0:        http://www.clearsilver.net/downloads/%{name}-%{version}.tar.gz
9 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
10 BuildRequires:  zlib-devel
11 BuildRequires:  python-devel
12 BuildRequires:  automake
13 BuildRequires:  autoconf
14
15 %description
16 ClearSilver is a fast, powerful, and language-neutral HTML template
17 system. In both static content sites and dynamic HTML applications, it
18 provides a separation between presentation code and application logic
19 which makes working with your project easier.
20
21 %package devel
22 Summary:        ClearSilver development package
23 Group:          Development/Libraries
24
25 %description devel
26 This package provides needed files to develop extension to
27 ClearSilver.
28
29 %package -n python-clearsilver
30 Summary:        Neotonic ClearSilver Python Module
31 Group:          Development/Libraries
32 Requires:       %{name} = %{version}-%{release}
33
34 %description -n python-clearsilver
35 This package provides a python interface to the clearsilver CGI kit
36 and templating system.
37
38 %package -n perl-ClearSilver
39 Summary:        Neotonic ClearSilver Perl Module
40 Group:          Development/Libraries
41 Requires:       %{name} = %{version}-%{release}
42
43 %description -n perl-ClearSilver
44 The clearsilver-perl package provides a perl interface to the
45 clearsilver templating system.
46
47 %package -n ruby-clearsilver
48 Summary:        Neotonic ClearSilver Ruby Module
49 Group:          Development/Libraries
50 Requires:       %{name} = %{version}-%{release}
51
52 %description -n ruby-clearsilver
53 The clearsilver-ruby package provides a ruby interface to the
54 clearsilver templating system.
55
56 %prep
57 %setup -q
58
59 %build
60 install /usr/share/automake/config.* .
61 %{__aclocal}
62 %{__autoconf}
63 %configure \
64         --enable-apache \
65         --enable-python=%{_bindir}/python \
66         --enable-perl \
67         --disable-csharp \
68         --disable-ruby \
69         --disable-java
70
71 %{__make}
72
73 %install
74 rm -rf $RPM_BUILD_ROOT
75
76 %{__make} install \
77         DESTDIR="$RPM_BUILD_ROOT" \
78         INSTALLDIRS="vendor"
79
80 %{__make} install -C python \
81         DESTDIR="$RPM_BUILD_ROOT"
82
83 %{__make} install -C perl \
84         DESTDIR="$RPM_BUILD_ROOT" \
85         INSTALLDIRS="vendor"
86
87 %{__rm} -rf $RPM_BUILD_ROOT%{perl_archlib} \
88                 $RPM_BUILD_ROOT%{perl_vendorarch}/auto/*{,/*{,/*}}/.packlist
89
90 %clean
91 %{__rm} -rf $RPM_BUILD_ROOT
92
93 %files
94 %defattr(644,root,root,755)
95 %doc CS_LICENSE INSTALL LICENSE README scripts/cs_lint.py contrib/cs-mode.el
96 %doc %{_mandir}/man3/*.3.*
97 %attr(755,root,root) %{_bindir}/*
98
99 %files devel
100 %defattr(644,root,root,755)
101 %{_includedir}/ClearSilver/
102 %{_libdir}/libneo_*.a
103
104 %files -n python-clearsilver
105 %defattr(644,root,root,755)
106 %doc README.python
107 %{_libdir}/python*/site-packages/neo_cgi.so
108
109 %files -n perl-ClearSilver
110 %defattr(644,root,root,755)
111 %doc %{_mandir}/man3/*.3pm*
112 %{perl_vendorarch}/ClearSilver.pm
113 %{perl_vendorarch}/auto/ClearSilver/
114
115 #%files -n ruby
116 #%defattr(-, root, root, 0755)
117 #{ruby_sitepath}/(ruby_version}/neo.rb
118 #{ruby_sitepath}/(ruby_version}/$(ruby_arch}/hdf.so
119
120 #%files -n mod_ecs
121 #{apache_libexec}/mod_ecs.so
This page took 0.031817 seconds and 3 git commands to generate.