]> git.pld-linux.org Git - SPECS.git/blob - cjose.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / cjose.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # API documentation
4 %bcond_without  static_libs     # static library
5 #
6 Summary:        JOSE implementation for C
7 Summary(pl.UTF-8):      Implementacja JOSE dla C
8 Name:           cjose
9 Version:        0.6.1
10 Release:        1
11 License:        MIT
12 Group:          Libraries
13 #Source0Download: https://github.com/cisco/cjose/releases
14 Source0:        https://github.com/cisco/cjose/archive/%{version}/%{name}-%{version}.tar.gz
15 # Source0-md5:  7618e839ea0ecfa38355fa7f58391f88
16 URL:            https://github.com/cisco/cjose
17 BuildRequires:  autoconf >= 2.69
18 BuildRequires:  automake >= 1:1.14
19 BuildRequires:  check-devel >= 0.9.4
20 %{?with_apidocs:BuildRequires:  doxygen >= 1.8}
21 BuildRequires:  gcc >= 6:4.5
22 BuildRequires:  jansson-devel >= 2.3
23 BuildRequires:  libtool >= 2:2.2
24 BuildRequires:  make >= 3.81
25 BuildRequires:  openssl-devel >= 1.0.1
26 BuildRequires:  pkgconfig >= 1:0.20
27 Requires:       jansson >= 2.3
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 Implementation of JOSE (JavaScript Object Signing and Encryption) for
32 C/C++.
33
34 %description -l pl.UTF-8
35 Implementacja JOSE (JavaScript Object Signing and Encryption) dla
36 C/C++.
37
38 %package devel
39 Summary:        Header files for cjose library
40 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki cjose
41 Group:          Development/Libraries
42 Requires:       %{name} = %{version}-%{release}
43 Requires:       jansson-devel >= 2.3
44 Requires:       openssl-devel >= 1.0.1
45
46 %description devel
47 Header files for cjose library.
48
49 %description devel -l pl.UTF-8
50 Pliki nagłówkowe biblioteki cjose.
51
52 %package static
53 Summary:        Static cjose library
54 Summary(pl.UTF-8):      Statyczna biblioteka cjose
55 Group:          Development/Libraries
56 Requires:       %{name}-devel = %{version}-%{release}
57
58 %description static
59 Static cjose library.
60
61 %description static -l pl.UTF-8
62 Statyczna biblioteka cjose.
63
64 %package apidocs
65 Summary:        API documentation for cjose library
66 Summary(pl.UTF-8):      Dokumentacja API biblioteki cjose
67 Group:          Documentation
68 BuildArch:      noarch
69
70 %description apidocs
71 API documentation for cjose library.
72
73 %description apidocs -l pl.UTF-8
74 Dokumentacja API biblioteki cjose.
75
76 %prep
77 %setup -q
78
79 %build
80 %{__libtoolize}
81 %{__aclocal} -I m4
82 %{__autoconf}
83 %{__automake}
84 %configure \
85         %{!?with_apidocs:--disable-doxygen-doc} \
86         %{!?with_static_libs:--disable-static}
87 %{__make}
88
89 %install
90 rm -rf $RPM_BUILD_ROOT
91
92 %{__make} install \
93         DESTDIR=$RPM_BUILD_ROOT
94
95 # obsoleted by pkg-config
96 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libcjose.la
97
98 %clean
99 rm -rf $RPM_BUILD_ROOT
100
101 %post   -p /sbin/ldconfig
102 %postun -p /sbin/ldconfig
103
104 %files
105 %defattr(644,root,root,755)
106 %doc AUTHORS CHANGELOG.md LICENSE README.md
107 %attr(755,root,root) %{_libdir}/libcjose.so.*.*.*
108 %attr(755,root,root) %ghost %{_libdir}/libcjose.so.0
109
110 %files devel
111 %defattr(644,root,root,755)
112 %attr(755,root,root) %{_libdir}/libcjose.so
113 %{_includedir}/cjose
114 %{_pkgconfigdir}/cjose.pc
115
116 %if %{with static_libs}
117 %files static
118 %defattr(644,root,root,755)
119 %{_libdir}/libcjose.a
120 %endif
121
122 %if %{with apidocs}
123 %files apidocs
124 %defattr(644,root,root,755)
125 %doc doc/html/{search,*.css,*.html,*.png}
126 %endif
This page took 0.204845 seconds and 3 git commands to generate.