]> git.pld-linux.org Git - packages/chef.git/blob - chef.spec
R: lsb-release to identify as pld
[packages/chef.git] / chef.spec
1 # TODO
2 # - try not to use /var/chef
3 Summary:        A systems integration framework, built to bring the benefits of configuration management to your entire infrastructure
4 Name:           chef
5 Version:        11.4.0
6 Release:        0.5
7 License:        Apache v2.0
8 Group:          Development/Languages
9 Source0:        http://rubygems.org/downloads/%{name}-%{version}.gem
10 # Source0-md5:  1ebabd6fdeae44a99d5cb199c38adc15
11 URL:            http://wiki.opscode.com/display/chef
12 BuildRequires:  rpm-rubyprov
13 BuildRequires:  rpmbuild(macros) >= 1.656
14 Requires:       lsb-release
15 Requires:       ruby >= 1:1.8.7
16 Requires:       ruby-erubis
17 Requires:       ruby-highline >= 1.6.9
18 Requires:       ruby-json <= 1.7.7
19 Requires:       ruby-json >= 1.4.4
20 Requires:       ruby-mixlib-authentication >= 1.3.0
21 Requires:       ruby-mixlib-cli >= 1.3.0
22 Requires:       ruby-mixlib-config >= 1.1.2
23 Requires:       ruby-mixlib-log >= 1.3.0
24 Requires:       ruby-mixlib-shellout
25 Requires:       ruby-net-ssh >= 2.6
26 Requires:       ruby-net-ssh-multi >= 1.1.0
27 Requires:       ruby-ohai >= 0.6.0
28 Requires:       ruby-rest-client < 1.7.0
29 Requires:       ruby-rest-client >= 1.0.4
30 Requires:       ruby-rubygems
31 Requires:       ruby-yajl >= 1.1
32 BuildArch:      noarch
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %description
36 A systems integration framework, built to bring the benefits of
37 configuration management to your entire infrastructure.
38
39 %prep
40 %setup -q
41
42 %install
43 rm -rf $RPM_BUILD_ROOT
44 install -d $RPM_BUILD_ROOT{%{ruby_rubylibdir},%{_bindir}}
45 cp -a bin/* $RPM_BUILD_ROOT%{_bindir}
46 cp -a lib/* $RPM_BUILD_ROOT%{ruby_rubylibdir}
47
48 install -d $RPM_BUILD_ROOT{%{_sysconfdir},/var}/%{name}
49
50 %clean
51 rm -rf $RPM_BUILD_ROOT
52
53 %files
54 %defattr(644,root,root,755)
55 %doc README.md CONTRIBUTING.md
56 %dir %{_sysconfdir}/%{name}
57 %attr(755,root,root) %{_bindir}/chef-apply
58 %attr(755,root,root) %{_bindir}/chef-client
59 %attr(755,root,root) %{_bindir}/chef-shell
60 %attr(755,root,root) %{_bindir}/chef-solo
61 %attr(755,root,root) %{_bindir}/knife
62 %attr(755,root,root) %{_bindir}/shef
63 %{ruby_rubylibdir}/chef.rb
64 %{ruby_rubylibdir}/chef
65
66 # FIXME: FHS
67 %dir /var/%{name}
This page took 0.086608 seconds and 4 git commands to generate.