]> git.pld-linux.org Git - packages/chef.git/blob - chef.spec
update packaging
[packages/chef.git] / chef.spec
1 # TODO
2 # - try not to use /var/chef
3 Summary:        A systems integration framework, built to bring the benefits of configuration management to your entire infrastructure
4 Name:           chef
5 Version:        0.10.6
6 Release:        0.4
7 License:        Apache v2.0
8 Group:          Development/Languages
9 URL:            http://wiki.opscode.com/display/chef
10 Source0:        http://rubygems.org/downloads/%{name}-%{version}.gem
11 # Source0-md5:  ea8746476a2ec37e1f8265a9febba6b9
12 BuildRequires:  rpm-rubyprov
13 BuildRequires:  rpmbuild(macros) >= 1.656
14 Requires:       ruby >= 1:1.8.7
15 Requires:       ruby-bunny >= 0.6.0
16 Requires:       ruby-erubis
17 Requires:       ruby-mixlib-authentication >= 1.1.0
18 Requires:       ruby-mixlib-config >= 1.1.2
19 Requires:       ruby-mixlib-log >= 1.3.0
20 Requires:       ruby-moneta
21 Requires:       ruby-ohai >= 0.6
22 Requires:       ruby-rubygems
23 Requires:       ruby-uuidtools
24 BuildArch:      noarch
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 A systems integration framework, built to bring the benefits of
29 configuration management to your entire infrastructure.
30
31 %prep
32 %setup -q
33
34 %install
35 rm -rf $RPM_BUILD_ROOT
36 install -d $RPM_BUILD_ROOT{%{ruby_rubylibdir},%{_bindir}}
37
38 cp -a bin/* $RPM_BUILD_ROOT%{_bindir}
39 cp -a lib/* $RPM_BUILD_ROOT%{ruby_rubylibdir}
40
41 install -d $RPM_BUILD_ROOT{%{_sysconfdir},/var}/%{name}
42
43 %clean
44 rm -rf $RPM_BUILD_ROOT
45
46 %files
47 %defattr(644,root,root,755)
48 %doc README.rdoc
49 %dir %{_sysconfdir}/%{name}
50 %attr(755,root,root) %{_bindir}/chef-client
51 %attr(755,root,root) %{_bindir}/chef-solo
52 %attr(755,root,root) %{_bindir}/knife
53 %attr(755,root,root) %{_bindir}/shef
54 %{ruby_rubylibdir}/chef.rb
55 %{ruby_rubylibdir}/chef
56
57 # FIXME: FHS
58 %dir /var/%{name}
This page took 0.061916 seconds and 4 git commands to generate.