]> git.pld-linux.org Git - packages/chef.git/blob - chef.spec
up to 11.4.0
[packages/chef.git] / chef.spec
1 # TODO
2 # - try not to use /var/chef
3 Summary:        A systems integration framework, built to bring the benefits of configuration management to your entire infrastructure
4 Name:           chef
5 Version:        11.4.0
6 Release:        0.4
7 License:        Apache v2.0
8 Group:          Development/Languages
9 Source0:        http://rubygems.org/downloads/%{name}-%{version}.gem
10 # Source0-md5:  1ebabd6fdeae44a99d5cb199c38adc15
11 URL:            http://wiki.opscode.com/display/chef
12 BuildRequires:  rpm-rubyprov
13 BuildRequires:  rpmbuild(macros) >= 1.656
14 Requires:       ruby >= 1:1.8.7
15 Requires:       ruby-erubis
16 Requires:       ruby-highline >= 1.6.9
17 Requires:       ruby-json <= 1.7.7
18 Requires:       ruby-json >= 1.4.4
19 Requires:       ruby-mixlib-authentication >= 1.3.0
20 Requires:       ruby-mixlib-cli >= 1.3.0
21 Requires:       ruby-mixlib-config >= 1.1.2
22 Requires:       ruby-mixlib-log >= 1.3.0
23 Requires:       ruby-mixlib-shellout
24 Requires:       ruby-net-ssh >= 2.6
25 Requires:       ruby-net-ssh-multi >= 1.1.0
26 Requires:       ruby-ohai >= 0.6.0
27 Requires:       ruby-rest-client < 1.7.0
28 Requires:       ruby-rest-client >= 1.0.4
29 Requires:       ruby-rubygems
30 Requires:       ruby-yajl >= 1.1
31 BuildArch:      noarch
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 A systems integration framework, built to bring the benefits of
36 configuration management to your entire infrastructure.
37
38 %prep
39 %setup -q
40
41 %install
42 rm -rf $RPM_BUILD_ROOT
43 install -d $RPM_BUILD_ROOT{%{ruby_rubylibdir},%{_bindir}}
44 cp -a bin/* $RPM_BUILD_ROOT%{_bindir}
45 cp -a lib/* $RPM_BUILD_ROOT%{ruby_rubylibdir}
46
47 install -d $RPM_BUILD_ROOT{%{_sysconfdir},/var}/%{name}
48
49 %clean
50 rm -rf $RPM_BUILD_ROOT
51
52 %files
53 %defattr(644,root,root,755)
54 %doc README.md CONTRIBUTING.md
55 %dir %{_sysconfdir}/%{name}
56 %attr(755,root,root) %{_bindir}/chef-apply
57 %attr(755,root,root) %{_bindir}/chef-client
58 %attr(755,root,root) %{_bindir}/chef-shell
59 %attr(755,root,root) %{_bindir}/chef-solo
60 %attr(755,root,root) %{_bindir}/knife
61 %attr(755,root,root) %{_bindir}/shef
62 %{ruby_rubylibdir}/chef.rb
63 %{ruby_rubylibdir}/chef
64
65 # FIXME: FHS
66 %dir /var/%{name}
This page took 0.110942 seconds and 4 git commands to generate.