]> git.pld-linux.org Git - packages/cdrdao.git/blob - cdrdao.spec
- pass CFLAGS and __cc
[packages/cdrdao.git] / cdrdao.spec
1 #
2 # Conditional build:
3 %bcond_with     gnome   # build gcdmaster
4 %bcond_without  mp3     # without MP3 support
5 %bcond_without  ogg     # without Ogg support
6 #
7 Summary:        Tools for burning CDRs in Disk At Once mode
8 Summary(pl):    Narzêdzia do wypalania p³yt w trybie Disk At Once
9 Summary(pt_BR): Cdrdao - Escreve CD-Rs de áudio em modo "disk-at-once"
10 Name:           cdrdao
11 Version:        1.2.1
12 Release:        1
13 License:        GPL v2+
14 Group:          Applications/System
15 Source0:        http://dl.sourceforge.net/cdrdao/%{name}-%{version}.tar.gz
16 # Source0-md5:  d959c98e08105b5b8380de275bac1413
17 Source1:        %{name}.desktop
18 # http://cdrdao.sourceforge.net/drives.html#dt
19 Source2:        %{name}.drivers
20 Patch0:         %{name}-nolibs.patch
21 Patch1:         %{name}-pccts-antlr.patch
22 Patch2:         %{name}-gcc4.patch
23 URL:            http://cdrdao.sourceforge.net/
24 BuildRequires:  autoconf
25 BuildRequires:  automake
26 BuildRequires:  cdrtools-devel >= 3:2.01a25
27 %{?with_gnome:BuildRequires:    gtkmm-devel >= 2.4.0}
28 %{?with_mp3:BuildRequires:      lame-libs-devel >= 3.92}
29 %if %{with mp3} || %{with ogg}
30 BuildRequires:  libao-devel >= 0.8
31 %endif
32 %{?with_mp3:BuildRequires:      libmad-devel >= 0.15.1b-4}
33 %{?with_gnome:BuildRequires:    libgnomeuimm-devel >= 2.6.0}
34 BuildRequires:  libmad-devel >= 0.15.1b-4
35 %{?with_gnome:BuildRequires:    libsigc++-devel >= 2.0.0}
36 BuildRequires:  libstdc++-devel
37 %{?with_ogg:BuildRequires:      libvorbis-devel >= 1.0}
38 BuildRequires:  pccts >= 1.33MR33-8
39 BuildRequires:  pkgconfig
40 BuildRequires:  sed >= 4.0
41 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
42
43 %description
44 Cdrdao records audio and data CD-Rs in Disk At Once mode. This mode
45 gives much better control over contents of CD.
46
47 %description -l pl
48 Cdrdao zapisuje p³ytki audio i z danymi w trybie Disk At Once. W tym
49 trybie masz znacznie wiêksz± kontrolê nad zawarto¶ci± p³ytki.
50
51 %description -l pt_BR
52 Escreve CD-Rs de áudio em modo "disk-at-once" (DAO) permitindo
53 controle sobre pre-gaps (tamanho reduzido a 0, dados não zerados de
54 áudio) e informações de sub-canais como códigos ISRC. Todos os dados
55 que são escritos no disco devem ser especificados através de um
56 arquivo texto. Dados de áudio também podem estar no formato WAVE ou
57 raw.
58
59 %package gcdmaster
60 Summary:        GNOME frontend to cdrdao for composing audio CDs
61 Summary(pl):    Frontend GNOME do cdrdao do sk³adania p³yt CD-Audio
62 Group:          X11/Applications
63 Requires:       %{name} = %{version}-%{release}
64
65 %description gcdmaster
66 gcdmaster allows the creation of toc-files for cdrdao and can control
67 the recording process. Its main application is the composition of
68 audio CDs from one or more audio files. It supports PQ-channel
69 editing, entry of meta data like ISRC codes/CD-TEXT and non
70 destructive cut of the audio data.
71
72 %description gcdmaster -l pl
73 gcdmaster pozwala na tworzenie plików toc dla cdrdao oraz mo¿e
74 kontrolowaæ proces nagrywania. G³ównym celem jest sk³adanie p³yt
75 CD-Audio z jednego lub wiêcej plików z d¼wiêkiem. Obs³uguje edycjê
76 kana³u PQ, wpisy meta-danych takich jak kody ISRC/CD-TEXT oraz
77 niedestruktywne ciêcie danych audio.
78
79 %prep
80 %setup -q
81 %patch0 -p1
82 %patch1 -p1
83 %patch2 -p1
84
85 sed -i -e 's#/usr/src/linux/include##g' scsilib/DEFAULT*/Defaults.linux
86 %if %{without gnome}
87 sed -i -e 's/^en_xdao=yes$/en_xdao=no/' configure.ac
88 %endif
89
90 %build
91 %{__aclocal}
92 %{__autoconf}
93 %{__autoheader}
94 %{__automake}
95 PKG_CONFIG=%{_bindir}/pkg-config \
96 %configure \
97         --with-pcctsbin=%{_bindir} \
98         --with-pcctsinc=%{_libdir}/pccts/h \
99         --with-scglib-inc=%{_includedir}/schily \
100         --with-scglib-lib=%{_libdir} \
101         --with%{!?with_gnome:out}-xdao \
102         --with%{!?with_mp3:out}-mp3-support \
103         --with%{!?with_ogg:out}-ogg-support
104
105 %{__make} \
106         CC="%{__cc}" \
107         COPTOPT="%{rpmcflags}"
108
109 %install
110 rm -rf $RPM_BUILD_ROOT
111 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir},%{_datadir}/%{name}}
112
113 %{__make} install \
114         DESTDIR=$RPM_BUILD_ROOT
115
116 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}/gcdmaster.desktop
117 install %{SOURCE2} $RPM_BUILD_ROOT%{_datadir}/%{name}/drivers
118
119 %clean
120 rm -rf $RPM_BUILD_ROOT
121
122 %files
123 %defattr(644,root,root,755)
124 %doc CREDITS README README.PlexDAE 
125 %attr(755,root,root) %{_bindir}/cdrdao
126 %attr(755,root,root) %{_bindir}/toc2*
127 %attr(755,root,root) %{_bindir}/cue2toc
128 %{_datadir}/%{name}
129 %{_mandir}/man1/cdrdao.1*
130 %{_mandir}/man1/cue2toc.1*
131
132 %if %{with gnome}
133 %files gcdmaster
134 %defattr(644,root,root,755)
135 %attr(755,root,root) %{_bindir}/gcdmaster
136 %{_desktopdir}/gcdmaster.desktop
137 %{_pixmapsdir}/*
138 %{_mandir}/man1/gcdmaster.*
139 %endif
This page took 0.045796 seconds and 4 git commands to generate.