]> git.pld-linux.org Git - packages/ccnet.git/blob - ccnet.spec
rebuild with openssl 3.0.0
[packages/ccnet.git] / ccnet.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # build without tests
4
5 Summary:        A framework for writing networked applications in C
6 Name:           ccnet
7 Version:        6.1.8
8 Release:        3
9 License:        GPL v3
10 Group:          Libraries
11 Source0:        https://github.com/haiwen/ccnet/archive/v%{version}/%{name}-%{version}.tar.gz
12 # Source0-md5:  4bab2537f68070d5af226fc80b79c859
13 Patch0:         codegen.patch
14 URL:            https://github.com/haiwen/ccnet
15 BuildRequires:  autoconf
16 BuildRequires:  automake
17 BuildRequires:  glib2-devel
18 BuildRequires:  libevent-devel
19 BuildRequires:  libsearpc-devel
20 BuildRequires:  libtool
21 BuildRequires:  libuuid-devel
22 BuildRequires:  libzdb-devel >= 2.10.2
23 BuildRequires:  openssl-devel
24 BuildRequires:  python-devel
25 BuildRequires:  rpm-pythonprov
26 BuildRequires:  rpmbuild(macros) >= 1.714
27 BuildRequires:  sqlite-devel
28 BuildRequires:  vala >= 0.8
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 Ccnet is a framework for writing networked applications in C. It
33 provides the following basic services:
34
35 - Peer identification
36 - Connection Management
37 - Service invocation
38 - Message sending
39
40 In ccnet network, there are two types of nodes, i.e., client and
41 server. Server has the following functions:
42
43 - User management
44 - Group management
45 - Cluster management
46
47 %package devel
48 Summary:        Development files for %{name}
49 Group:          Development/Libraries
50 Requires:       %{name} = %{version}-%{release}
51 Requires:       glib2-devel
52 Requires:       libevent-devel
53 Requires:       libsearpc-devel
54
55 %description devel
56 The %{name}-devel package contains libraries and header files for
57 developing applications that use %{name}.
58
59 %prep
60 %setup -q
61 %patch0 -p1
62
63 # meh is this?
64 sed -i -e 's/(DESTDIR)//' libccnet.pc.in
65
66 %build
67 %{__libtoolize}
68 %{__aclocal} -I m4
69 %{__autoheader}
70 %{__automake} --gnu
71 %{__autoconf}
72 %configure \
73         --disable-static \
74         --disable-compile-demo \
75
76 %{__make}
77
78 %if %{with tests}
79 %{__make} check
80 %endif
81
82 %install
83 rm -rf $RPM_BUILD_ROOT
84 %{__make} install \
85         DESTDIR=$RPM_BUILD_ROOT
86
87 %py_postclean
88
89 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libccnet.la
90
91 %clean
92 rm -rf $RPM_BUILD_ROOT
93
94 %post   -p /sbin/ldconfig
95 %postun -p /sbin/ldconfig
96
97 %files
98 %defattr(644,root,root,755)
99 %doc README.markdown HACKING LICENSE.txt
100 %attr(755,root,root) %{_libdir}/libccnet.so.*.*.*
101 %ghost %{_libdir}/libccnet.so.0
102 %attr(755,root,root) %{_bindir}/ccnet
103 %attr(755,root,root) %{_bindir}/ccnet-init
104 %{py_sitedir}/ccnet
105
106 %files devel
107 %defattr(644,root,root,755)
108 %doc LICENSE.txt
109 %{_includedir}/ccnet.h
110 %{_includedir}/ccnet
111 %{_libdir}/libccnet.so
112 %{_pkgconfigdir}/libccnet.pc
This page took 0.047304 seconds and 3 git commands to generate.