]> git.pld-linux.org Git - packages/cancd.git/blob - cancd.spec
- Don't listen on the IRC port!
[packages/cancd.git] / cancd.spec
1 Summary:        The CA NetConsole Daemon
2 Summary(pl):    Demon CA NetConsole
3 Name:           cancd
4 Version:        0.1.0
5 Release:        0.5
6 License:        GPL
7 Group:          Applications/File
8 Source0:        http://oss.oracle.com/projects/cancd/dist/files/source/%{name}-%{version}.tar.gz
9 # Source0-md5:  3eb4a75cfa4d1a860ea547fdc76c6d4d
10 Source1:        %{name}.init
11 Source2:        %{name}.sysconfig
12 Patch0:         %{name}-make.patch
13 URL:            http://oss.oracle.com/projects/cancd/
14 BuildRequires:  rpmbuild(macros) >= 1.228
15 Requires(post,preun):   /sbin/chkconfig
16 Requires(postun):       /usr/sbin/groupdel
17 Requires(postun):       /usr/sbin/userdel
18 Requires(pre):  /bin/id
19 Requires(pre):  /usr/bin/getgid
20 Requires(pre):  /usr/sbin/groupadd
21 Requires(pre):  /usr/sbin/useradd
22 Requires:       /sbin/chkconfig
23 Requires:       rc-scripts >= 0.4.0.17
24 Provides:       group(cancd)
25 Provides:       user(cancd)
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 This is the CA NetConsole Daemon, a daemon to receive output from the
30 Linux netconsole driver.
31
32 %description -l pl
33 To jest demon CA NetConsole - demon odbieraj±cy wyj¶cie z linuksowego
34 sterownika netconsole (konsoli sieciowej).
35
36 %prep
37 %setup -q
38 %patch0 -p1
39
40 %build
41 %{__make} \
42         CC="%{__cc}" \
43         OPTFLAGS="%{rpmcflags}"
44
45 %install
46 rm -rf $RPM_BUILD_ROOT
47 install -d $RPM_BUILD_ROOT{/etc/{rc.d/init.d,sysconfig},/var/log/cancd}
48 %{__make} install \
49         DESTDIR=$RPM_BUILD_ROOT
50
51 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/cancd
52 install %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/cancd
53
54 %clean
55 rm -rf "$RPM_BUILD_ROOT"
56
57 %pre
58 %groupadd -g 162 cancd
59 %useradd -u 162 -c "CA NetConsole Daemon" -g cancd cancd
60
61 %post
62 /sbin/chkconfig --add cancd
63 %service cancd restart
64
65 %preun
66 if [ "$1" = "0" ]; then
67         %service cancd stop
68         /sbin/chkconfig --del cancd
69 fi
70
71 %postun
72 if [ "$1" = "0" ]; then
73         %userremove cancd
74         %groupremove cancd
75 fi
76
77 %files
78 %defattr(644,root,root,755)
79 %attr(755,root,root) %{_sbindir}/cancd
80 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/cancd
81 %attr(754,root,root) /etc/rc.d/init.d/cancd
82 %attr(770,root,cancd) %dir /var/log/cancd
This page took 0.051746 seconds and 3 git commands to generate.