]> git.pld-linux.org Git - packages/cairo.git/blob - cairo.spec
- Updated the lcd patch, taken from
[packages/cairo.git] / cairo.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # disable gtk-doc
4 %bcond_with     glitz           # build with glitz backend
5 %bcond_without  xcb             # XCB backend
6 %bcond_with     tests           # perform tests (can fail due to out of memory)
7 %bcond_without  lcd             # freetype LCD filtering (instead of internal)
8 #
9 Summary:        Cairo - multi-platform 2D graphics library
10 Summary(pl.UTF-8):      Cairo - wieloplatformowa biblioteka graficzna 2D
11 Name:           cairo
12 Version:        1.6.4
13 Release:        2
14 License:        LGPL v2.1 or MPL v1.1
15 Group:          Libraries
16 Source0:        http://cairographics.org/releases/%{name}-%{version}.tar.gz
17 # Source0-md5:  a198d509f9e3a35b78de8bb02174ebb9
18 Patch0:         %{name}-link.patch
19 Patch1:         %{name}-lt.patch
20 Patch2:         %{name}-am.patch
21 # The lcd patch is being maintained at
22 # http://bugs.freedesktop.org/show_bug.cgi?id=10301
23 Patch3:         %{name}-lcd-filter.patch
24 URL:            http://cairographics.org/
25 BuildRequires:  autoconf >= 2.58
26 BuildRequires:  automake >= 1:1.8
27 BuildRequires:  fontconfig-devel
28 %{!?with_lcd:BuildRequires:     freetype-devel >= 1:2.1.10}
29 %{?with_lcd:BuildRequires:      freetype-devel >= 1:2.3.0}
30 %{?with_glitz:BuildRequires:    glitz-devel >= 0.5.1}
31 %{?with_apidocs:BuildRequires:  gtk-doc >= 1.6}
32 BuildRequires:  libpng-devel
33 BuildRequires:  libtool
34 BuildRequires:  pixman-devel >= 0.10.0
35 BuildRequires:  pkgconfig
36 BuildRequires:  poppler-glib-devel >= 0.8.0
37 %if %{with xcb}
38 BuildRequires:  libxcb-devel >= 0.9.92
39 BuildRequires:  xcb-util-devel >= 0.2
40 %endif
41 BuildRequires:  xorg-lib-libXrender-devel >= 0.6
42 BuildRequires:  zlib-devel
43 %{!?with_lcd:Requires:  freetype >= 1:2.1.10}
44 %{?with_lcd:Requires:   freetype >= 1:2.3.0}
45 %{?with_glitz:Requires: glitz >= 0.5.1}
46 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
47
48 %description
49 Cairo provides anti-aliased vector-based rendering for X. Paths
50 consist of line segments and cubic splines and can be rendered at any
51 width with various join and cap styles. All colors may be specified
52 with optional translucence (opacity/alpha) and combined using the
53 extended Porter/Duff compositing algebra as found in the X Render
54 Extension.
55
56 Cairo exports a stateful rendering API similar in spirit to the path
57 construction, text, and painting operators of PostScript, (with the
58 significant addition of translucence in the imaging model). When
59 complete, the API is intended to support the complete imaging model of
60 PDF 1.4.
61
62 %description -l pl.UTF-8
63 Cairo obsługuje oparty na wektorach rendering z antyaliasingiem dla X.
64 Ścieżki składają się z odcinków i splajnów kubicznych, a renderowane
65 mogą być z dowolną grubością i różnymi stylami połączeń i zakończeń.
66 Wszystkie kolory mogą być podane z opcjonalną półprzezroczystością
67 (podaną przez współczynnik nieprzezroczystości lub alpha) i łączone
68 przy użyciu rozszerzonego algorytmu składania Portera-Duffa, który
69 można znaleźć w rozszerzeniu X Render.
70
71 Cairo eksportuje stanowe API renderujące w duchu podobne do operatorów
72 konstruowania ścieżek, tekstu i rysowania z PostScriptu (ze znacznym
73 dodatkiem półprzezroczystości w modelu obrazu). Kiedy API zostanie
74 ukończone, ma obsługiwać pełny model obrazu z PDF w wersji 1.4.
75
76 %package devel
77 Summary:        Development files for Cairo library
78 Summary(pl.UTF-8):      Pliki programistyczne biblioteki Cairo
79 Group:          Development/Libraries
80 Requires:       %{name} = %{version}-%{release}
81 Requires:       fontconfig-devel
82 Requires:       freetype-devel >= 1:2.1.10
83 %{?with_glitz:Requires: glitz-devel >= 0.5.1}
84 Requires:       libpng-devel
85 %{?with_xcb:Requires:   libxcb-devel >= 0.9.92}
86 Requires:       pixman-devel >= 0.10.0
87 %{?with_xcb:Requires:   xcb-util-devel >= 0.2}
88 Requires:       xorg-lib-libXrender-devel >= 0.6
89
90 %description devel
91 Development files for Cairo library.
92
93 %description devel -l pl.UTF-8
94 Pliki programistyczne biblioteki Cairo.
95
96 %package static
97 Summary:        Static Cairo library
98 Summary(pl.UTF-8):      Statyczna biblioteka Cairo
99 Group:          Development/Libraries
100 Requires:       %{name}-devel = %{version}-%{release}
101
102 %description static
103 Static Cairo library.
104
105 %description static -l pl.UTF-8
106 Statyczna biblioteka Cairo.
107
108 %package apidocs
109 Summary:        Cairo API documentation
110 Summary(pl.UTF-8):      Dokumentacja API Cairo
111 Group:          Documentation
112 Requires:       gtk-doc-common
113
114 %description apidocs
115 Cairo API documentation.
116
117 %description apidocs -l pl.UTF-8
118 Dokumentacja API Cairo.
119
120 %prep
121 %setup -q
122 %patch0 -p1
123 %patch1 -p1
124 %patch2 -p1
125 %{?with_lcd:%patch3 -p1}
126
127 %build
128 %{?with_apidocs:%{__gtkdocize}}
129 %{__libtoolize}
130 %{__aclocal}
131 %{__autoheader}
132 %{__autoconf}
133 %{__automake}
134 %configure \
135         %{?with_apidocs:--enable-gtk-doc} \
136         %{?with_xcb:--enable-xcb} \
137         %{?with_glitz:--enable-glitz} \
138         --enable-ps \
139         --enable-pdf \
140         --enable-png \
141         --enable-freetype \
142         --with-html-dir=%{_gtkdocdir}
143 %{__make}
144 %{?with_tests:%{__make} check}
145
146 %install
147 rm -rf $RPM_BUILD_ROOT
148
149 %{__make} install \
150         DESTDIR=$RPM_BUILD_ROOT
151
152 %{!?with_apidocs:rm -rf $RPM_BUILD_ROOT%{_gtkdocdir}/cairo}
153
154 %clean
155 rm -rf $RPM_BUILD_ROOT
156
157 %post   -p /sbin/ldconfig
158 %postun -p /sbin/ldconfig
159
160 %files
161 %defattr(644,root,root,755)
162 # COPYING contains only notes, not LGPL/MPL texts
163 %doc AUTHORS COPYING ChangeLog NEWS README
164 %attr(755,root,root) %{_libdir}/libcairo.so.*.*.*
165 %attr(755,root,root) %ghost %{_libdir}/libcairo.so.2
166
167 %files devel
168 %defattr(644,root,root,755)
169 %attr(755,root,root) %{_libdir}/libcairo.so
170 %{_libdir}/libcairo.la
171 %{_includedir}/cairo
172 %{_pkgconfigdir}/cairo.pc
173 %{_pkgconfigdir}/cairo-ft.pc
174 %{_pkgconfigdir}/cairo-pdf.pc
175 %{_pkgconfigdir}/cairo-png.pc
176 %{_pkgconfigdir}/cairo-ps.pc
177 %{_pkgconfigdir}/cairo-svg.pc
178 %{?with_xcb:%{_pkgconfigdir}/cairo-xcb.pc}
179 %{_pkgconfigdir}/cairo-xlib.pc
180 %{_pkgconfigdir}/cairo-xlib-xrender.pc
181
182 %files static
183 %defattr(644,root,root,755)
184 %{_libdir}/libcairo.a
185
186 %if %{with apidocs}
187 %files apidocs
188 %defattr(644,root,root,755)
189 %{_gtkdocdir}/cairo
190 %endif
This page took 0.075802 seconds and 4 git commands to generate.