]> git.pld-linux.org Git - packages/cairo.git/blob - cairo.spec
- added lt,am patches to fix build with current am and libtool 2.2
[packages/cairo.git] / cairo.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # disable gtk-doc
4 %bcond_with     glitz           # build with glitz backend
5 %bcond_without  xcb             # XCB backend
6 %bcond_with     tests           # perform tests (can fail due to out of memory)
7 %bcond_with     lcd             # freetype LCD filtering (instead of internal) [not ready]
8 #
9 Summary:        Cairo - multi-platform 2D graphics library
10 Summary(pl.UTF-8):      Cairo - wieloplatformowa biblioteka graficzna 2D
11 Name:           cairo
12 Version:        1.6.4
13 Release:        0.1
14 License:        LGPL v2.1 or MPL v1.1
15 Group:          Libraries
16 Source0:        http://cairographics.org/releases/%{name}-%{version}.tar.gz
17 # Source0-md5:  a198d509f9e3a35b78de8bb02174ebb9
18 Patch0:         %{name}-link.patch
19 Patch1:         %{name}-lt.patch
20 Patch2:         %{name}-am.patch
21 # Updated from http://david.freetype.org/lcd/cairo-1.2.4-lcd-filter-1.patch
22 # The lcd patch is being maintained at
23 # http://bugs.freedesktop.org/show_bug.cgi?id=10301
24 # It is not applied upstream for political reasons (patents) and its fate has
25 # not been decided yet AFAIK. -- Qrczak
26 # the latest version is for some early 1.5.x and won't be applied upstream to 1.6.x series
27 Patch3:         %{name}-1.2.4-lcd-filter-1.patch
28 URL:            http://cairographics.org/
29 BuildRequires:  autoconf >= 2.58
30 BuildRequires:  automake >= 1:1.8
31 BuildRequires:  fontconfig-devel
32 %{!?with_lcd:BuildRequires:     freetype-devel >= 1:2.1.10}
33 %{?with_lcd:BuildRequires:      freetype-devel >= 1:2.3.0}
34 %{?with_glitz:BuildRequires:    glitz-devel >= 0.5.1}
35 %{?with_apidocs:BuildRequires:  gtk-doc >= 1.6}
36 BuildRequires:  libpng-devel
37 BuildRequires:  libtool
38 BuildRequires:  pkgconfig
39 BuildRequires:  pixman-devel >= 0.10.0
40 BuildRequires:  poppler-glib-devel >= 0.8.0
41 %if %{with xcb}
42 BuildRequires:  libxcb-devel >= 0.9.92
43 BuildRequires:  xcb-util-devel >= 0.2
44 %endif
45 BuildRequires:  xorg-lib-libXrender-devel >= 0.6
46 BuildRequires:  zlib-devel
47 %{!?with_lcd:Requires:  freetype >= 1:2.1.10}
48 %{?with_lcd:Requires:   freetype >= 1:2.3.0}
49 %{?with_glitz:Requires: glitz >= 0.5.1}
50 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
51
52 %description
53 Cairo provides anti-aliased vector-based rendering for X. Paths
54 consist of line segments and cubic splines and can be rendered at any
55 width with various join and cap styles. All colors may be specified
56 with optional translucence (opacity/alpha) and combined using the
57 extended Porter/Duff compositing algebra as found in the X Render
58 Extension.
59
60 Cairo exports a stateful rendering API similar in spirit to the path
61 construction, text, and painting operators of PostScript, (with the
62 significant addition of translucence in the imaging model). When
63 complete, the API is intended to support the complete imaging model of
64 PDF 1.4.
65
66 %description -l pl.UTF-8
67 Cairo obsługuje oparty na wektorach rendering z antyaliasingiem dla X.
68 Ścieżki składają się z odcinków i splajnów kubicznych, a renderowane
69 mogą być z dowolną grubością i różnymi stylami połączeń i zakończeń.
70 Wszystkie kolory mogą być podane z opcjonalną półprzezroczystością
71 (podaną przez współczynnik nieprzezroczystości lub alpha) i łączone
72 przy użyciu rozszerzonego algorytmu składania Portera-Duffa, który
73 można znaleźć w rozszerzeniu X Render.
74
75 Cairo eksportuje stanowe API renderujące w duchu podobne do operatorów
76 konstruowania ścieżek, tekstu i rysowania z PostScriptu (ze znacznym
77 dodatkiem półprzezroczystości w modelu obrazu). Kiedy API zostanie
78 ukończone, ma obsługiwać pełny model obrazu z PDF w wersji 1.4.
79
80 %package devel
81 Summary:        Development files for Cairo library
82 Summary(pl.UTF-8):      Pliki programistyczne biblioteki Cairo
83 Group:          Development/Libraries
84 Requires:       %{name} = %{version}-%{release}
85 Requires:       fontconfig-devel
86 Requires:       freetype-devel >= 1:2.1.10
87 %{?with_glitz:Requires: glitz-devel >= 0.5.1}
88 Requires:       libpng-devel
89 %{?with_xcb:Requires:   libxcb-devel >= 0.9.92}
90 %{?with_xcb:Requires:   xcb-util-devel >= 0.2}
91 Requires:       xorg-lib-libXrender-devel >= 0.6
92
93 %description devel
94 Development files for Cairo library.
95
96 %description devel -l pl.UTF-8
97 Pliki programistyczne biblioteki Cairo.
98
99 %package static
100 Summary:        Static Cairo library
101 Summary(pl.UTF-8):      Statyczna biblioteka Cairo
102 Group:          Development/Libraries
103 Requires:       %{name}-devel = %{version}-%{release}
104
105 %description static
106 Static Cairo library.
107
108 %description static -l pl.UTF-8
109 Statyczna biblioteka Cairo.
110
111 %package apidocs
112 Summary:        Cairo API documentation
113 Summary(pl.UTF-8):      Dokumentacja API Cairo
114 Group:          Documentation
115 Requires:       gtk-doc-common
116
117 %description apidocs
118 Cairo API documentation.
119
120 %description apidocs -l pl.UTF-8
121 Dokumentacja API Cairo.
122
123 %prep
124 %setup -q
125 %patch0 -p1
126 %patch1 -p1
127 %patch2 -p1
128 %{?with_lcd:%patch3 -p1}
129
130 %build
131 %{?with_apidocs:%{__gtkdocize}}
132 %{__libtoolize}
133 %{__aclocal}
134 %{__autoheader}
135 %{__autoconf}
136 %{__automake}
137 %configure \
138         %{?with_apidocs:--enable-gtk-doc} \
139         %{?with_xcb:--enable-xcb} \
140         %{?with_glitz:--enable-glitz} \
141         --enable-ps \
142         --enable-pdf \
143         --enable-png \
144         --enable-freetype \
145         --with-html-dir=%{_gtkdocdir}
146 %{__make}
147 %{?with_tests:%{__make} check}
148
149 %install
150 rm -rf $RPM_BUILD_ROOT
151
152 %{__make} install \
153         DESTDIR=$RPM_BUILD_ROOT
154
155 %{!?with_apidocs:rm -rf $RPM_BUILD_ROOT%{_gtkdocdir}/cairo}
156
157 %clean
158 rm -rf $RPM_BUILD_ROOT
159
160 %post   -p /sbin/ldconfig
161 %postun -p /sbin/ldconfig
162
163 %files
164 %defattr(644,root,root,755)
165 # COPYING contains only notes, not LGPL/MPL texts
166 %doc AUTHORS COPYING ChangeLog NEWS README
167 %attr(755,root,root) %{_libdir}/libcairo.so.*.*.*
168 %attr(755,root,root) %ghost %{_libdir}/libcairo.so.2
169
170 %files devel
171 %defattr(644,root,root,755)
172 %attr(755,root,root) %{_libdir}/libcairo.so
173 %{_libdir}/libcairo.la
174 %{_includedir}/cairo
175 %{_pkgconfigdir}/cairo.pc
176 %{_pkgconfigdir}/cairo-ft.pc
177 %{_pkgconfigdir}/cairo-pdf.pc
178 %{_pkgconfigdir}/cairo-png.pc
179 %{_pkgconfigdir}/cairo-ps.pc
180 %{_pkgconfigdir}/cairo-svg.pc
181 %{?with_xcb:%{_pkgconfigdir}/cairo-xcb.pc}
182 %{_pkgconfigdir}/cairo-xlib.pc
183 %{_pkgconfigdir}/cairo-xlib-xrender.pc
184
185 %files static
186 %defattr(644,root,root,755)
187 %{_libdir}/libcairo.a
188
189 %if %{with apidocs}
190 %files apidocs
191 %defattr(644,root,root,755)
192 %{_gtkdocdir}/cairo
193 %endif
This page took 0.045092 seconds and 4 git commands to generate.