]> git.pld-linux.org Git - packages/cairo.git/blob - cairo.spec
- different pl translation of 'compositing'
[packages/cairo.git] / cairo.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # disable gtk-doc
4 %bcond_with     glitz           # build with glitz backend
5 %bcond_without  xcb             # XCB backend
6 %bcond_with     tests           # perform tests (can fail due to out of memory)
7 %bcond_without  lcd             # use own LCD filtering instead of freetype's
8 #
9 Summary:        Cairo - multi-platform 2D graphics library
10 Summary(pl.UTF-8):      Cairo - wieloplatformowa biblioteka graficzna 2D
11 Name:           cairo
12 Version:        1.4.10
13 Release:        1
14 License:        LGPL v2.1 or MPL v1.1
15 Group:          Libraries
16 Source0:        http://cairographics.org/releases/%{name}-%{version}.tar.gz
17 # Source0-md5:  5598a5e500ad922e37b159dee72fc993
18 Patch0:         %{name}-link.patch
19 # updated from http://david.freetype.org/lcd/cairo-1.2.4-lcd-filter-1.patch
20 Patch1:         cairo-1.2.4-lcd-filter-1.patch
21 URL:            http://cairographics.org/
22 BuildRequires:  autoconf >= 2.54
23 BuildRequires:  automake >= 1:1.7
24 BuildRequires:  fontconfig-devel
25 %{?with_lcd:BuildRequires:      freetype-devel >= 1:2.3.0}
26 %{!?with_lcd:BuildRequires:     freetype-devel >= 1:2.1.10}
27 %{?with_glitz:BuildRequires:    glitz-devel >= 0.5.1}
28 %{?with_apidocs:BuildRequires:  gtk-doc >= 1.3}
29 BuildRequires:  libpng-devel
30 BuildRequires:  libtool
31 BuildRequires:  pkgconfig
32 %if %{with xcb}
33 BuildRequires:  libxcb-devel >= 0.9.92
34 BuildRequires:  xcb-util-devel >= 0.2
35 %endif
36 BuildRequires:  xorg-lib-libXrender-devel >= 0.6
37 BuildRequires:  zlib-devel
38 %{!?with_lcd:Requires:  freetype >= 1:2.1.10}
39 %{?with_lcd:Requires:   freetype >= 1:2.3.0}
40 %{?with_glitz:Requires: glitz >= 0.5.1}
41 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
42
43 %description
44 Cairo provides anti-aliased vector-based rendering for X. Paths
45 consist of line segments and cubic splines and can be rendered at any
46 width with various join and cap styles. All colors may be specified
47 with optional translucence (opacity/alpha) and combined using the
48 extended Porter/Duff compositing algebra as found in the X Render
49 Extension.
50
51 Cairo exports a stateful rendering API similar in spirit to the path
52 construction, text, and painting operators of PostScript, (with the
53 significant addition of translucence in the imaging model). When
54 complete, the API is intended to support the complete imaging model of
55 PDF 1.4.
56
57 %description -l pl.UTF-8
58 Cairo obsługuje oparty na wektorach rendering z antyaliasingiem dla X.
59 Ścieżki składają się z odcinków i splajnów kubicznych, a renderowane
60 mogą być z dowolną grubością i różnymi stylami połączeń i zakończeń.
61 Wszystkie kolory mogą być podane z opcjonalną półprzezroczystością
62 (podaną przez współczynnik nieprzezroczystości lub alpha) i łączone
63 przy użyciu rozszerzonego algorytmu składania Portera-Duffa, który
64 można znaleźć w rozszerzeniu X Render.
65
66 Cairo eksportuje stanowe API renderujące w duchu podobne do operatorów
67 konstruowania ścieżek, tekstu i rysowania z PostScriptu (ze znacznym
68 dodatkiem półprzezroczystości w modelu obrazu). Kiedy API zostanie
69 ukończone, ma obsługiwać pełny model obrazu z PDF w wersji 1.4.
70
71 %package devel
72 Summary:        Development files for Cairo library
73 Summary(pl.UTF-8):      Pliki programistyczne biblioteki Cairo
74 Group:          Development/Libraries
75 Requires:       %{name} = %{version}-%{release}
76 Requires:       fontconfig-devel
77 Requires:       freetype-devel >= 1:2.1.10
78 %{?with_glitz:Requires: glitz-devel >= 0.5.1}
79 Requires:       libpng-devel
80 %{?with_xcb:Requires:   libxcb-devel >= 0.9.92}
81 %{?with_xcb:Requires:   xcb-util-devel >= 0.2}
82 Requires:       xorg-lib-libXrender-devel >= 0.6
83
84 %description devel
85 Development files for Cairo library.
86
87 %description devel -l pl.UTF-8
88 Pliki programistyczne biblioteki Cairo.
89
90 %package static
91 Summary:        Static Cairo library
92 Summary(pl.UTF-8):      Statyczna biblioteka Cairo
93 Group:          Development/Libraries
94 Requires:       %{name}-devel = %{version}-%{release}
95
96 %description static
97 Static Cairo library.
98
99 %description static -l pl.UTF-8
100 Statyczna biblioteka Cairo.
101
102 %package apidocs
103 Summary:        Cairo API documentation
104 Summary(pl.UTF-8):      Dokumentacja API Cairo
105 Group:          Documentation
106 Requires:       gtk-doc-common
107
108 %description apidocs
109 Cairo API documentation.
110
111 %description apidocs -l pl.UTF-8
112 Dokumentacja API Cairo. 
113
114 %prep
115 %setup -q
116 %patch0 -p1
117 %{?with_lcd:%patch1 -p1}
118
119 %build
120 %{?with_apidocs:%{__gtkdocize}}
121 %{__libtoolize}
122 %{__aclocal}
123 %{__autoheader}
124 %{__autoconf}
125 %{__automake}
126 %configure \
127         %{?with_apidocs:--enable-gtk-doc} \
128         %{?with_xcb:--enable-xcb} \
129         %{?with_glitz:--enable-glitz} \
130         --enable-ps \
131         --enable-pdf \
132         --with-html-dir=%{_gtkdocdir}
133 %{__make}
134 %{?with_tests:%{__make} check}
135
136 %install
137 rm -rf $RPM_BUILD_ROOT
138
139 %{__make} install \
140         DESTDIR=$RPM_BUILD_ROOT
141
142 %clean
143 rm -rf $RPM_BUILD_ROOT
144
145 %post   -p /sbin/ldconfig
146 %postun -p /sbin/ldconfig
147
148 %files
149 %defattr(644,root,root,755)
150 # COPYING contains only notes, not LGPL/MPL texts
151 %doc AUTHORS COPYING ChangeLog NEWS README TODO
152 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
153
154 %files devel
155 %defattr(644,root,root,755)
156 %attr(755,root,root) %{_libdir}/lib*.so
157 %{_libdir}/lib*.la
158 %{_includedir}/*
159 %{_pkgconfigdir}/*.pc
160
161 %files static
162 %defattr(644,root,root,755)
163 %{_libdir}/lib*.a
164
165 %files apidocs
166 %defattr(644,root,root,755)
167 %{_gtkdocdir}/cairo
This page took 0.03705 seconds and 4 git commands to generate.