]> git.pld-linux.org Git - packages/cairo.git/blob - cairo.spec
-devel BR: pixman-devel (from DEVEL)
[packages/cairo.git] / cairo.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # disable gtk-doc
4 %bcond_with     glitz           # build with glitz backend
5 %bcond_without  xcb             # XCB backend
6 %bcond_with     tests           # perform tests (can fail due to out of memory)
7 %bcond_with     lcd             # freetype LCD filtering (instead of internal) [not ready]
8 #
9 Summary:        Cairo - multi-platform 2D graphics library
10 Summary(pl.UTF-8):      Cairo - wieloplatformowa biblioteka graficzna 2D
11 Name:           cairo
12 Version:        1.6.4
13 Release:        0.1
14 License:        LGPL v2.1 or MPL v1.1
15 Group:          Libraries
16 Source0:        http://cairographics.org/releases/%{name}-%{version}.tar.gz
17 # Source0-md5:  a198d509f9e3a35b78de8bb02174ebb9
18 Patch0:         %{name}-link.patch
19 Patch1:         %{name}-lt.patch
20 Patch2:         %{name}-am.patch
21 # Updated from http://david.freetype.org/lcd/cairo-1.2.4-lcd-filter-1.patch
22 # The lcd patch is being maintained at
23 # http://bugs.freedesktop.org/show_bug.cgi?id=10301
24 # It is not applied upstream for political reasons (patents) and its fate has
25 # not been decided yet AFAIK. -- Qrczak
26 # the latest version is for some early 1.5.x and won't be applied upstream to 1.6.x series
27 Patch3:         %{name}-1.2.4-lcd-filter-1.patch
28 URL:            http://cairographics.org/
29 BuildRequires:  autoconf >= 2.58
30 BuildRequires:  automake >= 1:1.8
31 BuildRequires:  fontconfig-devel
32 %{!?with_lcd:BuildRequires:     freetype-devel >= 1:2.1.10}
33 %{?with_lcd:BuildRequires:      freetype-devel >= 1:2.3.0}
34 %{?with_glitz:BuildRequires:    glitz-devel >= 0.5.1}
35 %{?with_apidocs:BuildRequires:  gtk-doc >= 1.6}
36 BuildRequires:  libpng-devel
37 BuildRequires:  libtool
38 BuildRequires:  pixman-devel >= 0.10.0
39 BuildRequires:  pkgconfig
40 BuildRequires:  poppler-glib-devel >= 0.8.0
41 %if %{with xcb}
42 BuildRequires:  libxcb-devel >= 0.9.92
43 BuildRequires:  xcb-util-devel >= 0.2
44 %endif
45 BuildRequires:  xorg-lib-libXrender-devel >= 0.6
46 BuildRequires:  zlib-devel
47 %{!?with_lcd:Requires:  freetype >= 1:2.1.10}
48 %{?with_lcd:Requires:   freetype >= 1:2.3.0}
49 %{?with_glitz:Requires: glitz:Requires: glitz >= 0.5.1}
50 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
51
52 %description
53 Cairo provides anti-aliased vector-based rendering for X. Paths
54 consist of line segments and cubic splines and can be rendered at any
55 width with various join and cap styles. All colors may be specified
56 with optional translucence (opacity/alpha) and combined using the
57 extended Porter/Duff compositing algebra as found in the X Render
58 Extension.
59
60 Cairo exports a stateful rendering API similar in spirit to the path
61 construction, text, and painting operators of PostScript, (with the
62 significant addition of translucence in the imaging model). When
63 complete, the API is intended to support the complete imaging model of
64 PDF 1.4.
65
66 %description -l pl.UTF-8
67 Cairo obsługuje oparty na wektorach rendering z antyaliasingiem dla X.
68 Ścieżki składają się z odcinków i splajnów kubicznych, a renderowane
69 mogą być z dowolną grubością i różnymi stylami połączeń i zakończeń.
70 Wszystkie kolory mogą być podane z opcjonalną półprzezroczystością
71 (podaną przez współczynnik nieprzezroczystości lub alpha) i łączone
72 przy użyciu rozszerzonego algorytmu składania Portera-Duffa, który
73 można znaleźć w rozszerzeniu X Render.
74
75 Cairo eksportuje stanowe API renderujące w duchu podobne do operatorów
76 konstruowania ścieżek, tekstu i rysowania z PostScriptu (ze znacznym
77 dodatkiem półprzezroczystości w modelu obrazu). Kiedy API zostanie
78 ukończone, ma obsługiwać pełny model obrazu z PDF w wersji 1.4.
79
80 %package devel
81 Summary:        Development files for Cairo library
82 Summary(pl.UTF-8):      Pliki programistyczne biblioteki Cairo
83 Group:          Development/Libraries
84 Requires:       %{name} = %{version}-%{release}
85 Requires:       fontconfig-devel
86 Requires:       freetype-devel >= 1:2.1.10
87 %{?with_glitz:Requires: glitz-devel >= 0.5.1}
88 Requires:       libpng-devel
89 %{?with_xcb:Requires:   libxcb-devel >= 0.9.92}
90 Requires:       pixman-devel >= 0.10.0
91 %{?with_xcb:Requires:   xcb-util-devel >= 0.2}
92 Requires:       xorg-lib-libXrender-devel >= 0.6
93
94 %description devel
95 Development files for Cairo library.
96
97 %description devel -l pl.UTF-8
98 Pliki programistyczne biblioteki Cairo.
99
100 %package static
101 Summary:        Static Cairo library
102 Summary(pl.UTF-8):      Statyczna biblioteka Cairo
103 Group:          Development/Libraries
104 Requires:       %{name}-devel = %{version}-%{release}
105
106 %description static
107 Static Cairo library.
108
109 %description static -l pl.UTF-8
110 Statyczna biblioteka Cairo.
111
112 %package apidocs
113 Summary:        Cairo API documentation
114 Summary(pl.UTF-8):      Dokumentacja API Cairo
115 Group:          Documentation
116 Requires:       gtk-doc-common
117
118 %description apidocs
119 Cairo API documentation.
120
121 %description apidocs -l pl.UTF-8
122 Dokumentacja API Cairo.
123
124 %prep
125 %setup -q
126 %patch0 -p1
127 %patch1 -p1
128 %patch2 -p1
129 %{?with_lcd:%patch3 -p1}
130
131 %build
132 %{?with_apidocs:%{__gtkdocize}}
133 %{__libtoolize}
134 %{__aclocal}
135 %{__autoheader}
136 %{__autoconf}
137 %{__automake}
138 %configure \
139         %{?with_apidocs:--enable-gtk-doc} \
140         %{?with_xcb:--enable-xcb} \
141         %{?with_glitz:--enable-glitz} \
142         --enable-ps \
143         --enable-pdf \
144         --enable-png \
145         --enable-freetype \
146         --with-html-dir=%{_gtkdocdir}
147 %{__make}
148 %{?with_tests:%{__make} check}
149
150 %install
151 rm -rf $RPM_BUILD_ROOT
152
153 %{__make} install \
154         DESTDIR=$RPM_BUILD_ROOT
155
156 %{!?with_apidocs:rm -rf $RPM_BUILD_ROOT%{_gtkdocdir}/cairo}
157
158 %clean
159 rm -rf $RPM_BUILD_ROOT
160
161 %post   -p /sbin/ldconfig
162 %postun -p /sbin/ldconfig
163
164 %files
165 %defattr(644,root,root,755)
166 # COPYING contains only notes, not LGPL/MPL texts
167 %doc AUTHORS COPYING ChangeLog NEWS README
168 %attr(755,root,root) %{_libdir}/libcairo.so.*.*.*
169 %attr(755,root,root) %ghost %{_libdir}/libcairo.so.2
170
171 %files devel
172 %defattr(644,root,root,755)
173 %attr(755,root,root) %{_libdir}/libcairo.so
174 %{_libdir}/libcairo.la
175 %{_includedir}/cairo
176 %{_pkgconfigdir}/cairo.pc
177 %{_pkgconfigdir}/cairo-ft.pc
178 %{_pkgconfigdir}/cairo-pdf.pc
179 %{_pkgconfigdir}/cairo-png.pc
180 %{_pkgconfigdir}/cairo-ps.pc
181 %{_pkgconfigdir}/cairo-svg.pc
182 %{?with_xcb:%{_pkgconfigdir}/cairo-xcb.pc}
183 %{_pkgconfigdir}/cairo-xlib.pc
184 %{_pkgconfigdir}/cairo-xlib-xrender.pc
185
186 %files static
187 %defattr(644,root,root,755)
188 %{_libdir}/libcairo.a
189
190 %if %{with apidocs}
191 %files apidocs
192 %defattr(644,root,root,755)
193 %{_gtkdocdir}/cairo
194 %endif
This page took 0.085873 seconds and 4 git commands to generate.