]> git.pld-linux.org Git - packages/cairo.git/blob - cairo.spec
- partial up to 1.6.4
[packages/cairo.git] / cairo.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # disable gtk-doc
4 %bcond_with     glitz           # build with glitz backend
5 %bcond_without  xcb             # XCB backend
6 %bcond_with     tests           # perform tests (can fail due to out of memory)
7 %bcond_without  lcd             # use own LCD filtering instead of freetype's
8 #
9 Summary:        Cairo - multi-platform 2D graphics library
10 Summary(pl.UTF-8):      Cairo - wieloplatformowa biblioteka graficzna 2D
11 Name:           cairo
12 Version:        1.6.4
13 Release:        0.1
14 License:        LGPL v2.1 or MPL v1.1
15 Group:          Libraries
16 Source0:        http://cairographics.org/releases/%{name}-%{version}.tar.gz
17 # Source0-md5:  a198d509f9e3a35b78de8bb02174ebb9
18 Patch0:         %{name}-link.patch
19 # Updated from http://david.freetype.org/lcd/cairo-1.2.4-lcd-filter-1.patch
20 # The lcd patch is being maintained at
21 # http://bugs.freedesktop.org/show_bug.cgi?id=10301
22 # It is not applied upstream for political reasons (patents) and its fate has
23 # not been decided yet AFAIK. -- Qrczak
24 Patch1:         %{name}-1.2.4-lcd-filter-1.patch
25 URL:            http://cairographics.org/
26 BuildRequires:  autoconf >= 2.54
27 BuildRequires:  automake >= 1:1.7
28 BuildRequires:  fontconfig-devel
29 %{!?with_lcd:BuildRequires:     freetype-devel >= 1:2.1.10}
30 %{?with_lcd:BuildRequires:      freetype-devel >= 1:2.3.0}
31 %{?with_glitz:BuildRequires:    glitz-devel >= 0.5.1}
32 %{?with_apidocs:BuildRequires:  gtk-doc >= 1.3}
33 BuildRequires:  libpng-devel
34 BuildRequires:  libtool
35 BuildRequires:  pkgconfig
36 BuildRequires:  pixman-devel >= 0.10.0
37 BuildRequires:  poppler-glib-devel >= 0.8.0
38 %if %{with xcb}
39 BuildRequires:  libxcb-devel >= 0.9.92
40 BuildRequires:  xcb-util-devel >= 0.2
41 %endif
42 BuildRequires:  xorg-lib-libXrender-devel >= 0.6
43 BuildRequires:  zlib-devel
44 %{!?with_lcd:Requires:  freetype >= 1:2.1.10}
45 %{?with_lcd:Requires:   freetype >= 1:2.3.0}
46 %{?with_glitz:Requires: glitz >= 0.5.1}
47 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
48
49 %description
50 Cairo provides anti-aliased vector-based rendering for X. Paths
51 consist of line segments and cubic splines and can be rendered at any
52 width with various join and cap styles. All colors may be specified
53 with optional translucence (opacity/alpha) and combined using the
54 extended Porter/Duff compositing algebra as found in the X Render
55 Extension.
56
57 Cairo exports a stateful rendering API similar in spirit to the path
58 construction, text, and painting operators of PostScript, (with the
59 significant addition of translucence in the imaging model). When
60 complete, the API is intended to support the complete imaging model of
61 PDF 1.4.
62
63 %description -l pl.UTF-8
64 Cairo obsługuje oparty na wektorach rendering z antyaliasingiem dla X.
65 Ścieżki składają się z odcinków i splajnów kubicznych, a renderowane
66 mogą być z dowolną grubością i różnymi stylami połączeń i zakończeń.
67 Wszystkie kolory mogą być podane z opcjonalną półprzezroczystością
68 (podaną przez współczynnik nieprzezroczystości lub alpha) i łączone
69 przy użyciu rozszerzonego algorytmu składania Portera-Duffa, który
70 można znaleźć w rozszerzeniu X Render.
71
72 Cairo eksportuje stanowe API renderujące w duchu podobne do operatorów
73 konstruowania ścieżek, tekstu i rysowania z PostScriptu (ze znacznym
74 dodatkiem półprzezroczystości w modelu obrazu). Kiedy API zostanie
75 ukończone, ma obsługiwać pełny model obrazu z PDF w wersji 1.4.
76
77 %package devel
78 Summary:        Development files for Cairo library
79 Summary(pl.UTF-8):      Pliki programistyczne biblioteki Cairo
80 Group:          Development/Libraries
81 Requires:       %{name} = %{version}-%{release}
82 Requires:       fontconfig-devel
83 Requires:       freetype-devel >= 1:2.1.10
84 %{?with_glitz:Requires: glitz-devel >= 0.5.1}
85 Requires:       libpng-devel
86 %{?with_xcb:Requires:   libxcb-devel >= 0.9.92}
87 %{?with_xcb:Requires:   xcb-util-devel >= 0.2}
88 Requires:       xorg-lib-libXrender-devel >= 0.6
89
90 %description devel
91 Development files for Cairo library.
92
93 %description devel -l pl.UTF-8
94 Pliki programistyczne biblioteki Cairo.
95
96 %package static
97 Summary:        Static Cairo library
98 Summary(pl.UTF-8):      Statyczna biblioteka Cairo
99 Group:          Development/Libraries
100 Requires:       %{name}-devel = %{version}-%{release}
101
102 %description static
103 Static Cairo library.
104
105 %description static -l pl.UTF-8
106 Statyczna biblioteka Cairo.
107
108 %package apidocs
109 Summary:        Cairo API documentation
110 Summary(pl.UTF-8):      Dokumentacja API Cairo
111 Group:          Documentation
112 Requires:       gtk-doc-common
113
114 %description apidocs
115 Cairo API documentation.
116
117 %description apidocs -l pl.UTF-8
118 Dokumentacja API Cairo.
119
120 %prep
121 %setup -q
122 %patch0 -p1
123 %{?with_lcd:%patch1 -p1}
124
125 %build
126 %{?with_apidocs:%{__gtkdocize}}
127 %{__libtoolize}
128 %{__aclocal}
129 %{__autoheader}
130 %{__autoconf}
131 %{__automake}
132 %configure \
133         %{?with_apidocs:--enable-gtk-doc} \
134         %{?with_xcb:--enable-xcb} \
135         %{?with_glitz:--enable-glitz} \
136         --enable-ps \
137         --enable-pdf \
138         --enable-png \
139         --enable-freetype \
140         --with-html-dir=%{_gtkdocdir}
141 %{__make}
142 %{?with_tests:%{__make} check}
143
144 %install
145 rm -rf $RPM_BUILD_ROOT
146
147 %{__make} install \
148         DESTDIR=$RPM_BUILD_ROOT
149
150 %{!?with_apidocs:rm -rf $RPM_BUILD_ROOT%{_gtkdocdir}/cairo}
151
152 %clean
153 rm -rf $RPM_BUILD_ROOT
154
155 %post   -p /sbin/ldconfig
156 %postun -p /sbin/ldconfig
157
158 %files
159 %defattr(644,root,root,755)
160 # COPYING contains only notes, not LGPL/MPL texts
161 %doc AUTHORS COPYING ChangeLog NEWS README
162 %attr(755,root,root) %{_libdir}/libcairo.so.*.*.*
163 %attr(755,root,root) %ghost %{_libdir}/libcairo.so.2
164
165 %files devel
166 %defattr(644,root,root,755)
167 %attr(755,root,root) %{_libdir}/libcairo.so
168 %{_libdir}/libcairo.la
169 %{_includedir}/cairo
170 %{_pkgconfigdir}/cairo.pc
171 %{_pkgconfigdir}/cairo-ft.pc
172 %{_pkgconfigdir}/cairo-pdf.pc
173 %{_pkgconfigdir}/cairo-png.pc
174 %{_pkgconfigdir}/cairo-ps.pc
175 %{_pkgconfigdir}/cairo-svg.pc
176 %{?with_xcb:%{_pkgconfigdir}/cairo-xcb.pc}
177 %{_pkgconfigdir}/cairo-xlib.pc
178 %{_pkgconfigdir}/cairo-xlib-xrender.pc
179
180 %files static
181 %defattr(644,root,root,755)
182 %{_libdir}/libcairo.a
183
184 %if %{with apidocs}
185 %files apidocs
186 %defattr(644,root,root,755)
187 %{_gtkdocdir}/cairo
188 %endif
This page took 0.113492 seconds and 4 git commands to generate.